PDA

View Full Version : BF4 Maxing out at 60FPS with G-Sync



RockSteadyYeti
12-15-2014, 06:57 PM
Hey All,
So first post on the forum, sorry if I don't get it right. Man I am going crazy trying to figure this one out, I just got my Swift setup and when it is working right its amazing. Here is what is going on.

When i get in game my FPS counter will be pegged at 60FPS. The only way to fix it is to got to the Video settings and pick another hrtz setting and then safe and then go back to 120 or 144. Then I start getting FPS over 60. With G Sync off I get better FPS all the time and do not need to reset anything in game to get the right FPS. Here is what I have done
1) Installed Swift Driver
2) Reinstalled fresh new video drivers
3) Make sure the turbo button is set to 120 or 144
4) In Nvidia Control Panel G sync is enabled.
5) Went to game video settings and made sure the Sync setting was G sync not V sync.



I still have to change teh video settings to get the right Hrtz and in turn the right FPS. It also happens that if I have alt-tab out the video settings go back to 60 Hertz. Please HELP!! Does anyone have the same issue? I can try some other games, but I really don't care about anything besides BF4...
Thanks!!!

Windows 8.1 64
2600k @ 4.8 Custom H20
780ti Stock Newest Video Drivers
Evo SSD Raid 0
Rampage MB

zimzoid
12-15-2014, 10:07 PM
Hi, are you sure that Vertical sync in nv control panel/manage 3D settings is set to gsync? and not just enabled in the display/enable G-Sync, also in the game settings make sure v-sync is set to OFF

RockSteadyYeti
12-17-2014, 07:05 PM
sync is set to G sync and Vsync is turned off in game. I reinstalled all drivers for Video Card and Monitor, and installed another game to test, Insurgency (I AM A FPS ADDICT :D ). Insurgency acted the same. Only thing that seems different now is the manual Hrtz button on the monitor seems to work now, when I change it the FPS climb in game. I really dont want to have to hit a button everytime I alt-tab out of a game or start one up. It feels like it is picking the Hrtz up from my desktop settings. Is there a way to force 144 hrtz at all times in OS and games? I will do some googling on that today. Has anyone else had this issue? Thanks for the help!! I can never go back to 60 hrtz now!

Volt
12-17-2014, 09:53 PM
I think you can just cycle the button and leave it at 144. That's how I have mine. It remains that way after shutting down my computer/monitor for the night and then starting it up the next day.

seallone
12-19-2014, 08:45 PM
There is a setting in NV control panel. Something called choose max refresh rate. Set that to max. see if that helps'

Opie
12-21-2014, 04:03 PM
I'm having a a similar issue.

I just moved from Win7 to a new build with a Rampage V and Win 8. The Swift will not go to 144hz without manual intervention (i.e., the monitor button which reacts VERY slowly) no matter what the NV control panel says. This was not an issue with Win 7.

Seems like if you set it a particular refresh rate it should stay.

RockSteadyYeti
01-10-2015, 06:45 PM
Thank YOU All who said set the max refresh rate in Nvidia control panel, THAT DID IT!!!! I think this can be locked as that is the fix!!