PDA

View Full Version : ROG G751JT Battery does not charge, DOA?



Rulzern
12-16-2014, 06:06 PM
I have recently purchased a G751JT laptop, but it appears the battery does not charge at all. Windows reports "Plugged in, 53%, charging" (or 0%).
powercfg /batteryreport shows that the battery does not report anything (the fields in the HTML report are empty). Unplugging the power leads to the computer immidiately shutting down.

In addition, sometimes the battery LED will flash orange and green, but unplugging the power supply from the wall (not the laptop) and plugging it back in again after a minute resolves this issue (returns it to a solid orange).

Also, I have tried the following:
- Charging the computer overnight with it turned off, no effect
- Different wall outlets, no effect
- Turning off/on power saving features in the power plan in windows, no effect
- Making sure all connectors are firmly in place, no effect

Is the problem the PSU or the battery? Are there any things I can try?

Thank you.

Darnassus
12-16-2014, 06:08 PM
Try charge the battery with the unit turned off. If it fully charges at the reasonable time it should, then I have a feeling it's the power supply..

I'm not 100% certain, it's just a guess.

Rulzern
12-16-2014, 06:11 PM
Thank you for your answer, I have unfortunately already tried it, and the battery is still as dead.