PDA

View Full Version : Elite:Dangerous crashes on start on G20



icwhatudidthere
12-17-2014, 08:17 PM
Just picked up a brand new G20 last night for Elite: Dangerous and eventually Star Citizen. Went to try Elite: Dangerous and it crashes instantly. This was after turning the machine on and doing a Windows update and NVidia driver update. The Single Player Combat Demo runs well though.

Just wanted to put this thread out there to see if anyone else has seen the problem and for future reference as well. There are apparently others on Frontier's own forums who are having similar problems of instant crashing.

ETA: I have the GTX 760 model with 16GB from Best Buy.

Carl

toronto699
12-17-2014, 08:59 PM
http://rog.asus.com/forum/showthread.php?53630-NEED-HELP-with-my-ROG-G20AJ
the posts above sound like your problem , return your unit is what I would do. see the post below yours in the G series thread,
http://rog.asus.com/forum/showthread.php?54931-G20AJ-blue-screen-of-death-problems-on-wake-up-Virtu-Watt-error
I would return your G20 for another one ASAP!!!!!!!!!

icwhatudidthere
12-18-2014, 04:11 AM
Don't think it's that serious. I have actually gotten things working. It looks like there's something wrong with the software bloat that Asus installs by default. Really disappointing TBH. I killed all background processes except for standard Windows ones and all my games start up ok. Now comes the fun part of figuring out which one causes the problem.

Adam_1701
02-01-2015, 07:27 PM
Did you ever figure out which one caused the crash? I'm having the same issue, where the demo runs, but not the Elite Dangerous itself; crashes instantly when pressing play. I thought I had it solved by modifying launcher permissions to full, but now it's crashing again after the latest update.

toronto699
02-01-2015, 07:52 PM
I returned 2 G20 that had BSODs right out of the box , and bought an Alienware X51 instead, I posted questions on the Alienware forum before I made my decision to buy the X51

icwhatudidthere
02-02-2015, 05:07 AM
Yes, it's the VirtuWatt stuff. I now turn it off before playing any game at all. Everything works once it's disabled.

Adam_1701
02-02-2015, 06:53 PM
Disabling VirtuWatt solved it. Thank You! :D

KyleJamesMod
02-02-2015, 08:10 PM
I also have purchased the g20 from best buy. The first time I bought one i went with the i5 8gb model. Thing crashed so much, had some weird start-up issues where it would get stuck on the asus screen right on boot-up. I returned it and purchased the more powerful i7 model with the 16 gigs...so far no real issues. I noticed the fans act different then the last model, sometimes it sounds like ocean waves when its updating and bothers me. Its still very quiet and doesn't get to loud. I guess what im wondering is if i should purchase the warranty from best buy on it. I also own a Lenovo y50 that is awesome haven't had any issues worth it but for some reason this mini desktop makes me want to purchase a warranty, last one i had was so "sketchy" for lack of better words. Also i noticed if you do all windows update then Nvidia Drivers the computer works alot more efficiently.