View Full Version : G751JT bricked my Corsair GS 240GB SSD

12-18-2014, 11:45 PM
Purchased the G751JT earlier this month and finally got an SSD for it. I used Corsair's SSD Toolbox to do a clone from the original 1TB HDD the laptop came with.

I thought the clone went well, until I tried to install a program. I didn't even get to the prompt when Windows Explorer crashed. I did a Ctrl+Alt+Del to try to shut down and it told me it wasn't available (wtf?). I don't remember the exact wording, but I had never seen anything like that.

I could not shut down normally, so I forced a shutdown. When I turned the laptop back on, after a minute, it went to the BIOs since I had disabled all other boot options except for the SSD. I did not even see the SSD as a bootable option anymore. I opted to just boot to the original HDD and see what happened. My laptop does not read the SSD at all. I tried changing some settings in the BIOs and even updated the firmware, but nothing helped. I pulled it out and had my husband put it in his computer to see if his computer could see it; no such luck.

He tried rebooting his computer with the SSD connected, and it wouldn't let him boot. He unplugged the SSD and he was able to boot normally. Since I just recently purchased it from Amazon, they are sending me a replacement and I am shipping this one back as defective. But I seriously don't know what the heck happened.

Has anyone had issues like this? I've been hearing a lot of crap about Backtracker (I won't even go there), but has anyone tried cloning to a Corsair SSD with the Corsair Toolbox with any G751?

Guess I should also check out Corsair's forums for any information.