PDA

View Full Version : G74S BluRay Playback = Black Screen, only BluRay audio plays?



skyway666
11-03-2011, 02:04 AM
Hi Folks,

I have just purchased a G74S and have a problem which I am feeling is probably well experianced, though I could not find any answers within the forum, please excuse if there is something i missed.

Here is my problem, I am unable to play BluRay movies, I have tried several discs and they all give me the audio, but not video. Is this something known? It has not worked yet. so I dont think i have broken it.

Any help greatly appreciated.

dstrakele
11-03-2011, 02:58 AM
Here is a thread with an issue similar to yours: http://www.avsforum.com/avs-vb/showthread.php?t=1084682

I don't know if it will help you, but it does sound like a software issue rather than hardware.

Does your G74SX ODD play DVD video?

Are you attempting to play the disc on a TV, second monitor , or your laptop display?

What software/version are you using to play the Blu-Ray disc?

Did you choose the correct disc format in this software?

Have you tried any other Blu-Ray playback software?

Since you just got a new system, I'd be tempted to go to the retailer (if possible) with some Blu-ray discs and see if they play on the display model. If yes, see if they will exchange your system for another one without the issue.

gusto
11-03-2011, 11:41 PM
ok. i have the same problem it's a software issue! there is no fix that i know of if you find one please post it. here is a temp fix or a way around it if your only getting audio. eject you blu-ray, close the restart roxio cineplayer with no disc in drive. after it starts insert any dvd let boot up if you get video stop the dvd, eject and insert your blu-ray don't close or restart the roxio bam now you have video with your blu-ray. sometime you will have repeat closing and restarting this crap with a dvd until it starts working.

dstrakele
11-04-2011, 01:55 AM
I'm running Roxio CinePlayer BD version 5.8.A06 build 582B47A, the release included with my G74SX-A1. I've noticed on startup, if I select any menu items, it would report "This output type is not supported on the current machine, please select a new one." I've found I can eliminate this error dialog if I go to "Settings - 3D" and set "Enable 3D Processing" from AUTOMATIC to OFF.

I suspect there may be a problem with the automatic setting to enable 3D processing in this version. I believe it always automatically detects a 3D disc regardless of what you put in the tray. I also suspect gusto's workaround of replacing the Blu-Ray disc with a DVD and closing/restaarting eventually allows the automatic setting to choose 2D.

I know I now can play 2D DVD's without any problems. Unfortunately, cheap luddite that I am (I play on my laptop by candlelight), I don't even own a Blu-Ray disc to check this settings change workaround. Perhaps some good samaritan can let us know if it resolves this Blu-Ray video issue with the Roxio CinePlayer?

ScottinSoCal
11-04-2011, 01:52 PM
let us know if it resolves this Blu-Ray video issue with the Roxio CinePlayer?

I'm getting mine today, it turns out Newegg shipping is a lot faster than I expected, and I'll check it with a blu ray disc. If I get the black screen problem I'll try the setting change and see if that does anything.

Although I'm not getting the 3D unit, so it may have a different version of the playback software, or have that feature disabled by default. So my answer may not help you at all. Just a warning in advance.

JRd1st
11-04-2011, 02:08 PM
You know, next time you install an nVidia driver, you can just do a custom install and not install the 3D thing if you know you'll never use it. Who knows what that stuff does even if it's disabled. lol