View Full Version : Anyone tried v14.12 for AMD Radeon 5870 on G73JH

12-25-2014, 02:30 AM
Hey There - I hear a lot of stuff from 2010 about the G73JH - but my 6gb / i7 still manages to be a comparable machine to run stuff on. Its about 8 months since i used it - but i got it going just fine - except for i updated the video drivers and wham - gsod issues (I never had them before).

I see a lot about the vBios and so forth upgrading. I pulled out my old G73JH and tried to get it going with WOW again - wow complains about a video driver update, which is fine, but when I update the AMD Radeon 5870 drivers to the latest - i get all sorts of fun stuff (BSD on install, fixed with bios 213 upgrade), and GSOD about 5 mins into gaming. (It all starts ok). I have also had the driver crash a few times with just regular use. (browsing etc).
I thought it was heat - but Asus GPU Tweak, HW Info and a few others all hang when trying to run.

So my question is -
a) what is the latest driver anyone has running for the Radeon 5870 on G73JH -
b) what is the right vBios version (I see lots of upgrading notes but no explicit version - and links to rar files are suspecct)
c) anything else to upgrade ?
d) has anyone else got WOW / Warlords of Draenor to run without whining on their G73JH?

I also noticed trying to download some of the rar files for vbios on links in posts set my anti virus warnings off - b ware.


12-25-2014, 07:22 PM
I have 13.9 Catalyst on my G73jh A1. I have OD2 vBios on the ATI 5870. That was the last version, (and the best in my opinion.) I haven't tried updating the Catalyst driver since, but don't really have the need.

12-25-2014, 10:42 PM
Thank you - ill try the vbios upgrade again (OD2 v93) and try downgrading to 13.9 - thanks again.

12-25-2014, 11:35 PM
Let me know if you can't find a good virus free download. My file is called "Asus G73jh Notebook.zip" and is 173,957,026 bytes. MD5 checksum is 72fe2920a9d126a0f4299888327c04ca
It contains all of the vBios's including the OD2, and the auxillary files needed.

Then test your current Catalyst, it may work with this vBios. ;)