PDA

View Full Version : Front lights and touchpad stopped working after sending it to service center



Lakshaya
11-04-2011, 10:58 PM
Hi all,

I bought my G73 June 2010 in the US and took it back home with me to India. I had some problems with overheating and the display breaking (white screen, colored lines), which were solved by contacting the local service center in Delhi. I got stuff fixed there several times no problem. Then one day my sister dropped my laptop from a table (...)and severely damaged the body. Note that only the body and the battery was damaged, and even after I tried switching it on after this everything worked completely fine. I sent it to the same service center to fix this, and they took around one month to order the complete body parts for my ASUS, which is understandable since ASUS doesn't sell this product in India. When I got it back...the laptop looked completely new...except that the touchpad and the front lights stopped working. So did the overdrive button and the ones next to it..which is funny because they all were working before I gave it to the service center to replace the body. I called the service center and complained, and they said that they would fix it...but they didn't do so and the time came that I had to leave for college. I took the laptop from them and came here with it, and its still perfectly usable except I need a mouse to use it. .

Now... I want to get this fixed once and for all. I recently flashed the BIOS to 211, and I want to get the VBIOS up to date as well since I want to play Battlefield 3. If someone from ASUS can assist me with what to do here, I'm completely unsure of how servicing works here. I want to get my touchpad and everything fixed, and I also want ASUS to flash my VBios. Is it possible? How? I'm in philadelphia. Help would be appreciated.

dstrakele
11-04-2011, 11:04 PM
Check "Uninstall or change a program" in Control Panel. If there is no ATK Package, download ATK Package 1.00.0014 and install it. Reboot, then try Fn-F9 to enable the touchpad. If you DO see an ATK Package, I recommend you uninstall it - reboot - and install ATK Package 1.00.0014.

You may also need to install the latest touchpad driver for your laptop. Do you have a Synaptic or Sentelic touchpad? See http://www.asusrog.com/forums/showthread.php?1150-G73-74-53-Series-Driver-and-Application-Reference to obtain the ATK Package and recent Touchpad drivers.

http://www.asusrog.com/forums/showthread.php?519-G73Jh-GSOD-Vbios-Update discusses how to perform the G73 vBIOS update. Since you flashed your BIOS already, I think you can follow the directions and perform this flash as well.

Lakshaya
11-04-2011, 11:20 PM
Hey,

I did all you asked. It didn't work. I'm pretty sure all of this is not a driver issue, and something the technicians messed up back when they were trying to install a new body on my G73. Also, is that the latest VBIOS there is? If not i'll flash VBIOS right now.

dstrakele
11-04-2011, 11:32 PM
I see there is also a G73 Keyboard / Trackpad Fix NEW! on http://www.asusrog.com/forums/showthread.php?1150-G73-74-53-Series-Driver-and-Application-Reference Give that a try...

The v93 vBIOS is the latest one I know about (but what I don't know could fill volumes), so you might wait for some more knowledgeable folk to reply. It looks like there are 2 v93 vBIOS choices - pick yer poison!