PDA

View Full Version : Crazy fps drops in bordlerands 2 g751jy



Boom_austin
01-08-2015, 09:35 PM
This is not isolated to asus laptops but i thouight i would throw up a post here to see if anyone else is having issues.

the issue as hand that im having is im having crazy fps drops in borderlands 2 when physX turned on high. on my previous laptop (g75vx) running either windows 7 or 8 it seemed to perform much better. although i dont remember the settings i was using whatever geforece expierence recommended.

the fps drops go from 100fps all the way down to 23 on periods where im killing a few guys (3-4). this makes little sense to me because my old laptop with a 3630qm and a gtx670mx runs the game better than my new 4710hq and a gtx980m.

it seems to be related to physX. the physX is being process by my gpu so its not a cpu issue. also neither the 980m or the 4710 is running near max load. cpu is around 50% gpu around 60-70%. no thermal throttling is in effect.

all of my drivers are up to date that i know of. forsure the gpu drivers and the bois are as new as is out there.

any ideas on what might help anyone?

im also going to add that this isnt a pc issue because i can run the pre sequal fine and always stay above 60 fps with physX maxed out same with the rest of the settings. also other games run just fine like skyrim (with graphic enhancing mods) hell even wolefenstien the new order (freaking beautifil game) runs so well. there isnt many things to change but my fps is locked at 60 and wont budge no matter whats going on in game.

NitroX
01-08-2015, 10:01 PM
Hmm, it may be a problem with the game or an incompatibility between the new nvidia drivers and the Borderlands 2 which is older. The fact that GTX980M is quite new in both arhitecture and on the market may cause some troubles with older games.
Try changing the settings in your Nvidia Control Panel--> Manage 3d Settings ---> Choose Borderlands 2 ---> Put Power Management on Full Performance (or whatever it says) . And you should also go to the Physx settings in Nvidia control panel and select your GPU for Phyx because the game may change between CPU and GPU to process physx.
Try these out and see if something changes.

Boom_austin
01-08-2015, 10:07 PM
haha believe it or not i just tried what you said and the performance almost seemed worse :P i was at 50 fps just running to a read with enimies :P

BigDRim
01-08-2015, 10:11 PM
It is just PhysX. It's the same with Batman Arkham games.

Boom_austin
01-08-2015, 10:15 PM
i understand its the physX :P that much was obvious because i shut it off and the framerate improves some. i was really hoping to run it with physX because it looks damn awesome with it on. i guess that may not be possible its so strange even 2 gtx titans sli cant even run it at a good fps with physX on and yet much older cards can

BigDRim
01-09-2015, 04:28 PM
I think nvidia doesn't really care of physX. There are so few games using it.

Boom_austin
01-09-2015, 04:59 PM
darn haha :P