View Full Version : G74S "Fresco Logic USB3 Host Controller is not found!" - request for assistance

01-13-2015, 11:14 AM
My Windows 7 Home Premium no longer detects the Fresco Logic (FL) 1000 PCIe - USB3 chip.

I have researched and tried the many remedies that other people have claimed to have fixed the same problem on their G74S laptops, all to no avail.

I have a theory that the PCIe table associated with my FL chip has been changed so the Vendor Id is now 8086 (Intel) and the Device ID is a 6 Series/C200. I believe the Vendor and Device Id codes should be 1B73 (Fresco Logic) and 1000 respectively and that once these values are reset, the proper driver can be installed.

I am appealing for co-operative assistance from tech savvy owners of ASUS G74S laptops that have working USB3 port and other tech savvy owners who are experiencing the same USB3 problem.

Can anyone help me with the following?

Those with working USB3 - confirm the device PCIe address is - bus 0, device 28, function 0 (found via its properties in Device Manager.

Those with non working USB3 - confirm there is a spare device PCIe device whose PCIe address is - bus 0, device 28, function 0 (found via its properties in Device Manager).

Further, for those with working USB3

Obtain a copy of the PCIe control table content. It can be found by downloading the bootable iso image of freeware PCI Sniffer program (from http://www.majorgeeks.com/files/details/pcisniffer.html), creating a bootable CD and then using the CD to boot the laptop and study what the sniffer reports for 0/28/0. A digital image taken by camera would be a good way of taking the screenshot as it is running under DOS.

If anyone can assist but feels that they are not tech savvy then I can give more detailed instructions as to go about the above tasks.

Lastly, if anyone has cured this problem along the lines of my fact gathering I would be interested in hearing from you.

My onward efforts will be reported in this forum thread.

Thanks in Anticipation


A Guy
04-17-2016, 06:18 PM
I have a related issue. I seldom plug in my USB3 devices (external hard drive I use for backups) but I use USB2 every day.

Some days my external devices (mostly keyboard and mouse) do not work. Sometimes if I let it sit for a few minutes before logging in (or poking them) there is the USB connect sound and they work.
The thing that always works though is to log in, right click on My Computer and select manage. Enter an admin pw (I seldom log in as admin and use an account with reduced permissions). Then under Device Manager I disable the USB device that has a problem, wait a few seconds and then re-enable it. Sometimes both are messed up.

While not fixing the problem it is a reasonable work-around. In searching for a real fix I have tried any number of drivers, but none solved the issue.