PDA

View Full Version : GPU Tweak Not Applying Overclock to ASUS GeForce GTX 970



Blackout_STi
01-19-2015, 03:10 AM
So I just built a new rig, and I am attempting to OC my 970. But GPU Tweak refuses to apply my OC for whatever reason. Never had this issue before, but this card is new to me.

Specs of my rig are listed on my profile: https://rog.asus.com/forum/member.php?174044-Blackout_STi

This is a fresh install. I installed my drivers and utilities from the Maximus VII Hero install disc. I have some other programs installed like Corsair Link v2. I have the latest nVidia drivers (stable) installed. I did not install some of the unneccessary utilities from the Hero install disc (like 'ASUS Web Storage').

One quick note, I have tried the last 3 versions of GPU Tweak. None of them would apply the clock. I noticed the "Overclocking Range Enhancements" is missing from my settings menu in GPU Tweak (all three versions). GPU Tweak is showing my Strix 970 on it's UI.

Just as a theory, I reset my BIOS to default (and re-disabled 'Legacy USB 2.0 Support' so my H100i would register). Other than that, nothing is implementing any non-default settings. I do have ASUS AI Suite III installed from the Hero install disc. But I reverted all '5-Way Optimization' and 'Fan Xpert' adjustments when I reset the BIOS. I checked.

Anyways, what do I do? How can I figure out why the overclock isn't applying? I have never had to do this before. I am (admittedly) an amateur when it comes to overclocking. This rig is more than I have ever had as far as hardware. Can anyone with superior knowledge and skill tell me how to go about fixing this ?

Blackout_STi
01-19-2015, 08:21 PM
I forgot to set the 'Power Plan' in Windows. Derp. Also, I needed to switch to 'Advanced' mode in GPU Tweak. This fixed my problem.