PDA

View Full Version : G75VW DVD Drive Failed?



Aliasmk
01-27-2015, 06:02 AM
To add to the list of problems with my 2 year old G75VW (see this (https://rog.asus.com/forum/showthread.php?55556-FINALLY-The-G75VW-Random-Shutdown-Mystery-Solved) and this (https://rog.asus.com/forum/showthread.php?32428-Problem-with-VirtualBox)), within the past 2 weeks I believe my DVD Drive has failed.
For all 3 DVD's I have after putting it in the drive it clicks and wrrs, but it doesn't ever show up in My Computer, nor can I boot from it. The one CD I have works however.
No warnings or error in device manager. Is this something fixable, or is my $1500 computer slowly becoming a paperweight?

EDIT: The CD works, but only barely. Reads just enough to show up in my computer but as soon as I try browse it, it just clicks and wrrs again. This is so weird. I've never seen anything like it.

EDIT2: I recently updated to the 223 bios, but the problem started after that. There is no way to downgrade bios.

EDIT3: Got a new CD to test (I'm away from home so I dont have many test disks) and it worked perfectly. Gonna get my hands on another DVD to see if the problem persists, maybe it was just a fluke.

Aliasmk
02-12-2015, 12:32 AM
No one has had this problem? Should I supply any more information?

GrecoISU
02-15-2015, 01:44 PM
Mine shows up but doesn't normally recognize anything I put into it. I also have a G75VW.

Aliasmk
02-15-2015, 11:21 PM
Mine shows up but doesn't normally recognize anything I put into it. I also have a G75VW.

Did that just start happening for you? Or has it always been that way?

Aliasmk
02-26-2015, 03:56 PM
Okay, so I have an update. I got a new music CD from my girlfriend for Valentines Day (<3). I decided to try to import it to my G75, and it reads perfectly. Not even a stumble, no clicking, nothing, just read it just like it did when the computer was new.
I don't understand why my other disks didn't work. The CD has worked before in my G75 and all the disks I tested worked fine when I put them into my Macbook Pro. So the disks arent unreadable, my G75 seems to just not like them for some reason.

cl-Albert
02-26-2015, 04:44 PM
Unfortunately, I'm not an expert on this and it may not help, but I remember hearing a few people say cleaning the lasers in the Optical Drive was able to help with some issues, so one thing to look into (check your DVD drive for any obvious problems and try searching these forums for more information?).

Also, doesn't sound like a software or Windows issue, but you may want to try to boot to a disk, test it in Windows Safe Mode, or out of Windows just to eliminate the possibility of any software issues if you think it's worth the effort.

Good luck!

Aliasmk
03-02-2015, 04:50 PM
I did basic cleaning with an air duster, but i have a feeling that there is a bigger problem with the drive. I took the drive out and discovered that it was a SATA drive so I'll be hooking it to another computer to make sure that it is the drive that is failing and not the computer (due to the bios update).

Tried booting to disk but computer did not like it; clicked and wirred even before the "Starting Windows" screen popped up, and when I overrided to boot to my linux live DVD the drive clicked and wirred before saying that there was no suitable boot media.

If it turns out that the drive works on other computers, I'll assume that it was the bios and take steps to restore it back.. which apparently is risky using Winflash.
I'm pretty sure its the drive though, the timing between the update and the drive failing is just a little bit off... I seem to remember it working at a point after upgrading the bios.

Will update again after pulling the drive and testing it elsewhere.

BrandeX
03-18-2015, 12:34 PM
Mine crapped out too.