View Full Version : G74sx - Installed new WiFi card (INTEL AC 7260), now, no WiFi card working [solved]

01-27-2015, 04:32 PM

I bought a new WiFi card for my G74sx (Windows 7), an Intel Dual Band Wireless AC 7260.

Uninstalled the old card (Qualcomm Atheros AR9002WB-1NG) and replaced it with the new card.

Installed drivers for the new card, as found on Intels drivers page, aaand ... it didn't work.

It showed up as working when checking it out in Device manager and Network and sharing center. But when I was going to check for networks it didn't show anything.

I searched around this forum and many others for a fix, but found nothing. So I changed back too the old card, with the same drivers as I originally had, and the same thing happens.

So now I can't connect to my WiFi at all, and i'm a tad bit confused about what to do.

I thought that maybe something went wrong with the antennas when i swapped card, but i checked them and, as according to my abilities, they look fine. Anyone know if i can check them in any other way?

When I run the Windows Network Diagnostics tool it says:


I currently have the Atheros card installed, with the latest drivers I found (picture below), and this is some pictures as to how it looks.





I can swap cards and troubleshoot that one in case anyone has the time to help me, or knows what might be the problem.

Thanks in advance.

01-27-2015, 07:56 PM
Did intel proset wireless install? If it did then it's managing your wireless networks instead of windows.

01-27-2015, 10:47 PM
Thanks for the reply.

Yes, it did. But I uninstalled it since I didn't think i would need it. Is there something you know I could do, to check if there could be a residual problem?

01-27-2015, 11:54 PM
Intel Proset Wireless (IPW) can cause issues.

I would uninstall everything you recently installed with the new hardware. Then reinstall with the defaults. Leave IPW installed, go into the program and tell it to use windows to manage networks. Also make sure you can see your available wireless networks in IPW before you switch the setting.


I've ran into similar problems with Dell laptops and leaving IPW installed is the only way to make it work correctly.

If that doesn't work then boot into safemode, use system restore, after system restore completes and reboots use this file to update your driver.

http://downloadcenter.intel.com/confirm.aspx?httpDown=http://downloadmirror.intel.com/24652/eng/Wireless_17.14.0_Ds64.exe&Lang=eng&Dwnldid=24652 - win 7 64 bit without IPW

More than likely IPW writes something into the registry that needs to be removed before windows can see the wireless networks again.


01-28-2015, 10:15 AM
Tried uninstalling everything and installed the (new) card again. But since I had already uninstalled IPW earlier, and probably erased the settings when I did, when I now re-installed IPW, it couldn't find the profile and I don't know where to find it (if it can be found that is).

And since this was originally done a while ago, but haven't had time to fix it, a system restore is not that different from a complete re-installment of Windows.

I'll come back and close the thread if the WiFi works after reinstalling Windows.

Thanks for the help C4RN1.

10-05-2016, 09:23 AM
Reinstalled OS, now it works flawlessly.