View Full Version : Sound problems g73jh

11-09-2011, 10:05 PM
My sound completely stopped working after i installed ubuntu (dual booting with windows 7) so i tried uninstalling High Definition Audio Device in the device manager. I restarted the laptop and sound now plays through the subwoofer only.
in "sound" under control panel it shows two "Speaker" options. when i test them, one of them plays only the left sounds through the sub and the other plays only the right sounds through the sub.
I have tried uninstalling and restarting, but it always reinstalls it the same way.
I also downloaded Driver Sweeper off cnet and that was no help.

I have looked through other similar threads but nothing has worked for me.
Any ideas?

11-09-2011, 11:46 PM
I'm assuming you mean Windows re-installs the Microsoft Plug N Play drivers "the same way". What happens when you attempt re-install of the Realtek driver?

11-10-2011, 03:22 AM
I'm assuming you mean Windows re-installs the Microsoft Plug N Play drivers "the same way". What happens when you attempt re-install of the Realtek driver?

When I reinstall it myself there is only one "Speaker" in the sound options but it plays no sound

11-10-2011, 03:36 AM
Interesting... Have you tried a restore to an earlier time to recover proper speaker function?

11-13-2011, 04:28 AM
Tried a restore yesterday and it failed and told me to choose a more recent date. The more recent ones are after the sound stopped working, so it isn't really an option any more

11-13-2011, 04:48 AM
update: got the driver installed what seems to be correctly, and no sound plays. when I plug headphones in, sound plays through but it sounds like it has a strange echo and all the bass/mid/treble levels don't seem stable. No effects are turned on in my speaker preferences

11-13-2011, 06:49 AM
It looks like you are not the only one encountering this issue. http://answers.microsoft.com/en-us/windows/forum/windows_7-sound/no-sound-in-windows-7-after-ubuntu-dual-boot/16d1bc3a-b88a-4ea1-b643-f3b9213bb490 suggests this is a problem with Ubuntu. It posts a solution which may apply to Windows 7 as well:

Hello, i have the same problem with an WinXP - Ubuntu 9.10 dual-boot install and found out in this thread in the ubuntu forums ( http://ubuntuforums.org/showthread.php?t=1313079 ) that shutting down and booting into windows instead of restarting and booting into Windows let's you have sound in Windows.
There is also a link to a bugreport. ( https://bugs.launchpad.net/ubuntu/+source/linux/+bug/453395 ) In the comments there you will find the following solution:

> I was lucky to find a solution to this problem, when reading about other problem. When you edit /etc/init.d/alsa-utils, and comment the 378th line:

> # mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1

> the sound seems to work properly after restart from Ubuntu to Windows. Hope it will work for you too.

> The solution was posted by Gavindi in this bug report: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/352732

11-13-2011, 02:41 PM
drew's idea doesn't work, try totally uninstalling the Realtek driver and restart Windows. Let windows install it's generic driver and see if that works, THEN install Realtek HD if you want.

Looking at the G73JH page, it looks like you install a different Realtek driver, plus Realtek SRS? I don't know for sure. Someone enlighten me.