PDA

View Full Version : Another GameFirst 3 complaint.



Avoid
02-05-2015, 07:12 PM
Ok so I have moaned about this software in my first post. But this is an update to the issues I have with this god awful piece of crap.

So initially I had installed the drivers and software immediately after windows. This program wants flash and completely annihilated my internet. Good job you sucky crap.

Uninstalled... and everything works again. YAY. But I am told not to call the program a turd if I have not managed to get it to work, cause clearly I am stupid, and thus I am the turd.... Ok ...

So while killing some time I think I have flash installed and java I can try again with that Network Program and see how it goes... The same freaking grind to a halt feel comes to my internet. It MUST have that ISP test completed to start anything it seems and that page cause of its awesome compatibility with flash...clearly... has locked up the program...
Luckily on the other window I can click begin test and bring another window up which starts to run tests...

Now on the test page it doesn't want to go fast to 2 of the 3 test servers, which is amazing cause they are usually the faster of the two, but the dog server oh it likes that one and connets with speed.... after a few attempts cause these speeds have caused confusion... Finally it seems to work I can use google, I can bring up my web pages again...

No... no no no no no. Its crap. Steam pages down, Youtube starts then just buffers forever... some pages just no longer load. DELETED... this shall not go back on my pc.

Again I am amazed with how something can be so crap. So any ideas on what went wrong or is running a setup.exe my fault ?

toronto699
02-05-2015, 08:06 PM
many have had problems with game first, most have uninstalled it or disabled it , go to the G751 and G750 threads to read the posts there

whatdoesthisbuttondo
02-05-2015, 09:52 PM
many have had problems with game first, most have uninstalled it or disabled it , go to the G751 and G750 threads to read the posts there

Probably the fate of every single piece of these "extra-value" bloatwares that come preinstalled with complete rigs these days. I'll never understand the motivation, it's almost like the manufacturers do not realize how many not so computer-savy users just return the rigs to the store because they perform so terribly.

Why they insist on shipping the most sluggish AV software they can possibly find on a Windows8.1 system is beyond me, I can only assume the AV software developers are actually paying them to have their junk preinstalled.

Same with the network optimizing softwares, there are much better solutions integrated into $30 soho routers these days that actually are easier to use and understand.

Meh.