PDA

View Full Version : Enable ShadowPlay to record your desktop



joshindaphils
02-20-2015, 12:55 PM
For whatever reason nVidia cripples shadowplay on laptops and does not allow the recording of your desktop.

To enable this feature copy the below text (between the hashes but not including them)and use it to create a text file, name it what you wish, though with a .reg extension. Save it double click on it, afirm all popups, and bam you can now record your desktop:
#################################################
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\NVIDIA Corporation\Global\ShadowPlay\NVSPCAPS]

"DwmEnabled"=hex:01,00,00,00
"DwmEnabledUser"=hex:01,00,00,00
#################################################

Alternatively if you are familiar with regedit just add / edit these values.

-Josh

escha
02-20-2015, 02:20 PM
Thank you!!!!
Was thinking the same. Why on hell would they not allow desktop recording on laptop with NO optimus where screen is connected to the GPU basicaly the same way in PC it is!!

joshindaphils
02-21-2015, 07:02 AM
Your welcome! Yeah it is prolly just easier / lazy to not detecting optimus. Hopefully with more high end performance rigs abandoning optimus nVidia will see the light and remove this arbitrary restriction.

It is probably not getting much attention as I am guessing there is only a minority of users that would like to use this feature.

kalo86
03-07-2015, 07:31 PM
Hello guys, I just applied the workaround registry hack to make shadowplay working for desktop capture but I don't manage to record at all.
I activate the shadowplay, then I press on the dedicated button to start the recording, I see the temp files (they are always two files), then I stop the recording by pressing the dedicated button again and the recorded file is not created. Why?

joshindaphils
03-30-2015, 05:29 PM
Hello guys, I just applied the workaround registry hack to make shadowplay working for desktop capture but I don't manage to record at all.
I activate the shadowplay, then I press on the dedicated button to start the recording, I see the temp files (they are always two files), then I stop the recording by pressing the dedicated button again and the recorded file is not created. Why?

Sorry for the late reply just noticed this... check out the paths you are saving to, the temp files and where the file file ends up can be different, it is perhaps being moved to another location.

In GeForce Experience, under the Preferences tab, select ShadowPlay in the left sidebar then scroll down to the bottom. You will see two different paths for the Save location and Temporary files location.

diogogmaio
04-01-2015, 01:29 AM
I can't get shadowplay to work. I tried your fix but shadowplay cannot record anything. there is not a temp file.i'm getting sad over this. How can i do this?

joshindaphils
04-01-2015, 02:18 AM
Try this out and make sure you have the basics down: https://www.google.ru/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0CB8QyCkwAA&url=http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DmPS _3VNsxhw&ei=7FUbVcDtIMLLaPjagLAG&usg=AFQjCNGzNa_3xRbk-KfYKNOybch-irM00w&bvm=bv.89744112,d.d2s

NitroX
05-15-2015, 02:01 PM
I do have to add something. After making thre .reg file and double clicking on it (and finishing the registry modification) you have to also restart your notebook in order to fully make the feature available. Cheers and many thanks to josindaphils !

lukeadsit
05-24-2015, 04:39 PM
Every time I Change the DwmEnabled over to 01 00 00 00 it reverts back to 00 00 00 00 when i restart my computer
Edit* fixed that using the .reg document but now the status indicator wont pop up when I press play and it still doesn't record the video even thought the screen icon shows a desktop

escha
05-24-2015, 09:35 PM
using .reg file make sure You have admin rights and that shadowplay isn't currently active.
I use .reg file after every nvidia drivers update, then restart. Then open Geforce Experience, activate shadowplay, make sure the shadowplay options did not change (sometimes the 'play/record' button is switched for some 'shift+' thing) and test.
-as of 353.00 drivers on 980m Shadowplay does work on desktop and ingame after aplying this 'fix'

lukeadsit
05-25-2015, 06:10 AM
I'm running a 860m with the 352.86 drivers and i went thought and ran the .reg file with everything turned off and reset, before turning on shadowplay it showed the option for desktop capture unchecked and after i turned on shadowplay the option disappeared and the status indicator never appeared when I tried to record a video it didn't go into the save location.

escha
05-25-2015, 04:56 PM
...it showed the option for desktop capture unchecked and after i turned on shadowplay the option disappeared ...

that's actually a normal thing, it disappeares for me too,
what changed, after using this fix, is the apearance of the display/monitor above that after shadowplay was activated.
No need to check that box to record desktop with this fix.

try to change the save location to non system partition (NOT C:\)

lukeadsit
05-26-2015, 03:21 AM
I moved it over to my D:/ drive and I'm still not getting a recording or the Indicator
But i was wondering if i need to have a login in order to record or if it could be something else?

escha
05-26-2015, 10:16 AM
You don't need to log in to record,
i don't know what else gets in the way, except maybe Optimus.
If You have Optimus then it's the intels integrated graphics rendering the desktop and nvidia gpu is out of the chain (is in sleep mode)
Optimus laptops never had the option to record desktop via shadowplay and the drivers being same for all geforce gpus made that this option was disabled even for laptops without Optimus

https://forums.geforce.com/default/topic/808226/-solution-shadowplays-desktop-capture-for-notebooks-laptops/

So it is it!! You have Optimus laptop and this fix is for NON Optimus laptops only. (like g751 jt/jy)
Maybe try forcing Optimus to use nvidia gpu to render desktop, the shadowplay may or may not work then.

supertoad
05-26-2015, 03:56 PM
lol, there is an update today 10 minutes ago :
GeForce Experience 2.4.5 Release Highlights
• Bug fixes and quality improvements for GameStream.
• Enables ShadowPlay desktop capture for notebooks without Optimus. Optimus support is in development.

thank you anyway

SamDog
11-15-2015, 02:45 AM
I do this, and see the preview widow of the deck top but there is no Icon in the corner of my screen that tells me it's working. Also is this okay for my computer?

cpasoft
11-15-2015, 07:26 PM
Sorry if I'm saying something stupid, but you can enable to record your desktop under the ShadowPlay preferences.
Go to Nvidia GeForce Experience->Preference's tab->ShadowPlay, and on the bottom of the monitor symbol you can see "Allow to capture your desktop" (or something like that. I have the Spanish version, I don't really know how is in English).

Have I missed something of this post??