PDA

View Full Version : Returned my ASUS G751JY



pokerface
02-20-2015, 02:02 PM
I am sad to say this, I loved the IPS screen in the G751JY, it was the best screen I ever looked at, unfortunately, here is my problem

The moment I got my laptop, I hooked up my WD My Passport 2TB USB 3.0 external HDD and started to copy my data on the D: drive, after a few seconds the laptop would crash, not a BSOD, just a full crash where everything has frozen, nothing to show in Event Log Viewer as well. Only happened if the laptop was connected to any of the left USB ports. If it was connected to the right ports, it worked fine. I was shocked as this is the same problem I had with my old G750JX and I read similar complaints about the G750JM, JS, and JZ but I thought by now ASUS would have fixed these issues with the left USB ports but it's the exact same.

I then tried a clean install of Windows 8.1, no difference, tried BIOS 205, 206, no luck....

and another problem was the random black screens when rebooting where I had to hold the power button to force shutdown then boot again it would boot fine.

Seeing that this is a new laptop, I wasn't ready to accept such crippled behavior so I took it to the ASUS service center and showed them how it freezes, within 5 minutes they took the laptop back and declared it as DOA (dead on arrival), they didn't argue or open the laptop or try anything, seems like they were aware of such issues.

I am gonna get a refund soon and for the time being I am back to my Alienware 18..

hope ASUS sorts out these USB 3.0 problems in future laptops as I don't believe any BIOS is going to fix this

hmscott
02-20-2015, 02:30 PM
pokerface, that power problem seems to be a known issue, many have posted about it, requiring RMA to fix it, sorry it happened to you...

For the WD copying problem, it may be a known incompatibility between WD external enclosures and the Intel USB 3.0 chipset.

Apparently the WD controller U1/U2 powersave mode doesn't play nice with the Intel USB 3.0 controller.

Here is a post I made with WD's Knowledge Base info and a link to the WD application to check / turn off U1/U2 powersave mode.
https://rog.asus.com/forum/showthread.php?53877-G751-Problem-with-USB3-0-ports-(left-side)-and-external-HD-anyone-else&p=455699&viewfull=1#post455699

My WD Elements 2TB 2.5" bus powered USB 3.0 ( WDBU6Y0020BBK-NESN ) came with U1/U2 Power save disabled, but apparently some external WD's were shipped initially with U1/U2 powersave mode enabled.

46690

I have also disabled the power saving from the laptop side for all internal USB hubs:

46691

I have run the WD Elements 2TB 2.5" USB 3.0 drive using Bus power on all left / right USB 3.0 ports on my G750JH, and it runs fine transferring many GB's of data both directions.

If you still have a problem when you get your laptop back, check out the U1/U2 setting.

There also seems to be a potential grounding issue with the USB 3.0 connections on the left side of some G751's. There is a wire connecting the USB 3.0 adapter card to the motherboard.

Also reported, there is less bus power current available on the left side as compared to the right side. If you can power the external drive from an external source instead of using Bus power, try that too.

And, last but not least, as of Windows 8 Intel stopped shipping a Windows driver for their USB 3.0 chipset... and Microsofts driver doesn't work right - yet - so many people are actually running their USB 3.0 devices at USB 2.0.

There is a work around for this, but it doesn't seem to work on the G751. There is a patched Windows 7 driver that installs on Windows 8/8.1 and restores SuperSpeed USB 3.0 connections. It works on my G750JH, but the few people that have tried it on their G751 have failed to install it.

46692

46693

Here is the post with the info:

G751 - AC WLAN only at 7 MB per sec!?
https://rog.asus.com/forum/showthread.php?55158-G751-AC-WLAN-only-at-7-MB-per-sec!&p=464477&viewfull=1#post464477

Please come back and let us know how it works out :)

pokerface
02-20-2015, 04:32 PM
thanks for all the info bro, but I didn't return it for a replacement, returned it for a refund

d0r1n
02-20-2015, 05:19 PM
and what are u buying now?

pokerface
02-20-2015, 06:13 PM
and what are u buying now?

not buying anything bro, I already had an Alienware 18 so I'm back to it, the only reason I bought this ASIS G751JY is I wanted the 980 GTX but to be honest, when I benchmarked the 980, the 780M GTX in SLI mode still beats a single 980M GTX so I'm not in a hurry to upgrade

when I have the money, I will just replace these two 780M GTX cards with a dual 980 GTX setup

Medicius
02-22-2015, 08:30 PM
What about Asus reliability promotion?