PDA

View Full Version : Battery last for a shorter time than before



beatc
02-26-2015, 03:14 AM
When i purchased my laptop last year, it ran for 6 hours of browsing internet on battery. Now, my laptop can only last up to 3 hours. Does this mean that i need to replace a new battery? I play games all the time and most of it i play with the laptop plugged in.

tian447
02-26-2015, 01:19 PM
Battery in not lasting as long after a year shock.

In all seriousness, as long as it still lasts 3 hours, you don't need to buy a new battery. When you reach the stage that my old laptop was in, where unplugging it gave you 17 seconds of life and you could actually watch the little battery icon deplete almost immediately, that's when you need to buy a new one.

berserk91.a
02-26-2015, 10:07 PM
Actually I'm having the same problem: ROG G750JZ purchased 7 month ago, before 2 weeks ago the battery last easly 6 hours of web browsing...then the battery life drop to 3h!
It happened too all of a sudden to be the normal battery deterioration, and I'm still trying to figure out what specifically caused this problem.

Here is the details of my situation before and now:

Laptop configuration:
Asus ROG G750JZ - Intel Core i7-4700HQ - Nvidia GTX880M (4GB) - 16GB - Windows 8.1

SSD (slot 0): Samsung EVO840 256GB (added next, see below)
HDD (slot 1): WDC WD7500bpm ~700GB

Note: all the time measures are referred to a usage of web browsing (if wifi turned on) , document reading and/or word processing on intel GPU ( thanks to optimus ), performed from 100% to battery complete discharging

-From July 2014 to December 2014
Laptop in factory condition, only HDD in slot 0
Battery life: wifi ON ~6h ; wifi OFF ~7h

-From (ending of) December 2014 to first half of February 2015
Samsung SSD mounted on slot 0; fresh install of windows 8 through "asus backtracker" on SSD; HDD moved to slot 1 as data only storage; SSD optimized throught "samsung magician" software.
Battery life: unchanged, wifi ON ~6h ; wifi OFF ~7h

-From half of February 2015 to (now) end of February 2015
Laptop mounts both SSD (Win8.1 here) and HDD
Battery life: ~50% of precedent performance; wifi ON ~3h ; wifi OFF not-checked-yet
I started having various problem: windows indexing service running "heavily" also in idle (~20% of CPU always dedicated to this process, CPU fan run consequently ), strange issues about system permission (like I couldn't turn on plane mode option or switch off bluetooth) probably because of a wrong setting of my home network, also optimus seamed to not work properly.
Formatted through "asus backtraker" performing a new clean installation of the system (Windows on SSD) -> solved permissions and (supposed) optimus problems; done every windows updates; windows indexing still running wild; Battery life still low; windows indexing solved disabling it at all; Battery life still low;
Formatted (again) through "asus backtraker" performing a new clean installation of the system (Windows on SSD) -> windows indexing immediately stopped, no CPU over-usage or unexpected fan run; no windows update made; Battery life still low;

What tests I'm going to do now:
-using only the HDD removing the SSD
-using a different battery
-test my brother ROG G750JZ (same laptop configuration as mine except for the SSD) that has never be formatted or upgraded and has been purchased on October 2014
-using linux both on HDD only and SSD+HDD

For now I couldn't identify the cause of this problem, that to me seams all but a normal battery consumption.
Any help or suggestion?

Prostar Computer
02-26-2015, 10:55 PM
A sudden drop in life per charge would imply something is not right. Gradual loss is to be expected.

beatc
02-26-2015, 11:46 PM
@berserk91.a My problem is similar to yours and it is frustrating. Try download this program (http://www.nirsoft.net/utils/battery_information_view.html) and see your wear lvl.

berserk91.a
02-27-2015, 06:53 PM
Here are the results with BatteryInfoView:

Full Charged Capacity 78.170 mWh
Designed Capacity 89.208 mWh
Battery Wear Level 87.6%
Voltage 15.120 millivolts
Charge/Discharge Rate 20 to 35 milliwatts

What are yours @beatc?

UPDATE

-test using a different battery (wear level at 91%) in my pc: just a bit better, 30-40min more then mine, but still to low with respect to my precedent performance
-upgraded BIOS from 205 to 210: no changes

MAYBE I FOUND IT
(preliminary) test running only the SSD, removing the HDD: I gained at least 1h more! and the counter (depending on the usage) goes from 4 to 7 hours with full charge and wifi ON. Now I'm web browsing at 48% and gave me 4h left. I haven't done yet a complete and rigorous test in this situation, I'll update you as soon as I get new results ;)

For now my hypothesis is that: for same reason having an SSD and a HDD mounted doesn't permit the system to optimize the power consumption. It's strange because my PC works for two month in this way without problem... hopefully my next tests will give us answers

UPDATE 2

Unfortunately the precedent test was just a fortunate case, after a restart of the machine the situation turn back to the same bad situation. In any case I could note one thing measuring the battery consumption details with BatteryInfoView in both situations: in the "happy"-situation the battery discharging rate in idle was of 9-10.000 milliwatts, in the actual "bad" one it doesn't go down the 20-25.000 milliwatts

UPDATE 3

test using only SSD with linux Ubuntu 14.04 (unity interface; TLP for power managing; optimized for SSD): the power consumption is the same of windows, around 20-25 milliwatts.

UPDATE 4

test using only HDD with windows (HDD formatted and windows re-installed trough asus backtracker USB-Pen): CONSUMES TURN BACK TO NORMAL STATE, i.e. ~10mWatts in idle for a battery life back to ~6h of web browsing!

Hypothesis for now: the SSD seams the cause of the battery drain.