PDA

View Full Version : GL771JM: Is there any way to disable the kinetic (flick) scrolling?



Frankenweenie
03-13-2015, 05:02 AM
The kinetic/flick/inertial/momentum/whatever scrolling is driving me insane. It's never consistent and always makes me lose my place if I do something ever-so-slightly wrong.

There is no option in the Smart Gesture program to toggle this, only to toggle scrolling on/off but I WANT scrolling, I just don't want this ridiculous inertial scrolling.

Is there any way to get scrolling to be normal?

Edit: After a bunch of Googling I found a solution, but not a great one.
I downloaded an Elantech driver from here (http://support.asus.com/Download.aspx?SLanguage=en&m=Touchpad&os=30).
I uninstalled Smart Gesture and installed the Elantech driver.
First off there is no more momentum when you move the mouse. It feels okay, not great.
I went to regedit and went to HKEY_CURRENT_USER > Software > Elantech > SmartPad.
There is a registry called SC_IntertialScroll_Enable. I set this to 0. After a restart, this has disabled inertial scrolling.

The only reason I'm not happy with this is because my scrolling now feels really bad when going up. Scrolling down works decently, but when I start scrolling up it's very slow and doesn't respond well. Maybe this is just due to using a driver that wasn't meant to be on this laptop, or maybe I need to fiddle with some of the registry keys more.

Any other suggestions or ideas are super welcome.

Frankenweenie
03-16-2015, 01:20 AM
Bump. I'm not accepting no for an answer. There has to be a way to turn off this god-awful inertial scrolling. There has to be a registry key you can add to disable it - I just need to figure out what it is.

I can't be the only person who is seriously annoyed at the terrible inertial scrolling. There has to be a way to turn it off or lessen it, otherwise I'm selling this over-hyped gamer junk and getting a different brand so I will not have to deal with ASUS Smart Gesture.

XOIIO
03-16-2015, 02:04 AM
Did you try the latest elantech drivers and smart gesture from the asus site? I don't have this flick scrolling you do on my JT, just two finger scroll.

Frankenweenie
03-16-2015, 09:34 PM
The only drivers for the GL771JM is the ASUS Smart Touch, which are up to date. Like I said in my OP edit, I tried installing the latest Elantech drivers, but those worked worse than the Smart Gesture and it wouldn't let me install both drivers at the same time - I had to uninstall my Smart Gesture driver in order to get the Elantech one to install.

What drivers do you have? Are you sure you don't have inertial scrolling? Inertial scrolling is when you scroll with some force, let ago, and it continues scrolling. It seems to come standard on ASUS Smart Gesture with no option to disable it.

hmscott
03-16-2015, 09:41 PM
Asus Smart Gestures
http://www.tomsguide.com/forum/86880-35-asus-smart-gestures

Frankenweenie
03-20-2015, 10:42 PM
Tried all of those, hmscott. Tried going back to the oldest drivers, those all still had the inertial scrolling. Some of them just broke scrolling completely.

Currently using the latest ASUS Smart Gesture driver, not that it fixes anything - scrolling is still annoying, but at least it's the driver I should be using.
There has to be a registry key I can make and edit to disable it, but I'm not smart enough to figure out how to get the proper registry key when it's not already there.

hmscott
03-21-2015, 12:43 AM
Frankenweenie, google searching turned up mention of a registry edit to solve it, but they didn't say specifically what the exact fix was.

I did re-find this fix for Linux I have used before.

Adjust "coasting speed"

[SOLVED] disabling synaptics scroll inertia
https://bbs.archlinux.org/viewtopic.php?id=114122

xinput --set-prop --type=float "AlpsPS/2 ALPS DualPoint TouchPad" "Synaptics Coasting Speed" 0 0

Or, add line to / etc/X11/xorg.conf.d/10-synaptics.conf <== take out "space" between / and etc, weird board permission error when it is complete path as posted.

Option "CoastingSpeed" "0"

Maybe a related fix to registry for Windows...no CoastingSpeed token found in the registry.

The registry settings for Smart Gesture offer up some options, wanna try some settings? :)

47708

There are Mouse and Mouse/Ease of Access Center stuff that might mix... pointer speed, lines of scrolling for mouse wheel...

Enabling ReverseScrolling changes the scroll direction, I wonder if it changes the weighting?

Also, I have both Asus Smart Gesture 3.0.8 and Elantech Touchpad 11.5.14.5 x64 WHQL installed...which means I also have the Elantech registry entries:

47737

47738

There are a number of InertialScroll settable spots...

47709

47710

I set all the SC_*InertialScroll* DWORD's, everywhere to 0 - by hand, not global replace - rebooted, seems less twitchy.

Disclaimer: I don't use the built in keyboard / trackpad often - so I am not used to the scroll action. I only tried it first before the change and it seemed a bit wild - accelleration was annoying, now it stays a steady speed - but continues scrolling when I stop - even though the *ContinueScroll* setting for that is also 0...

ASUSTeK Computer Inc. -Support- Driver & Tools - Touchpad - there are newer versions than 11.5.14.5 here...
http://www.asus.com/support/Download/3/589/0/21/41/

Asus SmartGesture
http://support.asus.com/download.aspx?SLanguage=en&p=3&m=ASUS+Smart+Gesture&hashedid=n%2fa

Please let us know if you get it working, and what you did to make it work :)

Frankenweenie
04-03-2015, 05:49 AM
Thank you, hmscott!

I had already tried a bunch of things like installing Elantech drivers instead of ASUS SmartGesture, but with your link to the Elantech drivers, I installed the latest Elantech driver without uninstalling my ASUS SmartGesture and they seem to be working in conjunction.

After installing the Elantech V11.5.16.2, I went into the Registry Editor > HKEY_CURRENT_USER > Software > Elantech > SmartPad.
I set EGS_InertialScroll_Enable & EGS_InertialScroll_ShowItem both to 0 and this seems to have disabled inertial scrolling.

The only downside I can see is that my "two finger tap" that acts as a right click is less responsive for some reason, like sometimes it takes multiple tries to register as a right click. Left-click + dragging is less responsive too.
Most likely has something to do with Elantech messing with ASUS SmartGesture, but I'm not sure?

Edit: Ugh, not the miracle fix I was hoping for. While Elantech drivers do allow you to disable inertial scrolling, it looks like it generally makes the touchpad worse to use. Scrolling DOWN is fine, but scrolling up barely works for some reason. And the issues with the double tap being hardly responsive.

This sucks - do I have to be forced to choose between working double tap and godawful inertial scrolling with ASUS Smart Gesture, or non-inertial normal scrolling with barely functioning scrolling up and double tap with Elantech.

You just can't win with new laptops, I guess. **** clickpads. **** all of them to hell.

hmscott
04-03-2015, 02:09 PM
As they say, 1 step forward, 2 steps back, it's called progress.

Maybe there are other Elantech tweaks possible to mitigate some of the annoyances?

Keep the faith, take a breath and try another step forward, when you get it all tweaked to as close to perfect as possible, please come back and let us know the registry tunings.

Threemium
04-06-2015, 06:48 PM
I am also having this problem. Inertial scrolling ruins the trackpad. In the name of God can someone please fix this issue.

Threemium
04-07-2015, 03:18 AM
Haven't tried any of these but here's some suggestions:



After testing a bunch of different touchpad drivers I have found this one to be the best, by far.

Touchpad rating: 8/10

I have also hosted the driver here: Elan_touchpad_11.7.8.5


Important: Control Panel -> Touchpad:

View attachment 91490

Click advanced:

View attachment 91491

This will make the touchpad very stable, smooth and non-jumpy.

Only thing I'm missing is the same as Tummy wrote, the fn+F9 button to disable touchpad manually as I use external mouse (Razer Orochi) and sometimes I move around and want to quickly enable/disable without disconnecting the Orochi.


By reading and investigating both here and there, I have finally found a satisfactory setup on my Asus UX31E.

It involves Elantech Touchpad driver 11.6.9.001 from Acer and latest ATK Package from Asus.
It also involves getting rid of Smart Gesture, Virtual Touch and ETDware.

Acer drivere can be found here (search for Acer Aspire S7-191 Windows 8 64 bit):
Acer | Download

Asus drivers can be found here:
ASUSTeK Computer Inc. -Support- Drivers and Download Touchpad

Safe method for upgrading TP drivers (reboot as suggested along the way):
1.Deinstall ATK package, Smart Gesture, Virtual Touch and ETDware
2.Install Elantech Touchpad drivere (11.6.9.001)
3.Install latest ATK Package

This gave me a very good respons but Fn+F9 did not work anymore. Luckily, I don't miss it, since the touchpad can be configured to deactivate itself during writing, and resume operation after xx seconds, very nice :)

Now my notebook functions in the way it should have when leaving the factory.

These all came from http://forum.notebookreview.com/threads/new-elantech-and-asus-smart-gesture-drivers-how-are-they.689932 . I'm sure there are more setups you can try too. That thread is full of suggestions.

deaxes
08-14-2015, 01:03 PM
I found a way using the Asus Smart Gesture driver. Go to C:\Program Files (x86)\ASUS\ASUS Smart Gesture\AsTPCenter\model\ and change the InertiaSetting.ini file. What you want to change is the InertiaAlgo=0 to 2. This will turn Inertia off completely. If you just want to reduce it, change it to 1. Once thats done, restart and it should be changed.

deaxes
08-14-2015, 03:29 PM
That said, I personally prefer setting 1.

Hwulex
03-08-2016, 06:22 AM
I found a way using the Asus Smart Gesture driver. Go to C:\Program Files (x86)\ASUS\ASUS Smart Gesture\AsTPCenter\model\ and change the InertiaSetting.ini file. What you want to change is the InertiaAlgo=0 to 2. This will turn Inertia off completely. If you just want to reduce it, change it to 1. Once thats done, restart and it should be changed.

Felt compelled to register just to say THANK YOU! This "intertia" or "momentum" scrolling has been driving me nuts for three months since I got my UX305CA and this has finally disabled it and turned it off. Many thanks, kind person.

Robrecht
08-31-2016, 10:19 AM
I found a way using the Asus Smart Gesture driver. Go to C:\Program Files (x86)\ASUS\ASUS Smart Gesture\AsTPCenter\model\ and change the InertiaSetting.ini file. What you want to change is the InertiaAlgo=0 to 2. This will turn Inertia off completely. If you just want to reduce it, change it to 1. Once thats done, restart and it should be changed.

Felt compelled to register just to say THANK YOU! This "intertia" or "momentum" scrolling has been driving me nuts for three months since I got my UX305CA and this has finally disabled it and turned it off. Many thanks, kind person.

Same here, thank you! I've had my trusty old UX31E for years and have managed to disable scrolling "inertia" several times over that period, but the latest update re-enabled it again and this time I had no idea how to fix it.

The most annoying thing about this "feature" is this. I can't count the times I've quickly scrolled through a web page and then hit Ctrl+W to close the tab, only to see the page grow huge or tiny right before it closes. Why? Because holding Ctrl while scrolling controls zooming, and there was still some invisible scrolling "inertia" going on even though I'd released the touchpad! And since Google Chrome remembers your zoom level the next time you visit a page, I had to go back and reset it every time. Drove me crazy.