PDA

View Full Version : Asus Gaming Headset Cerberus microphone not working



Dragvon
03-14-2015, 07:30 PM
Hi guys, this might be the wrong section for this thread but I will continue anyway, because the issue I have right now really makes me suffer.

So I just bought a new gaming headset because a friend of me recommended it, not that I really needed it but honestly I don't waste money on something I don't simply use, or in other words CAN NOT USE. I bought this headset called Cerberus, I connected it with my PC, so far it was working fine with the sounds, I could change the volume, level it, mix the db and etc... Then I wanted to try out the microphone and of course this really f*cked me up.
The microphone on my headset doesn't work, it just won't work. I tried everything, I connected it on the front of my case and in the back. The computer can find the microphone but even though it shows up it still won't catch any sounds. I have it as default and enabled, I have the mute button off and it still doesn't work. No matter what I do the green bar just won't light up at all, it doesn't catch any sound. I tried this while having the detachable mic on, I haven't really tried it without because I managed to rage uninstall the whole driver before I could give it a try. But if the detacheable mic doesn't work then I see absolutely no point at using this headset over my old broken USB logitech headset.

So do you have any ideas on what's up with my microphone? So far I couldn't find any solutions on the internet, there were no issues like this reported. Please help me :(