PDA

View Full Version : G750JS laptop stuck on aptio setup utility



odyssey96
03-16-2015, 03:24 AM
Hi

My 3 month old ASUS G750JS-TS71 has been stuck on this setup for the past week. The laptop was working flawlessly until this just suddenly happened. I had not updated the BIOS or even touched it, but goggling around, it seems to be a common problem. I have tried several methods they listed, but the problem keeps reoccurring. When I try to save changes and exit it boots up with the same thing. My HDD in the BIOS is registered and quite stable.

I've tried disabling secure boot control and enable CSM and then pressing ESC to choose boot device forcing a shutdown to reboot to which led me right back to the utility.

I tried the same method but pressing F9 to boot into Window Recovery Menu and did a system restore, but it was temporary and didn't fix the problem.

I can restart and immediately boot into Windows, but the problem occurs hours later on when I power on the laptop.

Right now leaving the BIOS in it's default settings is a problem and only way I can boot up windows is through the recovery menu.

Any help please?