PDA

View Full Version : G750JW Charger is dead



elliont
03-21-2015, 05:55 PM
I have a ROG G750JW and i recently travel to china with my labtop.
The thing happened to my G750 is it cannot be charged for some times.
I tried every kind of adpters but they can only work for a few times.
Just wondering what happened to that G750. Will that be problem with voltage or my mother board has broken.
Does anyone have this problem as well?

Maxter
03-22-2015, 05:10 AM
I have a ROG G750JW and i recently travel to china with my labtop.
The thing happened to my G750 is it cannot be charged for some times.
I tried every kind of adpters but they can only work for a few times.
Just wondering what happened to that G750. Will that be problem with voltage or my mother board has broken.
Does anyone have this problem as well?


I have the JW. The adapter should be compatible everywhere., If you can run the computer without the battery, then the battery is the issue

elliont
03-22-2015, 09:20 AM
I have the JW. The adapter should be compatible everywhere., If you can run the computer without the battery, then the battery is the issue


I cannot charge my compter even i use all of the battery. I do not know if this is the problem with mother board or the adpter.

GottiBoi55
03-22-2015, 01:57 PM
I have a ROG G750JW and i recently travel to china with my labtop.
The thing happened to my G750 is it cannot be charged for some times.
I tried every kind of adpters but they can only work for a few times.
Just wondering what happened to that G750. Will that be problem with voltage or my mother board has broken.
Does anyone have this problem as well?

Hi elliont, and welcome to the ROG Forum.
Sounds like your battery may be dead, if you can run your JW on just the power adapter, then the battery is bad.
So try running without the battery, and just on the power adapter.
If everything runs fine on just the power adapter you need a new battery.

Hope this helps you my friend?

hmscott
03-23-2015, 07:26 PM
Hi elliont, and welcome to the ROG Forum.
Sounds like your battery may be dead, if you can run your JW on just the power adapter, then the battery is bad.
So try running without the battery, and just on the power adapter.
If everything runs fine on just the power adapter you need a new battery.
Hope this helps you my friend?

GottiBoi55/elliont View Post, it could also be the charging circuit, independent from the power through to the laptop - the power adapter can be good and power the laptop, and the battery is good, but the charging circuit can be bad.