PDA

View Full Version : G74 stock atheros bluetooth interference



wanfeilwong
11-16-2011, 10:59 PM
Hi fellow Asus members,

I currently have a razer orochi bluetooth mouse and sony bluetooth mw600 headset. While using both devices simultaneously, I find that the mouse stutters. When I turn off the headset, the mouse works fine. Maybe an interference or bandwidth issue?

I have the Atheros driver 9.2.1.459(dont think there is a separate BT driver)

Can anybody else attest to this? try using any BT headset and BT mouse together to see if you get the same results.

Any input would be appreciated

JRd1st
11-17-2011, 01:35 AM
There IS a separate driver for the BT, but I need to know your BT's Hardware ID to get an updated version.

wanfeilwong
11-17-2011, 04:39 AM
Went to device manager> bluetooth radios> bluetooth module

under hardware ID it shows:
USB\VID_13D3&PID_3304&REV_0001
USB\VID_13D3&PID_3304

current driver version: 7.2.0.65

JRd1st
11-17-2011, 12:05 PM
Try this driver ftp://ftp.asus.com.tw/pub/ASUS/nb/Drivers/Bluetooth/Bluetooth_Azurewave_NB037_Win7_64_Z70200055.zip

Warning: it's a long download

wanfeilwong
11-17-2011, 02:59 PM
Ouch, that is a long download, hahaha but worth it if it fixes my BT woes.
So I take it that the stock wlan/bt card is actually an Azurewave card which uses Atheros chips.
Does that mean there are two separate drivers needed to update this card?

Thanks

JRd1st
11-17-2011, 03:05 PM
Well, the whole thing is on the same card, both BT and Wifi. I call them Atheros because they make the drivers. What does it say in "Details"?

And yes. The same with my Intel 6230. Two sets of driver software. :shrug:

wanfeilwong
11-17-2011, 03:26 PM
Details states.....
device description: Bluetooth Module(not very descriptive)
hardwareID: USB\VID_13D3&PID_3304&REV_0001
Manufacturer: Atheros

I think this is the stock card http://www.azurewave.com/product_AW-NB037_1.asp

I downloaded that BT driver u recommended, and it says that I already have a newer version.
I'm gonna try this one.... ftp://ftp.asus.com.tw/pub/ASUS/nb/Drivers/Bluetooth/Bluetooth_Atheros_AR3011_AR3012_Win7_64_Z74090.zip

JRd1st
11-17-2011, 03:56 PM
Details states.....
device description: Bluetooth Module(not very descriptive)

Sorry 'bout that. The date was the newest one and since they have such weird and non-descriptive file names . . . .

I think the one you chose will work. It may be the last one I tried before I dumped the Atheros card.

wanfeilwong
11-17-2011, 04:19 PM
Hahaha nice, I may end up getting the same wifi/bt card you have if the problem persists.
Can u tell me where you purchased the card and if you ever got the fn+f2 toggle to work for BT?

Many Thanks,

JRd1st
11-17-2011, 04:29 PM
I got the card on Amazon.com (http://www.amazon.com/6230-IEEE-802-11n-draft-Bluetooth/dp/B004PG08SE/ref=sr_1_1?ie=UTF8&qid=1321547281&sr=8-1) and it's really tiny. The fn +f2 doesn't work for the BT, but it does work for the WiFi.

I just leave it on . . . :shrug:

wanfeilwong
11-18-2011, 02:52 PM
well..the BT 74090 drivers didnt help so I think I am going to take the plunge on the 6230 card. Have you used any BT mice or other accessories with the card?
No matter what I'll get better wifi signal with the new card, but just wondering if the BT is any different

JRd1st
11-18-2011, 03:02 PM
Did those drivers install and run, at least?

wanfeilwong
11-18-2011, 03:06 PM
they ran and im using them right now. Not exactly sure what they fixed though.

JRd1st
11-18-2011, 03:13 PM
New drivers don't always fix something. They have a placebo effect, sometimes, but they usually add new models to the install script so they will install. :shrug:

wanfeilwong
11-18-2011, 03:50 PM
Yeah, was too hopeful for a fix