PDA

View Full Version : SD Card Reader issue G750-JZ, card does not appear in file explorer - solved?



giffi
03-25-2015, 09:41 AM
SD Card Reader issue G750-JZ

I try to use the SD card reader but the card does not appear in file explorer.

Uninstalled and re-installed the card reader software:

CardReader_Genesys_Win81_64_VER4307

Still nothing when I insert a SD card. Any help or suggestions are most welcome.
Thank you.

hmscott
03-25-2015, 12:24 PM
SD Card Reader issue G750-JZ
I try to use the SD card reader but the card does not appear in file explorer.
Uninstalled and re-installed the card reader software:
CardReader_Genesys_Win81_64_VER4307
Still nothing when I insert a SD card. Any help or suggestions are most welcome.
Thank you.

giffi, for me the Genesys driver exhibited the same behavior, and I found that if I inserted the SD card, then ejected it, and inserted it one more time, the SD card would mount. This works consistently.

But, that is annoying, so I went looking for a better solution.

As I have posted many times, the newest drivers are available via new product releases, and the G501 is no exception, there are several new drivers useful in the G750/G751, and one of them is a newer Card Reader driver:

G501, Windows 8.1, Card Reader section, Realtek Version V6.3.9600.21255
http://support.asus.com/download.aspx?SLanguage=en&p=3&m=G501JW&hashedid=uv3gzPnU54cTZC6Y

I just uninstalled the Genesys driver and installed the Realtek driver, and now the SD card mounts first try every time :)

The only difference is now there isn't a fancy SD Icon for the drive, it is just a plain removable disk icon.

Please let us know how it works out for you :)

giffi
03-25-2015, 05:17 PM
Thank you for your reply. You are quite right. That is a working solution - it solved my problem so thanks again :-)

jmbear
03-30-2015, 02:53 AM
giffi, for me the Genesys driver exhibited the same behavior, and I found that if I inserted the SD card, then ejected it, and inserted it one more time, the SD card would mount. This works consistently.

But, that is annoying, so I went looking for a better solution.

As I have posted many times, the newest drivers are available via new product releases, and the G501 is no exception, there are several new drivers useful in the G750/G751, and one of them is a newer Card Reader driver:

G501, Windows 8.1, Card Reader section, Realtek Version V6.3.9600.21255
http://support.asus.com/download.aspx?SLanguage=en&p=3&m=G501JW&hashedid=uv3gzPnU54cTZC6Y

I just uninstalled the Genesys driver and installed the Realtek driver, and now the SD card mounts first try every time :)

The only difference is now there isn't a fancy SD Icon for the drive, it is just a plain removable disk icon.

Please let us know how it works out for you :)

I have the same problem with a ROG G750JZ. Tried both drivers and it did not work =(

hmscott
03-31-2015, 10:32 AM
I have the same problem with a ROG G750JZ. Tried both drivers and it did not work =(

jmbear, did you uninstall both old drivers and reboot first, before trying them - 1 at a time, or both at once - that is what I have configured - both?

Also, did you try the insert, eject, and insert again to get it to mount?

Is the SD card you are trying to read formatted? After inserting (1st and/or 2nd insert) open Windows Storage Manager - right click on desktop computer icon and select Manage, then Storage. See if the unformatted device is showing up there - then format it.

It might be a dead device, or the internal USB cable is disconnected. Use something like hwinfo64 and look at USB devices and see if you can find it, it looks like this - you need a card inserted for it to show up:

47998

Have you updated all your Windows patches and drivers for Windows 8.1? Here is a list of places to find the latest drivers for Windows. The Intel INF Chipset driver might be a good one to make sure you have the latest 9.x version installed:

http://rog.asus.com/forum/showthread.php?55572-Asus-G751-Support-Download-areas&p=473863&viewfull=1#post473863

If you can't get it to work, then write a Technical Inquiry to Asus and have them help you through debugging to potential RMA.

https://vip.asus.com <== create a login, register your laptop, file a Technical Inquiry with details as to the problem and debugging details you have already done.

Please come back and let us know how it worked out :)

Dr4g0n36
08-23-2015, 01:04 PM
Hi guys, tried all these solution, even downloading the "original" driver from realtek site and cheking policies under regedit, but i can't recognize my 12 SD card... i'm thinking to do a clean install, i NEED SD card access. Other solutions differnt from previous? Even advanced, i'm IT.

Gps3dx
08-03-2016, 10:38 PM
Well... I think I got a solution... at least for Windows 10 x64.
My issue was that although Genesys driver ( under USB controller tree ) was installed from the official download page for my G751JT, I got a "bad device" under the "disk drives" tree ( in device manager ).

so i've went to "Genesys Logic USB3.0 card reader" under USB tree and changed the driver to "USB mass storage device", as it appears as a "compatible hardware" driver.
then i've re-inserted the SDcard into the built-in card-reader of my G751JT, and then problem solved -> I can see my card content in file explorer.

Sejian
02-12-2017, 06:44 PM
I've still had no luck with this. I've tried drivers from G501JW, G750JM (mine), and G752VY.

G752VY's "Genesys Logic USB3.0 Card Reader" shows under my USB controllers but no device under Disk Management.

I can't recall a time when this card reader ever worked. Kinda like my DVD-RW drive. Sigh.

PTVJR
09-15-2017, 01:07 PM
My hardware worked in the fall but come spring the card reader did not. I had done Win10 and other software/driver updates including the BIOS update. (I still have to use the old touch pad driver for mine to work correctly.) The first time I tried his suggestion it didn't work then I realized I might not have upgraded the Intel drivers even though I had the latest downloaded. After the reboot from installing them his suggestion of changing drivers for the card reader to a mass storage device. You'll have to go to update driver, pick from local location. I had three choices; the previous driver version (which it was the system was using), the new version (which the system said was the wrong version and resulted in a device error) and the generic mass storage driver. If the driver and device name doesn't change to "USB Mass Storage Device" then his fix wasn't applied.