PDA

View Full Version : UEFI sartup problem



diegojusti
03-28-2015, 05:38 PM
I have a M5A99X EVO (it isn't the R2.0), I've tried to solve my problem trying different websites, forums (especially here)..... but I didn't find anything like this. Well, let's explain the problem, and I hope that you can help me:
My Motherboard at BIOS startup is showing the following message: "Please press DEL to enter UEFI BIOS settings". So, it appears to be simple, enter in BIOS and set up the boot BIOS for a legacy or UEFI drive mode. But there is a problem, I think that is better to tell the story.
I always have used in legacy and this message never appeared, but... recently I've tried the UEFI mode because of the startup speed. So I did, I've heard about the RUFUS and I've used this program to make a USB UEFI bootable device with a W8 image. Everything was fine during the installation, including the GPT partition that was set automatically and the MSR partition too. But after the installation when I restarted the computer the message appeared "Please press DEL to enter UEFI BIOS settings", I entered the BOOT bios tab and the label "UEFI" was at the Boot device manager partition, I selected this boot drive, but the same message insists to appear every time that I turn on my computer. "Well it's a simple message nothing to worry". But I discovered that the OS wasn't starting in the UEFI mode, because when I use the "advanced startup options" in W8 the "UEFI firmware settings" option isn't there, I don't understand about this but it seems that something is wrong. After this I tried to come back to legacy boot with a W8 in a normal USB boot installation, and the message also insists to appear. I upgraded to the most recently BIOS version and... the same. I tried to use the DIKSPART to clean partitions, many things and nothing works. This motherboard's problem is that in the Boot BIOS tab you can't choose the Boot mode (legacy, UEFI), this option isn't present and also the Secure Boot. I saw about a boot with the option "Launch EFI from filesystem device" but I didn't understand about this and I don't know if it's going to work. So I ask for help, what should I do to use the UEFI mode? Here some pictures about the situation:

UEFI Message:
47921

UEFI label at Windows boot manager partition:
47922

Boot tab with no UEFI/lagacy option:
47923
47924

drop4205
03-28-2015, 07:22 PM
secure boot set to widows os?boot device conrol set to uefi and legacy?csm enabled?Try disabling all other boot options except 1 and 2?

diegojusti
03-28-2015, 08:59 PM
Well, I disabled all other boot options, but I didn't find anytinhg about CSM or secure boot in BIOS.
The only thing that I found about legacy mode was in USB devices.

Clintlgm
03-29-2015, 02:23 AM
Did you possible have more than one hard drive install when you installed Windows 8.1 UEFI?
If so you may have the boot partition on a different Hard drive. This sometimes happens.
So remove all hard drive except the one you are going to install windows 8.1
You already have your rufus set up windows 8 UEFI install correct?
on boot up hit the F8 or ESC key for a boot menu select your UEFI Thumb Drive start the install as soon as the install window comes select language then hit F10, this will bring up a Command prompt
Use Diskpart to Clean your disk
Use Diskpart to convert to GPT
continue installing windows UEFI
after install reboot Check your BIOS if all is well shut down and connect your other hard drives.
On booting up again hit F8 for the boot menu again and select the disk your windows 8.1 is installed on. you shouldn't have any further problems

Some great step by step Tutorials here http://www.eightforums.com/tutorials/?filter[2]=Installation%20and%20Setup

Your DATA drives can be either MBR or GPT there really is not much difference unless the drives are over 2 GB then GPT will be needed.
You can convert a data drive from MBR to GPT or from GPT to MBR. But your OS must be installed either one way or the other OS drives can not be converted.
Of course you should always have your data backed up before trying any conversion as something could go wrong during the conversion.

diegojusti
04-01-2015, 02:47 AM
I tried what you said and the same happened. So I wrote an e-mail for ASUS explaining my situation. I received an answer saying that my motherboard isn't compatible with Windows 8/8.1 in UEFI mode, only in legacy. LOL. I think that I have to give up for this and use the legacy mode.... Anyway, I am grateful for your help.