PDA

View Full Version : G751JY wake on WLAN insomnia - wakes up every 10 minutes



krys
03-31-2015, 12:14 PM
Hello,
I am currently trying to set up wake on wireless lan on my new g751jy on Windows 8.1 .
On the Intel DuaI Band Wireless-ACC 7260 Properties, I checked
- "Allow the computer to turn off this device to save power"
- "Allow this device to wake the computer"
- "Only allow a magic packet to wake the computer"
Also in advanced :
- "GTK rekeying for WoWLAN" -> enabled
- "NS offload for WoWLAN" -> enabled
- "Sleep on WoWLAN Disconnect" -> disabled
- "Wake on Magic Packet" -> enabled


It almost works (I can wake it with a magic packet) except that it also has some insomnia at very precise timing :
It wakes up every 10 minutes (precisely at :02 :12 :22 :32 :42 :52) and then go again to sleep 3 minutes later (:05 :15 :25 :35 :45 :55 )
I am sure these wakeups are triggered by Wifi as they only occurs when Wifi is connected while going to sleep.

I am connected through WPA2 CCMP on an openWRT router.

Do anyone has an idea of what could triggered these wakeups?

XOIIO
03-31-2015, 01:11 PM
Maybe the router pinging the computer to see if it is still on the network?

krys
03-31-2015, 01:44 PM
Thank you XOIIO,

I performed a tcpdump on my OpenWRT router and here is what I got when my laptop wakes up:
13:57:00.519756 IP (tos 0xc0, ttl 1, id 0, offset 0, flags [DF], proto IGMP (2), length 32, options (RA))
0.0.0.0 > all-systems.mcast.net: igmp query v2
13:59:05.959755 IP (tos 0xc0, ttl 1, id 0, offset 0, flags [DF], proto IGMP (2), length 32, options (RA))
0.0.0.0 > all-systems.mcast.net: igmp query v2
14:01:11.399757 IP (tos 0xc0, ttl 1, id 0, offset 0, flags [DF], proto IGMP (2), length 32, options (RA))
0.0.0.0 > all-systems.mcast.net: igmp query v2
14:03:16.839756 IP (tos 0xc0, ttl 1, id 0, offset 0, flags [DF], proto IGMP (2), length 32, options (RA))
0.0.0.0 > all-systems.mcast.net: igmp query v2
14:03:46.307340 EAPOL key (3) v2, len 127
14:03:46.808198 EAPOL key (3) v2, len 127
14:03:47.809544 EAPOL key (3) v2, len 127
14:03:48.315020 5c:c5:d4:3b:1b:55 (oui Unknown) > Broadcast Null Unnumbered, xid, Flags [Response], length 6: 01 00
14:03:48.318382 EAPOL key (3) v2, len 95
14:03:48.997104 5c:c5:d4:3b:1b:55 (oui Unknown) > Broadcast Null Unnumbered, xid, Flags [Response], length 6: 01 00
14:03:48.999671 EAPOL key (3) v2, len 95
14:03:49.088878 EAPOL key (3) v1, len 119
14:03:49.090515 EAPOL key (3) v2, len 151
14:03:49.091985 EAPOL key (3) v1, len 95
14:03:49.141487 IP6 (hlim 1, next-header UDP (17) payload length: 92) fe80::8d54:795b:41c5:cff8.dhcpv6-client > ff02::1:2.dhcpv6-server: [udp sum ok] dhcp6 solicit (xid=1e9f2d (elapsed-time 0) (client-ID hwaddr/time type 1 time 475534867 08626653ad4c) (IA_NA IAID:73188820 T1:0 T2:0) (Client-FQDN) (vendor-class) (option-request DNS-search-list DNS-server vendor-specific-info Client-FQDN))
14:03:49.141544 IP6 (hlim 1, next-header UDP (17) payload length: 92) fe80::8d54:795b:41c5:cff8.dhcpv6-client > ff02::1:2.dhcpv6-server: [udp sum ok] dhcp6 solicit (xid=1e9f2d (elapsed-time 0) (client-ID hwaddr/time type 1 time 475534867 08626653ad4c) (IA_NA IAID:73188820 T1:0 T2:0) (Client-FQDN) (vendor-class) (option-request DNS-search-list DNS-server vendor-specific-info Client-FQDN))


The tcpdump correspond with the router logs :
Mar 31 14:03:48 OpenWrt daemon.info hostapd: wlan1: STA 5c:c5:d4:3b:1b:40 IEEE 802.11: authenticated
Mar 31 14:03:48 OpenWrt daemon.info hostapd: wlan1: STA 5c:c5:d4:3b:1b:55 IEEE 802.11: associated (aid 1)
Mar 31 14:03:48 OpenWrt daemon.info hostapd: wlan1: STA 5c:c5:d4:3b:1b:55 IEEE 802.11: authenticated
Mar 31 14:03:48 OpenWrt daemon.info hostapd: wlan1: STA 5c:c5:d4:3b:1b:55 IEEE 802.11: associated (aid 1)
Mar 31 14:03:49 OpenWrt daemon.info hostapd: wlan1: STA 5c:c5:d4:3b:1b:55 WPA: pairwise key handshake completed (RSN)
Mar 31 14:03:52 OpenWrt daemon.info dnsmasq-dhcp[1208]: DHCPREQUEST(br-lan) 192.168.237.226 08:62:66:53:ad:4c
Mar 31 14:03:52 OpenWrt daemon.info dnsmasq-dhcp[1208]: DHCPACK(br-lan) 192.168.237.226 08:62:66:53:ad:4c ASUS

Here are also the logs from Intel Pro Set :
387,Task Tray,03/31/2015 15:54:36,Information,General,krys,End scan event from the service.
388,S24EvMon,03/31/2015 16:03:44,Error,TCP/IP,Système,Did not receive an IP address from DHCP server
389,Task Tray,03/31/2015 16:03:44,Information,Adapter,krys,DHCP Failure event from the adapter.
390,S24EvMon,03/31/2015 16:03:44,Information,Driver,Système,ATC 64:70:02:ba:03:ec WIFIAP 48 RSSI=-53
391,S24EvMon,03/31/2015 16:03:44,Success,Driver,Système,RxAuthSuccess 64:70:02:ba:03:ec 48
392,S24EvMon,03/31/2015 16:03:44,Success,Driver,Système,RxAssocResp 64:70:02:ba:03:ec 48 -53
393,Profile Manager API,03/31/2015 16:03:44,Warning,Profile,krys,The given profile already exists in the database.
394,ZCfgSvc,03/31/2015 16:03:44,Information,Security,Système,Link down Wireless Profile: WIFIAP
395,S24EvMon,03/31/2015 16:03:44,Information,TCP/IP,Système,VoIP: Got link down - deleting flows .
396,S24EvMon,03/31/2015 16:03:44,Information,General,Système,Start Wireless Connection
397,S24EvMon,03/31/2015 16:03:45,Information,Driver,Système,ATC 64:70:02:ba:03:ec WIFIAP 48 RSSI=-53
398,S24EvMon,03/31/2015 16:03:45,Success,Driver,Système,RxAuthSuccess 64:70:02:ba:03:ec 48
399,S24EvMon,03/31/2015 16:03:45,Success,Driver,Système,RxAssocResp 64:70:02:ba:03:ec 48 -53
400,ZCfgSvc,03/31/2015 16:03:45,Success,Security,Système,Link up Wireless Profile: WIFIAP

The last ping was almost 1 minute before, so probably not related to the wakeup

And here are the Sytem Event logs :
Information 31-03-15 16:03:45 Power-Troubleshooter 1 None "The system has returned from a low power state. Sleep Time: ‎2015‎-‎03‎-‎31T13:54:48.305633600Z Wake Time: ‎2015‎-‎03‎-‎31T14:03:43.315769900Z Wake Source: Unknown"
Information 31-03-15 16:03:43 Kernel-Power 131 (33) "Firmware S3 times. ResumeCount: 20, FullResume: 977, AverageResume: 977"
Information 31-03-15 16:03:43 BTHUSB 18 None "Windows cannot store Bluetooth authentication codes (link keys) on the local adapter. Bluetooth keyboards might not work in the system BIOS during startup."
Information 31-03-15 16:03:42 MEIx64 2 None "Intel(R) Management Engine Interface driver has started successfully."
Information 31-03-15 16:03:42 Kernel-General 1 None "The system time has changed to ‎2015‎-‎03‎-‎31T14:03:42.500000000Z from ‎2015‎-‎03‎-‎31T13:54:50.574538000Z. Change Reason: System time synchronized with the hardware clock."
Information 31-03-15 15:54:49 Kernel-Power 42 (64) "The system is entering sleep. Reason: Application API"

note : there might be a 4-6 seconds lag between Windows and the router.

krys
03-31-2015, 06:16 PM
I also opened a thread on the OpenWRT forum as it is also related to my OpenWRT router :
https://forum.openwrt.org/viewtopic.php?pid=270712#p270712

ReDFoX2200
03-31-2015, 08:59 PM
are u waking it up from sleep mode or a shutdown?

XOIIO
04-01-2015, 04:52 AM
It must be in sleep mode since it's using wlan

krys
04-01-2015, 05:08 AM
I do it from sleep mode.
I tried from hibernate and shutdown but it's not working.

XOIIO
04-01-2015, 06:27 AM
Yeah that's the problem with wake on wireless lan, the card doesn't have any power and the OS isn't running so it can't wake the computer.

ReDFoX2200
04-01-2015, 04:47 PM
Yeah that's the problem with wake on wireless lan, the card doesn't have any power and the OS isn't running so it can't wake the computer.

I have tried WOL on the Ethernet card and it only works on sleep mode.

krys
04-02-2015, 07:39 AM
Beeing only able to do WOL on sleep mode is not a problem for me as I never shutdown/hibernate my laptop.

But I still don't understand why it wakes up every 10 minutes when connected to my Wifi with WOL enabled.

krys
04-02-2015, 11:58 AM
I have found the cause of these insomnias : WPA group rekeying.
By default, it is set to every 600s on openWRT. I changed it to 3600 and my g751jy wakes up only after 1hour.
So a workaround would be to increase this WPA group rekeying interval. But it also means decreasing security as hackers would have more time to break the generated key before it gets renewed.
For those who are interested by this workaround, I will post it on the OpenWRT forum https://forum.openwrt.org/viewtopic.php?id=56580 .

But I'm wondering if there is a way to allow the wireless card to handle this WPA group rekeying without waking the laptop.
I guess this is related to the setting
- "GTK rekeying for WoWLAN" -> enabled