View Full Version : Stubborn TurboBoost

11-18-2011, 09:56 AM
Hi, a while ago I complained about TurboBoost not working and causing Dolphin to work slowly - This was solved by putting Dolphin at High/RealTime priority which made things run smoothly.
Although apparently, it only solved Dolphin running slow, as looking at Intel TB Monitor (2.00) I see that my CPU never goes all the way up to 2.8GHz even when it's at 100% use.
And not just for Dolphin, If I convert a video and play at the same time, my CPU will scream but will stubbornly stay at 1.7GHz boost. (Well, he WILL go 1.73/74 but let's face it, far from enough, aye?)
On other occasions when Boosting is completely unnecessary, I find it at 2.2GHz = :confused:
Someone save me... :D

11-18-2011, 10:23 AM
I assume you still have Power4Gear installed? Set it to High Performance. Install ThrottleStop, go into options, click "Unlock Bidriectional Prochot", Click Ok, on main screen, click BD Prochot and push Turn On

Now try Dolphin or whatever and see if that eases your mind.

11-18-2011, 11:23 AM
Tried... did nothing :/

11-18-2011, 01:21 PM
Open Throttle Stop, set it up the way I told you and press TS Bench. select 8 threads, then 32m. It'll run a short benchmark test. My Turbo Boost monitor goes uo and stays at 2.60 GHz.

I've seen mine go up to 2.8 briefly, but I don't think it's supposed to go Turbo for long periods, just for short bursts. Sort of the way many peoples' "High Speed" internet works. It's really fast at the beginning of a download but then the speed drops quickly.

ALSO, in your Power4Gear or Powercfg settings, go to Advanced settings for the profile you use, then scroll down to Processor Power Management. If you want the fan to come on to cool the processor before the processor slows down to cool itself, set your profile in System Cooling Policy to Active. It'll be more noisey, but your CPU should run faster for longer.

11-18-2011, 01:43 PM
Nothing. :(
Unlocked Bidirectional PROCHOT, Marked the BD PROCHOT, Turned on, ran the test (Cooling policy active) CPU still lazes around on 1.7 and even went into power savings mode inthe middle >.>...

11-18-2011, 02:19 PM
Which model do you have again?

11-19-2011, 02:49 AM
With my G74 I had trouble with Turbo Boost under Linux (all cores never exceeded 2.0 GHz), until I installed a newer kernel that had ACPI compiled into it (now cores fly up to a sustained 2.925GHz for single threaded apps; 2.7 GHz for all 4 cores running). The G74 does not have ACPI implemented in hardware (i.e. BIOS) so Turbo Boost relies on software ACPI (i.e. in the OS: windows in your case). Specifically the Thermal Management features of ACPI are needed. Ensuring that this is fully enabled under Windows I suspect might solve your problem.

BTW, the cores of the 2630QM CPU will never hit their maximum 2.9 GHz under Windows in the G74: the most you can expect is 2.6-2.7 sustained, and maybe 2.8 for a short burst at the beginning. A peculiarity of the G74 and Windows.

11-19-2011, 08:34 AM
2630QM, 4 core max 2,6GHz, no bursts there that could go over this. 2 core max 2,8GHz and 1 core 2,9GHz.

2670QM, core maxes in order 2,8GHz, 3,0 and 3,1 for single core.

http://en.wikipedia.org/wiki/Sandy_Bridge <- scroll down for mobile cpu's.

I've tested my 2670 with ThrottleStop benchie and hwinfo64 for accurate clock readings from each core. It works just like it's supposed to.
Occasionally 1-core alone goes for its max, so do the 2 first cores together, and the 2 last cores go to their 4-core maxboost readings respectively.

11-19-2011, 03:53 PM
Sounds like you got a good G74 then, and that the problem of the 2630QM never reaching its full performance may be a peculirity of that chip itself in combowith the G74 system. If you're curious about the issue anyways, check out:

11-19-2011, 04:20 PM
Not me... Mine is a G73JH.

System Information
Time of this report: 11/19/2011, 18:17:58
Machine name: SOME1-PC
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506)
Language: Hebrew (Regional Setting: Hebrew)
System Manufacturer: ASUSTeK Computer Inc.
System Model: G73Jh
BIOS: BIOS Date: 10/30/09 15:13:23 Ver: 08.00.10
Processor: Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz (8 CPUs), ~1.6GHz
Memory: 8192MB RAM
Available OS Memory: 8116MB RAM


11-20-2011, 06:33 AM
Question still stands... sorry for doublepost.

11-22-2011, 06:38 AM
Sounds like your 720QM is running exactly as Intel designed it. The only problem is your expectations.

As more cores are active, these CPUs slow down. When all 4 cores are active, the maximum turbo boost is a multiplier increase of only +1. That's the maximum. If you are fully loaded and reach the power consumption limit, turbo boost is reduced to zero. That will leave you running at 1600 MHz and that's it. These early Core i mobile CPUs are not nearly as powerful as the latest generation.

A lot of software does not report turbo boost very accurately. Run ThrottleStop in monitoring mode and you will be able to see exactly what multiplier each thread is running at. If you want to see the maximum multiplier, try running a single threaded benchmark like Super PI mod. When a single core is active, the maximum multiplier is 21 but you will never see that multiplier. Why? Because Windows is full of hundreds of back ground threads that constantly need to be processed. As your benchmark is running, these threads continuously wake up the other cores so they can be processed. More cores become active, multiplier drops down. Cores go back to sleep, multiplier goes up. This is going on continuously. That's why you need a program like ThrottleStop that uses high performance system timers so it can accurately report exactly what your multiplier is up to. Turn on the ThrottleStop Log File option for a good look at what your CPU is up to and turn on the More Data feature too.

Your CPU can run for a few milliseconds here and there with the 21 multiplier but Intel did not design this CPU to run all 4 cores continuously at 2800 MHz. That's called marketing BS. The true speed of these CPUs beyond about 50% to 60% load is kind of sad. :(

11-24-2011, 05:43 PM
Thanks a lot!
I'm educated.