PDA

View Full Version : G46VW - No Sound from HDMI - solved, thanks!



dragonpride0
04-05-2015, 10:29 PM
Hi. I'm having issues getting sound to come out of the HDMI port when I connect it to an external TV, but I am getting video perfectly fine thru the HDMI. I had downgraded the OS from win8 to win7 and installed the audio drivers on the ASUS support page. However I can't get any sound to come thru the HDMI and from the TV.
I had even tried to set the default audio device under Playback Devices, but only the Speakers and Digital Audio (S/PDIF) are selectable and none of options was able to output sound coming from the TV
All sounds are still coming from the laptop's speakers. I tried uninstalling the VIA drivers and installed the realtek drivers which is also not working or installed as it only shows High Definition Audio Device as the sound device in Device Manager.

I am currently running out of ideas on how to get audio to output thru the HDMI port. Is it possible that the G46VW's HDMI port is only able to output video but not audio?

Pandur
04-06-2015, 04:14 AM
Assuming your G46 is like my G55 then your hdmi audio should show up as Nvidia hdmi output in playback devices. If you've installed the latest Geforce drivers they also contain the audio drivers.

C4RN1
04-06-2015, 04:31 AM
Install this driver

http://www.geforce.com/drivers/results/83082

Do a clean install and reboot. This should fix your issue.

TokoDude
04-06-2015, 06:56 PM
I had even tried to set the default audio device under Playback Devices, but only the Speakers and Digital Audio (S/PDIF) are selectable and none of options was able to output sound coming from the TV

I experienced this problem 2.

To fix it i did:

Download the latest driver (not from ASUS website). I used Driver Pack Solution for that it has a new driver.
If you got the latest update installed you may need to set your TV as default playback device.

If there's no sound coming out click right under on the sound Picture---> MIXER--> Enable all applications to have sound and turn your sound higher.

And like the other guys said it's important to have the latest NVIDIA update.

dragonpride0
04-10-2015, 03:44 AM
Install this driver

http://www.geforce.com/drivers/results/83082

Do a clean install and reboot. This should fix your issue.

Sorry for the late reply and thanks. I did the clean install and the TV shows up in the audio selection and is working perfectly. Thank you everyone for the help!

srmojuze
04-17-2015, 02:08 AM
Yeah a bit fiddly but generally the Nvidia HDMI works OK following steps like above. Cheers for the tip!