PDA

View Full Version : G750JM 'USB not recognized' while copying files



stanzlyf
04-13-2015, 04:57 PM
Hi guys,
my Asus G750JM with WIndows 8.1 have some problem while copying, a few days ago i often got BSOD while copying large files.
i do uninstall USBCharge program and now no longer got BSOD, but now i got another problem.
while copying, the transfer rate suddenly go down to 0 kbps and all usb suddenly disconnect and then connected again, including mouse. sometimes it show notification 'USB not recognized'
i try copy same files from other laptop to my hdd but i there's no problem. so i think its my laptop problem, not my hdd.

someone have same problem ?

please someone that have a solution post here
sorry for my bad english.
thanks

hmscott
04-13-2015, 09:25 PM
Hi guys,
my Asus G750JM with WIndows 8.1 have some problem while copying, a few days ago i often got BSOD while copying large files.
i do uninstall USBCharge program and now no longer got BSOD, but now i got another problem.
while copying, the transfer rate suddenly go down to 0 kbps and all usb suddenly disconnect and then connected again, including mouse. sometimes it show notification 'USB not recognized'
i try copy same files from other laptop to my hdd but i there's no problem. so i think its my laptop problem, not my hdd.

someone have same problem ?

please someone that have a solution post here
sorry for my bad english.
thanks

stanzlyf, details are important :)

What is the make/model of external drive (or enclosure if home built)?

For long transfers the Intel USB power saving mode isn't compatible with WD and a couple of others power saving modes.

Turn off the power saving mode using the application provide by the disk vendor, and turn off the power saving mode for the USB hubs via Windows Device Manager:

Western Digital - A USB 3.0 drive randomly disconnects and reconnects from a PC
https://wdc.custhelp.com/app/answers/detail/a_id/9588/~/a-usb-3.0-drive-randomly-disconnects-and-reconnects-from-a-pc

U1/U2 zip file
https://wdc.custhelp.com/ci/fattach/get/352718/0/session/L2F2LzEvdGltZS8xNDI5MDE4MjE4L3NpZC9fSXlyblJqbQ==/filename/U1U2.zip

48341

48343

Uncheck for all Hubs showing this tab/checkbox
48344

And, turn off the Disk power down in your active power plan
48345

**Power off laptop and disk and then power up again after making all these changes before testing again.**

If the problem persists, try plugging the USB disk on the right side instead of the left side - the right side has more power for powering external drives - or plug in a power adapter to your disk - or use the famous 2 USB connector cable to grab power from a second port.

Please let us know how it works out :)

stanzlyf
04-14-2015, 01:13 PM
Hi hmscott, thanks for your solution. it works on me
evidently its my USB power saving

stanzlyf
04-14-2015, 05:25 PM
hi guys, unfortunately i got another problem.
actually my right side USB port dont have problem.
but my left side USB still error while copying.
is that hardware issue ?
thanks

hmscott
04-14-2015, 10:38 PM
hi guys, unfortunately i got another problem.
actually my right side USB port dont have problem.
but my left side USB still error while copying.
is that hardware issue ?
thanks

stanzlyf, there have been reports of left side not having enough power to sustain long transfers, can you plug in the external device to a power supply, or use one of those split USB cables with a 2nd USB power connection?

You could try a powered hub, USB 3.0 / USB 2.0.

I wouldn't jump to the conclusion that it is a hardware failure outside normal incompatibilities. You can ask Asus:

https://vip.asus.com <== create a login, register your laptop, file a Technical Inquiry with the details stated clearly, and ask if you should RMA for repair.

Please come back and let us know if that works out :)