View Full Version : G750JW Built-in Webcam & Mic do not work anymore

04-15-2015, 01:45 AM
I'm having a frustrating issue that I've been trying to fix myself for a while now, but I haven't had any luck.
I can't figure out what specifically is causing my problem.

I purchased the G750JW last February and I absolutely love it. I still do, but my built-in webcam and
microphone do not work anymore. I don't mind that the microphone doesn't work because I have a wireless
headset/mic I prefer to use. I went to use Skype the other night and was surprised that my webcam wasn't
coming on. I haven't used the webcam in a while, so I can't say precisely how long it's been this way.

I attached a few pics below as well.

The mic shows up in the device manager and recording devices, but it's non-functional. I've tried updating and
re-installing drivers. Nothing.

The webcam doesn't even show up in the device manager. I can't find it when I go to add devices. No imaging
devices in the device manager. The mic shows up, as I said before.

I tried to use the mic set-up. Nothing. When I open the recording devices, I see the green bar next to the mic peak for
a second.

Someone told me to remove USB Charger Plus. I did so, but no results. I don't know if that was a valid solution
in the first place, but I was desperate to try anything.

As I said, I've tried to solve this myself - I've found a few threads on this forum with people who have the same issue, but I
just can't pinpoint what's causing mine.

Any assistance, advice, or suggestions are GREATLY appreciated.



11-05-2015, 07:13 PM
Hi ghostofgriever,
I have absolutely the same issue with mine 750JH.
Have you resolved it?

11-06-2015, 05:55 PM
Did this happen after Win10 upgrade? or just out of the blue? Do you have Win10?

11-06-2015, 06:45 PM
no, curently Win 8.1 installed.
but I don't know exactly when this problem happened.
and some time ago laptop was in service - mother board, HD, screen and keyboard were replaced by waranty.
so it can be some hardware issue also, may be they just not connected.