View Full Version : [SETUP] RAID1 AND RAID0 on two HDDs, Dual boot on RAID1

04-17-2015, 11:33 PM
Hi there,
i just kicked out the SSD for another 1TB HDD because i need the secure setup i've been using for work on a Clevo since years:

I use a linux installer to setup:
100MB get reserved as EFI partition and stay unused on the other HDD to keep same offsets on both HDDs for the following,
a 250GB and a 750GB partition on each HD.
Those four are type "RAID-member"; i join them pairwise:

250GB get mirrored as SYSTEMS, 250GB for operating systems
750GB get striped as DATAKAZE, 1.5GB for unsafe data

I setup the necessary partitions for Windows and Linux respectively on SYSTEMS.
I setup a Linux SWAP partition on DATAKAZE.

That worked fine for my Clevo that also featured an Intel onboard RAID.
On the ROG, of course nothing worked as expected because of that great UEFI innovation.
So at first, i backed up the keys from the setup menu.
I tried installing with secure boot switched off and switched on again. I deleted the keys and tried again.
I tried six kinds of installation media and listened to a lot of old music in the meanwhile:

Windows 7 pro 64bit DVD,
Windows 7 home 64bit DVD,
Ubuntu Studio 14.04 64bit DVD,
Linux Mint 17 64bit DVD,
Linux Mint 17 64bit live USB, and finally,
some partitioning tool i burned on a bootable DVD

In the end, i managed to install and login to an Ubuntu Studio (the one that would let me to partition), but it wouldn't fire up the VGA driver.
I guess it is completely unaware of the RAID it should be running on and bypassing the UEFI at all - and vice versa.
The Windows 7 loads from DVD but won't show the "progress bar" under the "Starting Windows" typo screen.

Tutorials and other helping threads never mention this elegant combination of RAID and dual boot.
Why does the STUPID embedded setup interface to the INTEL RST only allow for a single RAID0, spanning over all the disks??
How come UEFI has been in the making for ages but all those pre-OS bloat causes is tons of new trouble and more confusion than ever?
I want to talk to the captain! :mad:

04-19-2015, 01:04 PM
Ok, meanwhile i talked to the captain. Some new facts allow me to get more precise on:

Why does the STUPID embedded setup interface to the INTEL RST only allow for a single RAID0, spanning over all the disks??

I bypassed EFI by enabling the compatibility secure boot mode (CSM). The original RST menu appeared. When i entered [Ctrl]-[I], i had the option to setup two STRIPE arrays smaller than 100% of the drives.
But still no Mirror.
SwedeMike on freenode's #linux-raid channel told me to use linux' mdadm command with the -e imsm option.
He also linked me to the great white paper "Intel Rapid Storage Technology in Linux":
I could create those containers and i could create a STRIPE array, but when i tried to setup a MIRROR, i was shocked reading:

mdadm: platform does not support raid1 with 2 disks
This got even more definitive when i used

mdadm --detail-platform
From it's wikipedia article (https://en.wikipedia.org/wiki/Intel_Matrix_RAID) i learned that IMSM means "Intel Matrix Storage Manager".

But Intel states that it's chipset HM87 can do RAID levels 0,1,5, and 10 unless the BIOS enables it:

So the question to ASUS is:

Will i receive instructions to update my BIOS/EFI or do you prefer another RMA?

See also my blogPost on blausand.net (http://blausand.net/2015-04-18/intel-rapid-storage-technologies-rst).