PDA

View Full Version : How to disable hyperthreading



diriklet
11-19-2011, 10:37 PM
Hi, I have a G73SW and using the AMIBCP utility I managed to unhide the hyperthreading option in the BIOS setup. Windows 7 seems to ignore the setting though: if I disable hyperthreading in the BIOS setup I can still see 8 logical cores in Windows 7. To make it more puzzling, the coreinfo utility shows HTT as being disabled; it is as if the BIOS setting does what it's supposed to do, and Windows 7 is ignoring the setting.

Any thoughts/ideas?

Thanks

diriklet
11-20-2011, 10:13 PM
I also changed the number of physical cores in BIOS setup and that has no effect either, Windows 7 sees all 4 physical cores. But other options in the CPU Configuration menu in BIOS setup have an effect in Windows 7, for instance the Local x2APIC option.

Anybody? :)

junko_tamiya
11-22-2011, 03:50 PM
Run "msconfig".
Go to the "Boot" tab
Click on "Advanced options"
You can set the number of processors Windows can use from there.

diriklet
11-23-2011, 12:55 AM
If I set that to 4 it will enable 2 physical cores with HT enabled, not 4 physical cores without HT. That trick only works on Linux, where if I set maxcpus=4 I get 4 physical cores.

fostert
11-23-2011, 03:23 AM
Does that program ThrottleStop allow one to turn off HTT?

diriklet
11-23-2011, 03:46 AM
Never used ThrottleStop but I doubt it. It would either have to be done by BIOS or when the OS is booting up the CPUs.

dkillone
11-23-2011, 03:54 AM
Yeah, no options in throttlestop to turn off hyperthreading(not that ive seen).