PDA

View Full Version : G751 Sound Crackling Thread (The one thread to rule them all) [WORKAROUND]



Sanctrum
04-27-2015, 07:35 PM
So I have prepared another workaround... In short words, I have developed the portable application (and the service – pick the option you prefer :D) forcing the audio card to be powered by playing perfect silent 2 or 3 overlapping WAVE files in an endless loop. NO MORE ANY NEED to play with registry or to play with mic configuration and muting. You can restore the default configuration and use the app/service as is. AND it is working ALSO after changing the speakers setup at Realtek HD Audio Manager from stereo to 5.1 and opposite.

WARNING!


Use the app/service at your own risk!
I am not responsible for any direct or indirect SOFTWARE NOR HARDWARE damages and losses, etc.
I DID not have the time to STRESS test it, however it is not CPU nor RAM consuming.
It has been developed and tested at Asus G751JY – not sure how it will work at different hardware setups and operation systems and its bizarre configurations.
The ZIP files with the app and service are posted at ROG Forum server in this very post. If you have downloaded the file from any other source… do not unzip and do not start the app do not install nor start the service. Just delete ZIP as it might be corrupted.
Do not replace nor rename the attached WAVE files as they are tailored to work the best with the app/service.
I do not know if the app/service is (or is not) impacting the sound playback (or any other functionalities) in the games and/or other software – so once again, use it at your own risk!
Please do not expect any answers for your inquiries, issues, problems and questions. I DO NOT provide any support for the app. I do not make money of it, I have a private time too… and I have already consumed far too many hours for the app/service development and testing…
If you do not agree to the above – DO NOT download and/or use the app/service and wait for the official fix of Realtek drivers.


HOW TO USE

Undo any previous workarounds (posted here: https://rog.asus.com/forum/showthread.php?59248-G751-Sound-Crackling-Thread-%28The-one-thread-to-rule-them-all%29&p=493219&viewfull=1#post493219) but you can leave the last regedit powermngt fix as is – no impact.

Download theses ZIP files: Play_and_Loop_dummy_sound_workaround_G751_option1. zip (325 650 bites = 318KB) and Play_and_Loop_dummy_sound_workaround_G751_option2_ v2.zip (527 115 bites = 514KB):

OPTION1 (to get the idea) download: >>>>> 48662 <<<<<
OPTION2 download: >>>>> 48737 <<<<< - the best workaround now.
Edit: using option2 24/365 since the release date and no problems with crackling...


Option 1. Just unzip portable app and TWO wav files to any folder you like, start the app (Play_and_loop_dummy_sound.exe) and press PlayInLoop button! That’s it. However after each laptop’s reboot you need to start it again…

48672

The app is alternately looping 2 wave sounds in 2 seconds period. The wave files are 10 seconds long so “the sound” never ends. After each 15 seconds the app is cleaning its RAM occupation – preventing taking it too much.

Option 2. If you are lazy as I am :) and want to have everything automatic done for you… Unzip TWO service setup files (setup.exe and setup.msi) to any folder you like and INSTALL the service (setup.exe). Once it is installed hit Win+R and launch services.msc to configure newly installed service. Browse to Play_and_Loop_dummy_sound_service check I it has Automatic startup mode… and start the service.


You can ALWAYS uninstall the service as any other piece of software by going to Control Panel (Uninstall a Program)
The service is working little bit different as the app… It is alternately looping 3 aliases of one wave sound in 1750ms period. The wave file is 10 seconds long so “the sound” never ends. After each 30 seconds the service is cleaning its RAM occupation – preventing taking it too much.
FIXED at service v2. So not any more relevant: Occasionally I can still hear the crackling sound in case of using the service option 2… FIXED
Option3. Do not use this workaround an wait for the official Realtek HD audio driver fix. :p

In the meantime “Enjoy the Silence”!

Some boring explanations…
I have encountered several annoying issues during the development (going to list them here):

Issue1. The workaround stopped to be working after each change in stereo to 5.1 configuration setup, and opposite. Had to do something about it.
So I needed to develop several routines of overlapping silent wave playback and looping... and to test them. Not all routines was solving the issue1. FIXED

Issue2. Somehow some looping routines introduced SEVERE white noise when MAXX Audio was enabled.
Again, testing and revising the looping routines and preparing better 48kHz silent WAVE files. FIXED

Issue3. The most annoying one. Some looping routines introduced crackling sound after each loop cycle - so the cure was worse than the disease.
Again, testing and revising the looping routines. FIXED

I have decided not only to develop the executable/portable App, but also nicely installable windows service that shall start automatically after each reboot.

The final issue4. The service was working but System.Threading.Timer's were probably started as different/random thread in each loop and this made things to brake somehow as not each loop was played… so in fact the audio card after some short time started its crackling like hell – again.
Again, testing and revising the looping routines – had to switch to System.Timers.Timer instead of System.Threading.Timer. FIXED


P.S. Please remeber to uninstall the service (Option2) before reinstalling any Realtek driver in the future...

ReeveJ
04-28-2015, 05:00 AM
Work-around option number two:

Step 1: Open web browser.
Step 2: Navigate to Google Translate.
Step 3: Minimize web browser.
Step 4: Resume normal computer use.

Alternately...

Step 1: Open a video or music file.
Step 2: Minimize player.
Step 3: Resume normal computer use.

No seriously though, nice work. Still waiting on the official fix...

Sanctrum
04-28-2015, 08:42 AM
Work-around option number two:

Step 1: Open web browser.
Step 2: Navigate to Google Translate.
Step 3: Minimize web browser.
Step 4: Resume normal computer use.

Alternately...

Step 1: Open a video or music file.
Step 2: Minimize player.
Step 3: Resume normal computer use.

No seriously though, nice work. Still waiting on the official fix...

Ha, ha... this is not persistent while you reconfigure your speaker setup, plug something into jacks, etc... as you would have to constantly stop and start the playback again. Annoying. That is why the effective workaround is to start the playback every 2 seconds... that is the reason I have decided to develop the apps.

x7007
04-28-2015, 01:09 PM
It's almost the same issue like Logitech Z5500 Optical Digital issue that the sound had a latency issue where it took you 2 seconds to actually hear the sound . and the same fix you found is the fix for this too.

The microphone muting works properly and the last time I was able to talk through skype without an issue, I think it is the best Native solution if no one wants to use a 3rd programs, it's not bad, but just native usually is the best. compare to the Z5500 you needed to use the software someone made. maybe it is better, I'll post it here.

I am not going to try to hook your thread but maybe you can see what he used and make it better ?

http://www.zecil.com/2014/01/18/continuous-silence-v2-released/

http://forums.logitech.com/t5/Speakers/Z5500-SPDIF-Slow-Response-FIXED/td-p/634532

If you can't download I upload the file.

Sanctrum
04-28-2015, 08:53 PM
V2 of windows service released (option 2):

FIXED at service v2. So not any more relevant: Occasionally I can still hear the crackling sound in case of using the service option 2… but it’s tends to fix itself in several loops. If no, just stop and start the service again. That is why you must change the startup mode to Automatic (delayed)… as simple Automatic makes the service to start to soon when laptop’s system is not ready for playback yet and the workaround is not effective. Probably using DirectX libraries would fix it permanently… but I’ve never tried it. Maybe I will try to do something about it. Not satisfied? Use option 1 or 3.

Sanctrum
04-28-2015, 09:08 PM
It's almost the same issue like Logitech Z5500 Optical Digital issue that the sound had a latency issue where it took you 2 seconds to actually hear the sound . and the same fix you found is the fix for this too.

The microphone muting works properly and the last time I was able to talk through skype without an issue, I think it is the best Native solution if no one wants to use a 3rd programs, it's not bad, but just native usually is the best. compare to the Z5500 you needed to use the software someone made. maybe it is better, I'll post it here.

I am not going to try to hook your thread but maybe you can see what he used and make it better ?

http://www.zecil.com/2014/01/18/continuous-silence-v2-released/

http://forums.logitech.com/t5/Speakers/Z5500-SPDIF-Slow-Response-FIXED/td-p/634532

If you can't download I upload the file.

The workaround you posted is having the same issues as described by me it the post above yours... It is simply not PERSISTENT. You have to constantly start/stop this app each time you reconfigure the speakers config (2.0 -> 5.1 etc... or other) at Realtek HD Audio Manager. In that understanding it is not persistent at all - so simply annoying.

So mine workaround with the service release version 2 is PERSISTENT and now perfect. This was the main goal and the reason I have started to develop the service... to make it fully automatic and persistent... and not to fool-around with pausing youtube playback or reapplying mic mute after reconfigurations and other interferences.

x7007
04-29-2015, 03:50 AM
The workaround you posted is having the same issues as described by me it the post above yours... It is simply not PERSISTENT. You have to constantly start/stop this app each time you reconfigure the speakers config (2.0 -> 5.1 etc... or other) at Realtek HD Audio Manager. In that understanding it is not persistent at all - so simply annoying.

So mine workaround with the service release version 2 is PERSISTENT and now perfect. This was the main goal and the reason I have started to develop the service... to make it fully automatic and persistent... and not to fool-around with pausing youtube playback or reapplying mic mute after reconfigurations and other interferences.


ok, nice program then, should have all what everyone needs.
Thanks

racerace
09-15-2015, 03:12 PM
Thank you!!

warryabel
09-15-2015, 04:06 PM
this tread help for mehttps://rog.asus.com/forum/showthread.php?59248-G751-Sound-Crackling-Thread-%28The-one-thread-to-rule-them-all%29&p=536626#post536626

NitroX
01-15-2016, 02:01 PM
Sanctrum you're amazing dude. Thanks for this fix. I've actually learn to live with the small crackling sound as it wasn't really that annoying, but tbh I'm pretty glad to have found this thread because now I can work on my notebook in complete silence. It was most unpleasing when I was browsing the news feed on facebook cause the sound would play whenever an animation or video appeared in the news feed...

I'm also going to try and come up with a tutorial to make our G751 more quiet during low stress usage like writing or reading, surfing etc, stuff that you have to do in silence. And your trick with the service will definitely be present on that list along with a NBFC profile and a custom Power Plan to lower the heat. My idea is to try to make use the passive cooling capacity of the notebook when a lot of processing power isn't needed so I'm gonna see how that works out. At least, if I see that it won't be too reliable then I'll use it myself :)).

Thanks again and if you find a permanent solution to the crackling sound please let me know.

x7007
07-03-2016, 12:28 AM
Sanctrum you're amazing dude. Thanks for this fix. I've actually learn to live with the small crackling sound as it wasn't really that annoying, but tbh I'm pretty glad to have found this thread because now I can work on my notebook in complete silence. It was most unpleasing when I was browsing the news feed on facebook cause the sound would play whenever an animation or video appeared in the news feed...

I'm also going to try and come up with a tutorial to make our G751 more quiet during low stress usage like writing or reading, surfing etc, stuff that you have to do in silence. And your trick with the service will definitely be present on that list along with a NBFC profile and a custom Power Plan to lower the heat. My idea is to try to make use the passive cooling capacity of the notebook when a lot of processing power isn't needed so I'm gonna see how that works out. At least, if I see that it won't be too reliable then I'll use it myself :)).

Thanks again and if you find a permanent solution to the crackling sound please let me know.

Works , no need for software !

https://rog.asus.com/forum/showthread.php?59248-G751-Sound-Crackling-Thread-(The-one-thread-to-rule-them-all)&p=591512&viewfull=1#post591512

Sanctrum
07-06-2016, 09:42 PM
Works , no need for software !

https://rog.asus.com/forum/showthread.php?59248-G751-Sound-Crackling-Thread-(The-one-thread-to-rule-them-all)&p=591512&viewfull=1#post591512


Please check separately if it fixes both: headphones and laptop speakers popping with 6.0.1.7687 driver. Because you know... with the old drivers in my case the registy fix was always working with the headphones... but not fixing popping at speakers.

Maybe it is better with 6.0.1.7687. Also the driver is for win10 only? Can it be used at win8.1? Has it Maxaudio?

Also please note that it is still possible that in my case I have 2 audio issues at the same time: the driver issue (fixable by registry tweak) and the hardware issue (maybe the woofer related - fixable only by my service). But maybe in your case you have only the one root cause.

x7007
08-30-2016, 12:08 AM
this fix the problem for me

http://forum.notebookreview.com/threads/fix-for-realtek-sound-popping-and-or-high-pitched-tone-squeal.587521/page-7#post-9827010


Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Realtek\Audio\RtkNGUI64 \PowerMgnt]
"Enabled"=dword:00000001
"DelayTime"=dword:0000000a
"OnlyBattery"=dword:00000001
"PowerState"=dword:00000000


no more popping

Halil
01-22-2018, 07:56 PM
Works , no need for software !

https://rog.asus.com/forum/showthread.php?59248-G751-Sound-Crackling-Thread-(The-one-thread-to-rule-them-all)&p=591512&viewfull=1#post591512

Hi,
Man I need help about that my speakers not working... only making click sound like all time or when speaker should work like playing videos on youtube. click sound stops only when i silence volume or using headset This is my Thread please visit guys i need help only problem with this laptop sound problem... https://rog.asus.com/forum/showthread.php?97969-Asus-G751JT-Speaker-Don-t-Working-and-Click-Noice&p=690226#post690226

https://www.youtube.com/watch?v=hsrZiPs5FxE