View Full Version : G73jh battery woes

04-28-2015, 12:17 AM
So recently the battery on my G73jh has been saying "Plugged in, Charging" however, the battery is not actually charging and remains stuck at 5% (i also am unable to change the critical setting to 0% so i cannot try a complete drain). I have tried a few different suggested fixes but none of them have worked. I restored BIOS defaults and uninstalled / reinstalled ACPI but it still will not charge. Granted, the battery is pretty old some I am leaning towards a dead battery.

Here is CPUID information for my current battery:


I also have a G53 that never gets used and its much newer than my G73 however, It has a problem itself with the battery staying at 0% and not charging. The G73 battery is rated at 14.6V and the G53 battery is rated at 14.5V. I thought maybe I could swap them out, however, when i put the G53 battery in the G73, it still remains at "0% plugged in, charging" but does not charge. Not sure if this is due to different voltage or if I somehow have two faulty batteries even though the other one never gets used.

My power cord does not need to be wiggled or anything in order to make a connection to AC. I am at a loss as to what to do now.