PDA

View Full Version : G751JY - Power Management plan keeps reverting to "High Performance" after boot



Space Paste
05-03-2015, 07:20 AM
Greets!

I'm seeing some strange behavior with my G751JY laptop's Power Management settings. I've recently noticed that the power plan reverts to "High Performance" from my customized "Balanced" plan, usually after a fresh boot or restart.

It seems like when this occurs, about 25% of the time the settings of ALL power management plans will be affected to use those that utilize greater power consumption, such as forcing the display to be on at all times and disabling automatic sleep timers on both battery and plugged in configurations. From what I gathered in my research after combing through numerous Google search results, this isn't exactly unheard of, but it doesn't seem specific to my laptop either. I'm struggling to determine what's causing the problem.

It's nothing I consider detrimental, but I find it annoying like nails to a chalkboard. I'm not seeing this occur on my custom PC. Would anyone be able to enlighten me as to what the culprit could be? Some ASUS related program? A stupid oversight on my part, perhaps?

Things I have tried:
- Restore defaults of all power management plans, then reconfigure the "Balanced" plan to my desired preferences
- Update all drivers pulled from the ASUS G751JY global support page, including the BIOS (now running 206)
- Reset the laptop via Shift+Restart for a clean slate, once again updating drivers from the official support page thereafter

Space Paste
05-03-2015, 12:08 PM
Disregard -- I found the problem.

Through Windows Event Viewer I was able to trace the offending program that was affecting power management plan settings. I matched a timestamp under "UserModePowerService" to the last occurrence of this issue that I managed to catch in the act. The program "WakeUp.exe", located in "C:\Program Files (x86)\ASUS\ASUS Screen Saver\Utility\WakeUp.exe" triggered this issue in no specific pattern and seemed pretty haphazard.

It's worth noting that based on the timestamps of this issue occurring, this wasn't a problem until I updated the ASUS Screen Saver program to version 2.0.8, found from the G751JY global support page. The stock version (2.0.5) did not exhibit this behavior, nor was the file hierarchy the same as the "Utility" folder is missing in the stock version and the "WakeUp.exe" program is located at the root of the "ASUS Screen Saver" folder. I've confirmed after one last factory reset and updating everything except the ASUS Screen Saver utility that the issue no longer occurs.

So, there you have it. Don't make the same mistake I did, folks. Derp.

QC_AGENT
05-03-2015, 04:33 PM
Thanks for the tip!