View Full Version : G46VW Bios Update Verification Failed - Partial Brick

05-07-2015, 04:44 AM
Posting this so it can help the community. When I searched for "G46 Bios Brick" I found a bunch of useless threads.

Since I brought this G46VW back from the dead I haven't been able to get the original wifi card (intel centrino bluetooth/wireless n 2230) to work correctly. I now have 3 of the exact same wifi cards and they all have similar issues. I think they are defective or have a common flaw since a generic mini pci-e atheros wifi card works perfectly.

I thought updating the bios might help correct the issue, since the bios on the new motherboard I installed was 205 and the latest update is 210. So I verified the correct bios, downloaded it and formatted a 4gb flash drive to fat 32. I extracted the file to the root of the flash drive and kept the original zip file on it as well.

Once I got into ez flash I selected the bios file and flashed the machine, after it was done writing the new bios, the verification failed to confirm that it was correct (I hate flashing asus g series notebooks (http://forum.notebookreview.com/threads/asus-g53sx-brick-after-bios-update-version-209.670844/)). I let the computer sit for several minutes after I tried to get it to respond. I had to hold the power button to do a hard shutdown. When powering it back up the cpu fan spun, the lights came on, even the backlit keyboard lit up but nothing on the screen.

If you're a G46 owner you know these laptops are funky and they take about 13 seconds to show video. The usb still functioned so I tried to recover by naming the file G46VW.BIN. Then I tried the home and ctrl keys to recover (which made the laptop power off a few seconds later). I tried a few more things, then decided to take it apart.

Once I took it apart I removed the battery connector and cmos battery and held the power button for 30 seconds (hard reset), which didn't solve anything. I removed the ssd, hooked it up to my external and put the G46VW.BIN file on the root of C:, again this didn't work.

I tried several things including holding the delete key, holding home + ctrl, and holding the esc key. I also tried to boot the computer without the ssd to see if it would default to the bios, which didn't work. Finally once I had everything hooked back up I pulled the flash drive out while the computer was still on and had been sitting for a few mins, and the bios screen magically appeared. I really don't know what I did to get it to post with video.

The bios could see my ssd, but wouldn't boot windows. I had to disable secure boot and enable launch csm and pxe oprom to get back into windows.

Sadly this didn't fix my wifi/bluetooth woes, but I plan to upgrade to the intel ac wifi/bluetooth.

Here's a picture that confirms my bios is now 210, but it isn't the G46VW.BIN I renamed, it's the original one I flashed the computer with.


If you know exactly what I did get get it to post and show the bios screen then please respond to this to help others out. If you're having the same issue as I did, I can only suggest to do everything I did and hope for the best.