PDA

View Full Version : Intel's Wireless Adapter 7260 Troubleshooting - Ping Issues



NitroX
05-08-2015, 02:03 PM
Hello people!

I have seen many users around here that have had trouble with the Intel 7260 Wireless adapter. It seems that I've skipped this issue until now as I have used a cable connection most of the time but recently I had a Youtube buffering problem and while investigating the source of it I came across my ping issue... See below:

49033

Now, those ping spikes really shouldn't be there and I saw that I am definitely not the first one to have stumbled across this problem.

I would like to start this thread and share the experiences/informations/solutions that everybody has found while trying to solve this issue. I am quite annoyed by this problem to be honest and I could really use some tips on what other solutions I could try.


Until now I have done the followings:

1) Added "ScanWhenAssociated" DWord(32bit ) key to registry . This solved half of the lag spikes. This solution stops your wireless card from refreshing the wireless networks list which also causes high ping spikes (around 1000-2000ms). You can test this by going to run --> Cmd --> and write Ping (Your Router Ip Adress) -t (for example: "ping 193.127.1.0 -t" without ") and then click on the wireless icon on the taskbar. If you have a problem then you'll see that the ping goes way up when you click on the icon and the wireless network list appears and refreshes at the same time.

If anyone needs more info about this solution, you can access the link over here and go down to Post Number 7: https://communities.intel.com/thread/53294

2) I have tried to work around with my router settings and with my wireless adapter settings:

Router:
- Selected a unique channel for 2.4Ghz
- Made a DNS test and it seemed that the one I was using was indeed the fastest available. And I do not use Dynamic DNS
- My WLAN is on 2.4Ghz , Channel 6 , Bandwidth 40Mhz, and Transmitting power 100%, and QoS WMM as recommended by Intel
- I have also tried chaning the Beacon Interval way down to 350ms but without success
- The Security was checked with both WPA/WPA2 PSK + AES Encryption and with only WPA2 PSK + AES Encryption with no successful change in ping spikes
- I have set the security and firewall to minimum without any positive result

And this is just what I could point out at the moment.

Wireless Adapter:
- I have updated to the latest driver Intel's 17.16.0
- I have disabled the "Allow the computer to turn off this device" in the adapters Power Management tab
- I have disabled Bluetooth
- I have disabled U-APSD Support
- I have set HT (High throughput ) mode to both HT and VHT
- I have set the Transmit Power to Lowest (In order to remove most of the interference with neighbors routers (I am still getting good signal from my router as it is right next to my room)
- I have selected "2.4Ghz Band Preffered"
- I have set roaming aggressiveness to "Lowest", though this setting won't have any effect if you are at home and you have a very good signal from your own router. (But it is worth the damn try... I was getting nuts by the time I got there).
- I have disabled all the "Wake On WLAN / WOWLAN" settings but also without any success

What I find odd is that at "Wireless mode" I can only select from a/b/g ... Shouldn't it show an "n" option as well ? See below:
49034

Power plan settings: I have set the Wireless Adapter settings on Maximum performance for both Battery and Charging.

The router: I have also tested the router to make sure that it is not something wrong with it. At the moment I have only tested with my phone ( Xperia Mini Pro ) which gave these results:

Minimum ping: 2.44 ms
Average ping: 11.11 ms
Maximum ping: 39.5 ms
With a number of 500 packets, each packet being sent at 1 second.

From this test I can only assume that the problem is with my Intel 7260 Adapter, as many others. But I will try to make a test with my parents phones also, and with my wireless USB adapter.


So, from all these findings the only thing that helped with some of the ping spikes was the trick with the registry. After that nothing else made any damn difference... I mainly notice these ping spikes in online games like CS:GO or Heroes of the Storm. Even though I am not a pro gamer I still want to enjoy the time spent online and the money spent on this machine -_- .

I must add that I do not have any issues with the speed. I have quite a good wireless speed which gives me around 13-15 MB/s download on uTorrent. The problem is just the damn PING!!!


For more Info's about Intel 7260 Adapter settings you can access these links:

1) Full list of explained Adapter settings: http://www.intel.com/support/wireless/wlan/sb/CS-025393.htm

2) Recommended settings for "802.11 n" connections : http://www.intel.com/support/wireless/sb/cs-030709.htm

3) A list with frequently possible solutions (Maybe someone would find these helpful) : http://www.intel.com/support/wireless/wlan/sb/CS-034658.htm

NitroX
05-09-2015, 07:17 AM
Ok guys, I have come back with new results. So, in order to further narrow the possible problem area I have done some other test. In fact, I have spent more than half a day yesterday with these tests (Thank you Intel for this great opportunity ...).

The meaning of the tests was to see if the problem is coming from the router (faulty hardware, bad driver, radio interference etc.) or from the Intel 7260 Wireless card. In order to test both the router and the Intel 7260 I have done the following:

1) Used Ping Plotter with 1 second refresh time and a graph for the last 10 minutes

2) I have changed between 802.11n, 802.11g, 802.11b only standards on 2.4Ghz. Unfortunately, my router doesn't support AC nor Dual Band to use 5 Ghz technology.

3) I have also used an USB wireless adapter: D-link DWA 171 which has 802.11 g/n/AC standards . It isn't a very worthy tool as you can read in many reviews but I got it free and I have done my job with it for these tests.

4) I have also tested the ping between the router and my Xperia Mini Pro Sk17i which has 802.11 b/g/n standards. So, for each test that I ran on the PC I was also testing with the phone. I do not have screenshots from the phone results but you can trust me on this one :).

PS: If you want to see the Router and Intel's 7260 Adapter settings that I have used for these tests please scroll down to the bottom of post #3 .

All tests were done with the same Router and Adapter settings, with changes only to the Wireless Mode 802.11 b only , 802.11 g only and 802.11 n only.

802.11n only test: So, I first started with the router set on 802.11 n only of course. You can from the results below that from time to time the ping was going nuts, like 1000ms (those high variations in the graph that reach the red area) . Now, each of these ping spikes are high enough to ruin your online experience by making 1-3 secs delays or even by disconnecting you from the server. As you can see, my speed is quite good. I am usually getting around 100mbps download and upload with speedtest. In uTorrent I usually get from 12 to 15 MB/s .

49045


802.11g only test: Now, we all know that 802.11n standard is better in many ways than 802.11g standard but look at the results below. Even though the speed is limited to a 54.4mbps the ping to the router is extremely normal compared to the 802.11n test. I know that there might be more interference on the 802.11n since every neighbor is using it but this is freaking ridiculous (don't worry, I have done a test to blow up the interference part also).
So, as you can see, there are no ping spikes with the 802.11g only standard.
PS: Don't worry about those variations in the graph. As you can see, the maximum ping was 38ms and the graph is scaled depending on the maximum and minimum values. So all those peaks are less than 38ms pings.

49046

802.11b only test: For this test the results were quite the same as for the 802.11g only but of course with a much slower speed. There were also no ping spikes that could ruin an online gaming experience.

49047

After these tests I have come to the conclusion that it must be something wrong with the 802.11n standard but I had to make sure that the router isn't the source of the problem. Therefore, I have used the D-link DWA-171 USB adapter in order to test again the 802.11n only ping.

802.11n only test with D-link DWA-171 USB Adapter: For this part I have run the PingPlotter test for more than 1 hour just to be sure that the router wasn't causing those annoying high pings. As you can see from the results below, the 802.11n only standard of the router performed way better with the D-link DWA-171 compared to the Intel 7260. You can only see there a ping-spike of about 600ms which I think it resulted from a song buffering or something because I was doing my home workout as long as the test was running. But excluding that ping-spike, the results are far better with this piece of crap USB Adapter than with the Intel 7260. And we will see further proof with the results while gaming in the next post.

49048

802.11b/g/n Xperia Mini Pro: As for the results from my ancient Xperia smartphone I can tell you that for each test I haven't gotten any ping issues with my phone. The average ping was always between 10-14ms and the maximum was around 20-30ms. These are not values to consider and these are another proof that the router itself doesn't have a problem with the transmission or packet receiving.

So, these results pretty much leave me with the conclusion that the Intel 7260 was some serious issues with the 802.11n 2.4Ghz connection. I am half relieved and half pissed off because I am glad to know that my wireless adapter doesn't have a hardware issue (since the ping on the other standards is normal) but on the other hand I hate to see that in 2015 the current standards aren't working and the much older ones are better. Seriously I was blown away by this -_- ! I am just hoping that this is a software related issue and that it will be solved by a driver update.


Read further on my next post if you also want to see the results from online gaming. I believe that this was the whole purpose of my trial after all.

NitroX
05-09-2015, 08:00 AM
As I said in the previous post, I have also done some tests while gaming because this is the main purpose for our notebooks. To be honest, I didn't even notice the ping spikes until I have opened CS:GO or Heroes of the Storm. When I was downloading or browsing the connection was performing quite well. I did have quite often speed drops in uTorrent but I just thought that was something with the peers...

For testing the online gaming experience I have chosen to use CS:GO because I could enter/exit at any time and I could see the ping spikes immediately since I was constantly moving/shooting.


802.11n only test with D-link DWA-171 USB Adapter:: I will first start with the results from the D-link Adapter because this was the order I used when testing. As you can see below there were some sort of higher pings at certain moments but still the maximum was of 150ms and this was happening quite often. I do want to highlight that this adapter is not a very good one and I must accept the fact that some of the higher pings come from the poor quality of the product. Even so, the experience in CS:GO was not disturbed. I could play without experiencing delays, weird weapons recharges or sudden deaths due to "lagging". The average ping to the router was around 4ms (as shown in the screenshot) and the in-game ping was about 25 ms.

49049

802.11n only test with Intel 7260:: Now, for the Star of the Show. As you can see below, the results were a little better than in idle. I don't know what happens with the card when it recognizes that you are gaming but the ping spikes were limited to a 281ms value compared to 1000ms (and sometimes even 2500ms) at idle. Even so, the online experience was a disaster. The moment I changed to Intel 7260 I noticed immediately that I have constant delays in-game, my weapons were acting weird when I was pressing "Reload" (the animation wasn't running but the sound was hearing), I was constantly seeing players "teleporting" (due to high response time, I often had interrupted gun fights). You all know what I am talking about.
As you can see in the graph, the gaming experience was altered by constant ping spikes between 100-200ms. This is considerable worse than with the D-link USB Adapter. Having an average ping of 35ms shows how many ping spikes occurred during gaming.
I strongly advise you to you something like PingPlotter if you want to test your ping to the router because the in-game ping was showing me around 27ms .


49050


802.11g only test with Intel 7260: And finally, the winner of the night is still the Intel 7260 but on the 802.11g standard. As you can see in the screenshot, the ping was way better than any of the other 2 tests, with an average of 2ms and a maximum ping of 24ms. The online experience was the smoothest and I haven't experienced any kind of stutter or delay (lagging). It seems that this time older means better.

49051



Final conclusion:
Ok, so the final conclusion of my tests is that the Intel 7260 is still going to work for us but not as it is intended. I am glad that I've found a way to enjoy my online gaming without experiencing annoying delays but I am disappointed because I have to change between 802.11g and 802.11n standards every time I need to download or to game. The 802.11n standard still works fast enough for download, but if you experience high ping spikes in online gaming I do advise you to switch to 802.11g only (at least until you finished gaming). Of course the 802.11g could still be used for downloading, but with significantly lower speed.

Now, these are the results and the solution that I have come up with, at least until the Intel 7260 802.11n standard will get fixed.
I have read many things on the internet in the past few days and I saw that many users recommend going for the Intel 7260 802.11AC standard with 5Ghz band because that will be much more stable and it will also offer you the high speeds you desire. But, for the unfortunate ones (like myself) that do not own an AC Dual-Band router or don't afford one at the moment, I am suggesting to keep calm and use the 802.11g standard for online gaming.


Later Edit: All of the above tests were conducted with the following settings:
Router:
Mode: IEEE 802.11b only/ IEEE 802.11g only/ IEEE 802.11n only
Band: 2.4 Ghz (Router doesn’t have 5Ghz)
Channel Width: 40Mhz (Only for 802.11n only)
Country: Romania
Channel: 6
Beacon Interval: 1000ms
Transmitting power: 100%
QoS Type: WMM
RTS Threshold: 2347
DTIM: 1
Authenthication: WPA2-PSK
Encryption: AES
Firewall protection: Lowest

Intel 7260 Adapter (Click on the adapter  Properties  Advanced)
802.11n Channel Width: Auto
Ad Hoc Channel 802.11 b/g : Channel 6
Ad Hoc QoS Mode: WMM
ARP offload for WoWLAN: Disabled
Bluethooth AMP: Enabled
Fat Channel Intolerant: Disabled
GTK rekeying for WoWLAN: Disabled
HT Mode: VHT
Mixed mode protection: RTS/CTS Enabled
NS offload for WoWLAN: Disabled
Packet Coalescing: Disabled
Preferred band: 2.4Ghz
Roaming aggressiveness: Lowest
Sleep on WoWLAN Disconnect: Disabled
Throughput Booster: Disabled
Transmit Power: Highest
U-APSD support: Disabled
Wake on magic packet: Disabled
Wake on Pattern Match: Disabled
Wireless mode: 802.11 a/b/g
PS: In the Power Management tab from the same Properties window, go and deselect: “Allow the computer to turn off this device”

Windows: Power Plan set on High Performance (Just to make sure there wasn’t something from the power plan options, but as the results showed, the balanced power plan wasn’t the issue). Just make sure to change your “Wireless Adapter Settings” to “Maximum performance” from the balanced power plan if you are using it.

Asoryu
05-12-2015, 02:54 AM
I've been fighting with ASUS for a month or more now trying to get a resolution, and nothing but poor service on their end.

Try uninstalling ROG Game First III, I've had the best results with that.

NitroX
05-12-2015, 09:51 PM
@Asoryu: Thanks for the advice and I'm sorry for your trouble. I do not have the Gamefirst installed nor any other ASUS bloatware. I have followed all recommendations available here on the forums and just the registry trick worked for me. The other part of the ping spike was caused by high wireless interference in the 2.4Ghz band. I do recommend that you give a look into this thread because you might solve your issue with your wireless.


Ok guys, so if you have read the whole thread right to this point then you might have had some serious issues with the wireless connection as I did and I do have some good news about it. Like I said in the previous posts, half of my ping spikes were solved by the registry trick which turn off the automatically refresh of the wireless networks list. But I was still having ping spikes when I was in idle or when I was playing online games (as you can see also in the previous post). It seems that, in the end, the problem with those high pings was caused by the increased 802.11n interference in the building were I'm living.

Okay, so what have I learn? After reading tons of messages and articles about Wireless setups and recommendations I have found that the most reliable channels for 802.11n standard at 2.4Ghz are 1, 6 and 11 for more reasons. One of the most important is that these channels are not overlapping and therefore there shouldn't be any interference between them. But, as with our modern 802.11n routers, we also have the option to set it on 20Mhz or 40Mhz bandwidth. Now, of course you will set it on 40Mhz if you want to reach those higher speeds of 300Mbps. But settings the bandwidth on 40Mhz means that you are going to use 2 channels instead of one (This is referred to as Channel Bonding) in order to increase the throughput of your router. The second channel will be automatically chosen to be at a distance of 4 channels. This means that if you are on channel 1 and you select 40Mhz bandwidth, then you will use Channel 1 and Channel 5 at the same moment. This also means that you will end up with greater interference with your neighbors routers, especially if they will also have the channel bonding (40Mhz) activated.


Were did I go wrong? To be honest, until now I have been using a random channel which wasn't used by my neighbors. That is one big mistake that I wouldn't recommend to anyone because the interference is much greater from adjacent channels than there is from using the same channel as your neighbors. So, if you don't have any of the channels 1,6,11 free then you should still use one of those channels, by selecting the one were your neighbors signal is weaker. For example, at first I have chosen to use Channel 6 as I saw that there were fewer people on that channel, but in the end I was still getting ping spikes due to interference. That was because those 2 other people on channel 6, were actually having a strong signal that was interfering with my own router. So, after checking all the areas of my apartment with the WiFi Analyzer on my Xperia Mini Pro smartphone, I have decided to select Channel 11 as my wireless channel. After doing so, it went great for a while but then I started getting ping spikes again... I was like WTF!! I was thinking again that my Intel 7260 is broken or something. Fortunately the Intel 7260 wasn't broken (not more than it is for others :)) ) and it seemed that the ping spikes were coming again from radio interference. Now, there were less people on channel 11, but there were also some guys on channels 8 and 13... So, thanks to those guys the adjacent channel interference was very strong and it resulted in poor response between my router and my laptop. PAY ATTENTION: The distance between my router and my notebook is about 6 meters and there isn't any brick/concrete wall between them so the signal was damn good and the speed was also good.
So, after thanking those guys from channels 8 and 13 for ruining the wireless networks of all other neighbors I was left with the only recommended channel available which is Channel 1. After choosing to run on 802.11, 2.4Ghz on Channel 1, the ping spikes while gaming and watching videos online was much better.


Sorry for the long story guys, but if you wanna skip all those infos I will make you a list of instructions on how to minimize your radio interference in a wireless crowded area.


So, in the end, after excluding the channels that caused interference and selecting one which allows me a smoother experience I have come up with these results:

1) Intel 7260 802.11n only Channel 11 while playing CS:GO : This is how it was on Channel 11 for a while. It was all much better both in idle and while gaming.

49147

2) Intel 7260 802.11n only Channel 11 while playing CS:GO: This is how it was on Channel 11 after some time, then the interferences started being worse:
49148

3) Intel 7260 802.11n only Channel 1 while playing CS:GO: And this is how it is now on Channel 1. It seems stable for more than 3 days now and I'm hoping to remain so because otherwise I will be forced to go for a Dual-Band router and use the 5Ghz band -_- .
49149


Now, these are great results and I can finally enjoy my online gaming experience without annoying delays. But, on the other hand I have found something quite odd. As you can see in the screenshot below, at idle, I'm still getting some random ping spikes of about 1000ms. But this is happening just at idle! While I am gaming or when I am watching movies on youtube, those ping spikes are gone. Why do I say it is odd? Because even though I have selected Maximum performance in the Power plan settings, and deselected the option of "Allow this computer to turn off the device" I'm still getting these variable time responses. They might just be caused by the router which might have some kind of power management settings itself but on the other hand, these ping spikes never come up in the 802.11g only or 802.11b only settings. It is indeed odd and it might be something from the Intel 7260 as well, or who knows, maybe the notebooks motherboard doesn't give it enough juice while in idle... There are a couple of variables that might influence these results. If anyone dares to find a good explanation for these things I would be grateful and eager to listen to them.

4) Intel 7260 802.11n only Channel 1 while idle:
49156

And here is an example of my wireless speed made just today, after solving the issues.

49157

vincentvega
05-12-2015, 10:12 PM
I had the same issue, but with 5 GHz AC connection the first mentioned solution* worked, and now I haven't experience any lag spikes anymore.
* " 1) Added "ScanWhenAssociated" DWord(32bit ) key to registry . This solved half of the lag spikes. This solution stops your wireless card from refreshing the wireless networks list which also causes high ping spikes (around 1000-2000ms)."

By the way I'm using this laptop with ASUS RT-AC56U router.

NitroX
05-12-2015, 10:18 PM
I had the same issue, but with 5 GHz AC connection the first mentioned solution* worked, and now I haven't experience any lag spikes anymore.
* " 1) Added "ScanWhenAssociated" DWord(32bit ) key to registry . This solved half of the lag spikes. This solution stops your wireless card from refreshing the wireless networks list which also causes high ping spikes (around 1000-2000ms)."

By the way I'm using this laptop with ASUS RT-AC56U router.

Yep, I know that the 5Ghz band is much more better and the response time is greatly improved but I do not own a dual-band router and I had to work out something for the current one that I own :). It seems that everything can be solved on the 802.11n, 2.4Ghz too but with more work. It was kinda interesting for me and I did learn some great things from this experience. I did lost about 3 days to acquire all these info's and make the thread though... Hopefully I will make up the lost time :P.

Fischer
02-17-2016, 01:00 PM
I made an account to this forum only to give you this soution because it happens that I have the same problem as you described here. I own an AC56U and recently got myself the Intel AC7260. Installed the latest driver 18.32 and everything was fine, till i had some high ping spikes in online multiplayer. I decided to run a batch file so I could record my ping over a period of time via Wireless 5Ghz AC. The speed is very good, i have no problem with that, i got about 45-50MB/s through my network, and my internet tops out at 290Mbps (ISP provides 300Mbps connection). What i found out is that, from exactly 10 to 10 minutes, i had a major lagg spikes for about 4 seconds with ping over 200-300ms. So i tried all kind of fixes that i found on the internet, and none of them worked, I was going to return the WiFi card, but i found a program named WLAN Optimizer, which I didnt believe to work, but decided to try anyway. Here's the link http://www.martin-majowski.de/downloads.html . I run the program with Autoconfig ON, Background Scan OFF, Streaming mode ON, and I recorded my ping and NO PING SPIKES. This guy who wrote the program is a genius, this problem was driving me nuts. I played some online games and no hiccups everything is fine. THIS SOLVED MY PROBLEM and i think it works for every Intel AC 7260 card. I tried the program for another card which was having constant 1-2 minutes lag spikes, an Intel WiFi 5100 AGN and no ping laggs at all. Share this solution with as many people as possible, maybe for some works.

Have a nice day and enjoy your Intel AC 7260 :)

MrRuckus
02-17-2016, 05:58 PM
That program seems promising. Thanks for posting it. Im going to give it a go.

driver345
04-14-2017, 04:07 PM
I made an account to this forum only to give you this soution because it happens that I have the same problem as you described here. I own an AC56U and recently got myself the Intel AC7260. Installed the latest driver 18.32 and everything was fine, till i had some high ping spikes in online multiplayer. I decided to run a batch file so I could record my ping over a period of time via Wireless 5Ghz AC. The speed is very good, i have no problem with that, i got about 45-50MB/s through my network, and my internet tops out at 290Mbps (ISP provides 300Mbps connection). What i found out is that, from exactly 10 to 10 minutes, i had a major lagg spikes for about 4 seconds with ping over 200-300ms. So i tried all kind of fixes that i found on the internet, and none of them worked, I was going to return the WiFi card, but i found a program named WLAN Optimizer, which I didnt believe to work, but decided to try anyway. Here's the link http://www.martin-majowski.de/downloads.html . I run the program with Autoconfig ON, Background Scan OFF, Streaming mode ON, and I recorded my ping and NO PING SPIKES. This guy who wrote the program is a genius, this problem was driving me nuts. I played some online games and no hiccups everything is fine. THIS SOLVED MY PROBLEM and i think it works for every Intel AC 7260 card. I tried the program for another card which was having constant 1-2 minutes lag spikes, an Intel WiFi 5100 AGN and no ping laggs at all. Share this solution with as many people as possible, maybe for some works.

Have a nice day and enjoy your Intel AC 7260 :)



Fischer, I have to thank you for this post, after updating to new Windows 10 Creators my wireless speed has dropped about 25% with latest Intel Pro driver 19.50.1 so I tried you Wlan Optimizer program and it worked increasing my wireless speed about 50%. Once again thank you.