PDA

View Full Version : Backlit G750JZ not working!



icevn13
05-13-2015, 03:20 PM
Hello
My G750JZ is running on Win 8.1. And my problem is backlight of my keyboard. I'm trying to use Fn+F3 or Fn+F4, it's not working, but using Fn+F5 or F6, F9, F10, F11, F12, it's working normally. I just see small light with capslock button when i turn on or when i'm using this keyboard. I've installed ATK Package 1.0.0034.
So plz help me to solve this problem!

GottiBoi55
05-13-2015, 04:42 PM
Hello
My G750JZ is running on Win 8.1. And my problem is backlight of my keyboard. I'm trying to use Fn+F3 or Fn+F4, it's not working, but using Fn+F5 or F6, F9, F10, F11, F12, it's working normally. I just see small light with capslock button when i turn on or when i'm using this keyboard. I've installed ATK Package 1.0.0034.
So plz help me to solve this problem!

Hi icevn13, and welcome to the Asus ROG Forum.
Do you have the latest BIOS Version 210?

icevn13
05-13-2015, 05:08 PM
Version 210 already

code9523
05-13-2015, 05:15 PM
Version 210 already
What you done before with it that lights gone?

icevn13
05-13-2015, 05:20 PM
I can't see backlit after i bought this one. I just download and install drivers from Asus support. Everything is okay without backlit.

code9523
05-13-2015, 05:33 PM
Dou you have serial number of laptop on firs page of bios? Is this laptop refurbished?

icevn13
05-13-2015, 05:37 PM
This is ref product, and dont have serial on first page

icevn13
05-13-2015, 06:19 PM
Can i fix this problem ?

code9523
05-13-2015, 06:42 PM
PM me with your email i'll can share you fix for it))

GottiBoi55
05-13-2015, 10:29 PM
laptop refurbished, that can be your problem.
Asus uses third party service to refurbish there laptops.
I bet the keyboard lights cable is not connected, or they broke the connection cable.

slvrshdw
05-14-2015, 08:51 AM
laptop refurbished, that can be your problem.
Asus uses third party service to refurbish there laptops.
I bet the keyboard lights cable is not connected, or they broke the connection cable.

This was the case with my JZ. I called ASUS and they were able to RMA it less than a week. I read the repair order when I got it back and did notice it saying the fix was just to reassemble though, so you may just have the plug for the backlighting disconnected.

wmkse
05-15-2015, 01:37 AM
Same here -- had to sent my JS for a repair just a couple days after purchase, when I realized that I'm missing something; it took them 1 day to fix it.
It seems to be an assembly quality issue, or a design flaw, like a loose connector...

C4RN1
05-15-2015, 02:42 AM
If the keyboard doesn't flash when the computer posts then the backlit cable is probably unplugged. You can take the computer apart and fix this yourself or you can RMA it.

In this video you'll see the thin orange cable when they flip the palmrest assembly over. This is your backlight cable that's probably unplugged.

https://youtu.be/Y0dkQ4rajyM?t=757

My advice would be to fix it yourself, you won't void your warranty if you don't break anything.