PDA

View Full Version : OS X Yosemite 10.10.3 on ASUS G750JM, G750JS, and G750JZ (osx86)



rigolo
05-14-2015, 12:34 AM
DISCLAIMER: THIS IS TESTED ON G750JM. WHILE IT SHOULD WORK ON THE OTHER MODELS MENTIONED, I CANNOT GUARANTEE THIS. USE A BLANK DRIVE WITH NO DATA ON IT TO START. DO NOT PARTITION YOUR CURRENT DRIVE IF YOU DO NOT WANT TO RISK LOSING DATA.

This is a guide for a mostly-working OS X 10.10.3 on the G750JM/S/Z series notebooks from ASUS.

This is assuming you want to install OS X on one drive, and already have Windows on the other. I have my OS X drive in HDD bay #1, and can easily switch between them with no problems. Shut down, then power on, is more successful for me than restarts. YMMV.

You will need a working Mac with a copy of App Store Yosemite 10.10.3 on it. If you have Mavericks, just download Yosemite and it will appear in your Applications folder. You also need a blank internal hard drive and a USB drive for installer.

I am going to try to make this super easy. All credit goes to the brilliant minds that make this stuff work. I just followed some instructions and used a bit of deductive reasoning. Everything I used is taken from other detailed posts; this is a basic guide for a beginner at hackintosh-ing to get up and running quickly, and/or for an advanced user that can further improve upon this.

Working (NVIDIA is disabled):

i7 CPU 2.4-3.4GHz
Intel HD 4600 with QE/CI
Trackpad with scrolling and both buttons working.
Apple HDA sound
Brightness via SysPref slider
Lid Sleep and Wake
BroadCom Wifi
Battery with percentage
USB 3
Audio Out / Mic
Webcam
HDMI
Keyboard backlight - stays on, not adjustable yet. I am using SmartTouchpad kext, which needs some tweaking to get brightness and backlight keys working I think.
Some function keys - volume, display off, etc.

Not working yet:

Bluetooth - fixable, I just don't need it much. I will probably patch it in soon.
Brightness and kb backlight adjustment keys, change brightness through Sys pref

This was built and tested on my ASUS G750JM, taking cues from Mavericks guides for mine and the JS model. It should work fine on all three models of this series - G750JM, G750JS, AND G750JZ, as the only hardware difference is the NVIDIA card, which is disabled.

Battery life is not too bad. I am getting about 3 hours of web use, with full brightness. Windows is not much better even with better power management.

Ideally, you want to remove all except your 1 blank Mac HDD or SSD (32GB minimum) from your ASUS to avoid confusion. I have 3 drives in mine, 1 where the DVD used to be using a converter bay (who uses dvds and cds anymore?!) It is easier not to be juggling too many partitions while doing this.

Steps (assuming you have already downloaded 10.10.3 Yosemite Installer, newest one as of this post, from App store).

On Mac:

1. In Disk Utility, partition an 8GB or higher usb stick using MBR format in 'options'. Make 2 partitions, first about 250MB and FAT format, the other for the installer. Name the larger second partition "osxinstall". I have used USB2 and USB3, 8GB and 16GB. You are fine either way. You can used a hard drive for this as well; I have only tried with a USB drive.

2. Mount and restore the clover.dmg file attached here onto the first, smaller partition. Clover has been set up for this computer and doesn't need modification. No need to disable Haswell through kernel modification, etc. Ignore all of that junk. Clover rules.

3. Open Terminal. Type:

sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/osxinstall --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction

On ASUS:

1. Go into your ASUS BIOS, do these (I have a hacked 205 BIOS that allows changing voltage, etc of NVIDIA card. The other guides had different stock BIOSes. I don't really think it matters):

a: disable vt-d in advanced
b: disable secure boot and fast boot in advanced
c: enable Launch CSM, leave PXE OpROM Disabled

2. Save changes in bios and exit, and keep pressing ESC key until boot options appears. Choose your UEFI drive, then choose OS X installer.

3. It might take a few minutes to boot into installer. Open Disk Utility, partition your hard drive with GUID format and 2 partitions again, the first is FAT 250mb, the second is for OS X Extended journaled. Name the first one 'clover,' the second one 'os x' so you don't get confused.

4. Install OS X onto large partition. It might freeze up on "about a second remaining," and require a reboot. Let it reboot and continue installation if this happens.

5. You should now be able to boot into OS X. Everything is done, all kexts and dsdt etc are integrated into Clover. You can edit the color profile to sRGB if you have any artifacts. Edge scrolling seems to be enabled by default along with 2 finger scroll. I am looking into disabling it, as my big hands keep hitting the edges of the trackpad while I type. Look in the info.plist in SmartTouchpad kext.

6. You can now restore Clover.dmg onto your first 250mb hard drive partition so you don't need to keep that USB in there.

7. For Apple HDA sound, download Kext Utility, and install the DummyHDA and EAPDFix.kext from below. You will also need to delete voodooHDA kext from clover partition. The detailed guide is at:

http://www.insanelymac.com/forum/files/file/372-applehda-for-alc282/

- the changes to Clover posted there have already been done - feel free to double check anyway. Make sure you have vanilla AppleHDA, and reboot 2x once done to enable.

8. Post here any suggestions, fixes, or obvious blunders I made in this mini-guide. Sorry if I missed something. Just wanted to get this out there. This is a great machine, and can run programs like Logic really well.

Hopefully all new changes can be made via Clover, so I will just update that as needed.

The clover dmg is too big to attach here so follow the link.

As of right now, to switch back into windows, you need to go into ASUS bootloader by hitting ESC key when restarting. I will fix this and a few other things, then post a new Clover.

Download link:

http://s000.tinyupload.com/index.php?file_id=48497985968874331397

rigolo
05-14-2015, 03:17 PM
Update: I have removed edge scrolling by editing the smart touchpad kext plist file. Trackpad, 2-finger scrolling, and buttons are really nice and smooth now. This is a great rig, and I am surprised how well OS X is running - my previous experience with a Dell was pretty clunky. Sometimes I am forgetting I'm on a PC! Of course, graphics-wise this is basically the equivalent of a new 17" MacBook Air. But luckily, windows is still there for sound and fury!

Just place the attached touchpad kext into your clover partition in clover/kexts/other and reboot. That will disable edge scrolling.

rigolo
05-15-2015, 06:48 AM
Update: have Apple HDA working. Bright and crisp sound now. The sound dongle I ordered hasn't arrived, I guess I don't need it now! Going to try to make this a clover-only solution then upload a new Clover. If not, I'll post instructions.

rigolo
05-15-2015, 07:37 AM
For now, you can fix AppleHDA using this guide:

http://www.insanelymac.com/forum/files/file/372-applehda-for-alc282/

I have updated Clover posted above, so all you should need to do is patch dummyhda and eapdfix from that guide, the rest is already done in clover.dmg. I also update the trackpad settings so it is: 2-finger scrolling, no edge scrolling, both buttons working.

rigolo
05-15-2015, 09:31 PM
Edit: I had sleep working, I must have broken something. Sleep is not working with the Clover I posted. I will update once I have it working.

rigolo
05-21-2015, 04:12 AM
Sorry for delay, I have been busy with other projects. Can anyone post their progress here? I see that some people have been downloading these.

meanestrage
05-23-2015, 02:58 PM
Sorry for delay, I have been busy with other projects. Can anyone post their progress here? I see that some people have been downloading these.

hey rigolo, i have been trying to boot into the osxinstall partition, when i get to uefi that boots fine and when i select my install osx it goes into the apple symbol then right after it gives me a circle with line through it. i have followed the instructions word for word lol, using MBP13 2009 with mavericks and osx10.10 downloaded trying to hackintosh my G750JS

Duron27
05-24-2015, 03:56 AM
Nvidia is disabled, does that mean just from kexts or you did some kind of a bios thing?

meanestrage
05-25-2015, 03:30 PM
Nvidia is disabled, does that mean just from kexts or you did some kind of a bios thing?

its only disabled in osx due to optimus

Devin179
06-06-2015, 06:39 PM
I get a circle with a diagonal line through it when I try to boot. Any suggestions? I am running a G750JM-BSI7N24 which has a core i7 4710HQ.

agentds
06-06-2015, 08:44 PM
getting the circle with the line inside of it.gonna play around with clover's config and maybe figure something out

ASUE
08-04-2015, 05:46 PM
For people who are having the circle slash problem it has nothing to do with flags you have to download "OsxAptioFix2Drv.efi" (google it) and replace "OsxAptioFixDrv.efi" (not the same file/name) in the clover partition of the usb. It bypassed the error for me... On the other hand i'm having problems with audio i have a G750JZ and for the life of me i can NOT find out which codec i have (mobo: Mobile intel HM87 Express) and what driver do i need to install.
A little help would be appreciated...

HominidSmash
08-07-2015, 04:40 PM
Does this work with G750JX?

luciangl
08-19-2015, 07:02 PM
I have windows installed now,can I make a dual boot with yosemite after I will install yosemite ?

raphaellus
09-28-2015, 10:00 AM
I have same problem, someone has a the file "OsxAptioFix2Drv.efi"

Thanks

samandhi
10-29-2015, 11:44 AM
I realize this thread is a little long in the tooth, and hasn't been active for a bit, but I can't find any other guides for this particular model to install OS X. My question is: can El Capitan be installed in the same way as Yosemite? I cannot find Yosemite on the app store anymore, though I can find El Capitan. I am typing from it now (albeit in VMWare Workstation).

Also, is anyone actively working on getting the things working that are (at present) not working? I would love to have a fully functioning Mackintosh that will run beside Windows.

Lunaraiyne
02-19-2016, 11:10 PM
I'm waiting for a 1TB disk to come in the mail, then I'll be trying my hand at this installation. There are supposed to be guides for upgrading to El Capitan on the Hackintosh website, have a look there if you haven't already. There are two months or so between your post and mine, after all.

Lunaraiyne
02-22-2016, 05:38 PM
Double-post, bah...

Lunaraiyne
02-22-2016, 05:40 PM
Well it worked. I was able to install OSX Yosemite following these instructions. I also had that crossed out circle problem, so I Google'd "OsxAptioFix2Drv.efi" and swapped it as ASUE said. Unfortunately I'm also having the same issues, I have no sound from the machine, and so far no fixes anywhere (assuming I'm doing them right, since I'm a novice at this) are working. Also can't seem to get the computer to recognize the OSX partition in the bios boot menu, or the Clover boot thing at all natively, only works if I have the USB drive plugged in. Guess it's like the keys to the Mac side, in a sense... Anyway everything else works fine so far, except for the two things that the OP meant to fix. I don't have two finger scrolling on my trackpad and it's really annoying, and I have no sound. So... if I find a way to fix either of those, I'll write back here.

Jam31337
02-28-2016, 06:37 PM
It would be awesome if you'd upload a working bootable USB image so we could restore it via disktool on a mac (real or vm, doesn't matter). This could help to get rid of plenty issues. Please do. Google disk or any other like dropbox, cloud mail.ru, yandex disk etc.

Jam31337
02-28-2016, 11:30 PM
please add a step-by-step manual on how to partition the usb drive. should i format the fat partition as mbr? should the second partition be also FAT or osx journaled? please update the manual

Jam31337
02-28-2016, 11:55 PM
when i use disk utility in my el capitan vm i have no option to partition my usb after it is erased as master boot record it is 8gb fat and that's all. need assistance. the best way is the one i've posted first: please upload a working image made of your usb stick somwhere online

Jam31337
02-29-2016, 04:12 PM
i've made one usb with fat and master boot record restoring the clover image from your post and second formatted as mac os journaled deploying the yosemite distributive onto it. booted with both usb's attached and choose install yosemite from usb in clover i get an apple logo for 5 seconds and then a crossed circle. tried couple of times the result is same. please help.

Jam31337
02-29-2016, 08:58 PM
Changing the "OsxAptioFixDrv.efi" file to the one from internet (googled it and replaced the one on clover usb disk) helped to install and boot to mac os x. on the setup screens there was a mess so i've restarted the pc and it became ok. After that i've tried to restore my time machine backup from my mac running el capitan and after the restore was complete the system didn't boot. I've googled this issu and now what i'm trying is to create an el capitan installation disk to reinstall the system to the partition where i already have my time machine backup restored if this fails i'll tr a clean install. and migrate my data via migration tool. if thi fails too i will try to install yosemite from scratch and play around with updating via app store or something. will notify you guys here about the progress. cheers

Lunaraiyne
03-01-2016, 04:25 PM
Whoa, gimme a bit to read up on your posts

Lunaraiyne
03-01-2016, 04:31 PM
Yeah, I don't think you're supposed to restore it via Time Machine, it'll use all of Apple's original files and whatnot, and it won't be booted at all. I used my external hard disk to transfer the data that I wanted over, mostly my music. I still don't have any audio on my system, not natively at least. I have an external USB interface that I use to record stuff, and it fortunately has audio controls. The system's audio settings recognized it, so everything is working very nicely now in terms of sound.. still don't have scrolling functionality on my trackpad, did you get yours to work, Jam?

And yeah, I keep a copy of my clover partition on a pen drive. If I somehow break the one on my drive by experimenting with kexts and stuff, I just boot from there and restore it if things go south. I only updated some apps via the app store, I'm kind of afraid of trying to update the OS itself from there. But well, if you have any luck, do tell and I'll go about it too. I'm staying on Yosemite, don't want El Capitan on my system

Jam31337
03-01-2016, 06:57 PM
At last you're back man! Glad to see you here! I thought this topic is dead))
So i will summarize what i already have tested and what doesn't work and needs to be fixed:
1. Dizzy menu bar after boot it's ok and as soon as i launch any app the bar gets dizzed this was solved by installing multibeast(read to the end so you'll figure out why i'm using past tense for the worb "solved')
2. Bluetooth doesn't work.
3. Sound not working BUT i have managed get it working installing the last option of Voodoo bla-bla in multibeast options for sound drivers. So there is no need for third party devices. And the hotkeys on the keyboard worked also!)
4. LAN is not installed at all (same as bluetooth as i understand). Didn't check if multibeast fixed it.
5. Two finger scrolling not working on my machine too, sad but true.

so after i've installed multibeast something went wrong with wi-fi and i went forward trying to restore with time machine backup i had on my mac with el capitan. no luck. i already have a scheme after we figure out how to get el capitan installed to our G750JM's: first, before installing the system we do a time machine restore and then install the el capitan so the files are kept where they were restored previously. maybe some apps will need reinstallation but 90%+ should work.
i'm needing aperture to get my photo archive back and then i will continue with tests. please see this link for DSDT patches that will help getting keyboard backlight and battery percentage working https://github.com/Arise/Asus-G750-Series-DSDT-Patches.

I want to help you develop this thread so we fix all these issues and help other guys have less headache. Please don't refuse continuing developing this work. I will do my best to help you. See the links below for more info i've digged up:
El Capitan guide
http://roghackintosh.com/index.php?topic=74.0
battery patching
http://www.tonymacx86.com/el-capitan-laptop-support/116102-guide-how-patch-dsdt-working-battery-status.html
related to G750 threads
http://roghackintosh.com/index.php?board=12.0
insanelymac search with our problems
http://www.insanelymac.com/forum/index.php?app=core&module=search&do=search&fromMainBar=1
kexts from tonymacs86
http://www.tonymacx86.com/downloads.php?do=cat&id=11
some stuff from hackintosh developers
http://roghackintosh.com/index.php?board=14.0
SSDT info
https://www.google.by/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=G750JM+SSDT

i need help understanding these kexts, ssdt's and dsdt's please assist

about moving the partition of cloverto hdd. i've created a partition in the beginning of my hdd with disk tool in the setup before starting it i couldn't make the partition size less than 1.07gb and made it fat and mbr, but when i make the second partition where i install the mac os x and make it guid the first fat partition also becomes guid so i cant restore the clover image on it an make it bootbale. any suggestions?

please feel free to update the yosemite and any other apps from app store it works ok. i've tested that.

Lunaraiyne
03-02-2016, 12:14 AM
Well in terms of development, I'm not very savvy or skilled. I just know to look around a lot and find answers, so I won't be THAT much help. Still, I'll do my best

The menu bar looking weird, fix that by going into the system settings and changing the color profile on display. I'm using sRGB IEC61966-2.1 and all of the weird colors and "artifacts" as they call it went away

I had actually ruined wifi and a lot of things on mine as well the first time I installed, so I had to do a fresh installation. I think it was something I did with multibeast, changed the computer's identity from being a MacBook Air to being a Mac Pro or something like that. Right now, in "About This Mac," mine is listed as a MacBook Air. Bluetooth is also not working, but I don't think I'll be using it, so I can live without it for now...

System updates work natively and don't ruin the thing? That's good news methinks, though I also don't think I need to upgrade from 10.10.3 for now, unless there's a huge advantage to doing it that I'm not aware of

And sound... I still have no sound, and I tried a lot of things. Going to re-read what you typed up there and see if it does me any good

And finally, the clover partition, that one was annoying. I tried to restore the image and make a partition, but it never worked for me. Never let me copy. The way I solved it was by downloading the "Clover Configurator" application. Once downloaded, disconnect your USB drive (If you're using it to boot, like I was using at first. Couldn't launch the UEFI without the USB). Once it's disconnected, go to the "tool" tab on the left, then "mount refi". Once the window changes, the bottom-right will say "Mount EfI Partition" and you click it. Once it mounts on your desktop, copy-paste the contents from the USB to there. If you can't see it when it mounts, you'll have to click on "Finder" from your dock (Also done by clicking desktop.) From there, you go to preferences, and in the general tab, check all the boxes so you can see everything that's plugged into the machine. That should make it so you don't ned the USB drive anymore, once you can see the EFI partition, copy-paste USB contents into it and you're all set. Keep the USB, in case we break something, to be able to boot back in.

Lunaraiyne
03-02-2016, 12:23 AM
Okay then, I'm going to update Yosemite and anything I can on the app store to the latest version, and hope that I don't break anything. If it works, then I guess I'll be able to use all of the fixes and whatnot you found. Will post back with results

Lunaraiyne
03-02-2016, 06:50 PM
Updating Yosemite worked just fine, everything is flowing nicely. Now there are things that you did that I didn't do, such as making the keyboard buttons work, like sound, brightness, and keyboard backlight, ne? I'm going to try to make those work right now.

As for the Audio, I don't really understand what to do there at ALL. Maybe my Multibeast is too old, or I'm picking the wrong option from the menu, but the times I've used it, nothing happens. I went to tonymac and got the latest Multibeast for Yosemite, are you using that one, or the one for El Capitan? And... you know, if it's not too much trouble, could you just number the steps to fixing that for me? I'm a little sick right now, so maintaining congruent thoughts is a little hard

Jam31337
03-03-2016, 11:18 PM
hi, yes i took the one for Yosemite and have chosen the last option for audio saying voodoo 2.8.4 but then the wifi is gone even choosing only one option (not changing the id of mac to macbook pro, it still stays mac book air as it was when wifi worked) i'm trying to find a solution to fix the wifi without reinstalling cuz my internet is very slowand i have already downloaded tons of software from app store i have bought years ago). th sound keys work themselves as soon as the driver gets installed (you need a restart). other things like brightness and keryboard backlight i informed you showing the info i've found but i didn't fix that yet. i have no understanding what a kext is what is ssdt and dsdt. if you can explain that to me i would be very grateful.

Jam31337
03-06-2016, 04:38 PM
Any news my friend? which version of clover did you use? maybe you could use a newer version of clover? also extract the hda driver from multibeast and edit the config.plist to use exactly the needed hda driver so we can get more things working? or change clover to chameleon loader? please think about this. i'm ready to use my g750 for experiments, so you don't have to spoil your system)

Lunaraiyne
03-07-2016, 07:21 PM
I've been using my G750 to make music nonstop for the last three days, haven't checked up in here.

I'm using the version of clover that the original post used, I was thinking of maybe changing to a different one to see if it helped, since this original post is two years old or something like that. That might actually fix all of our problems, but I haven't sat down to try it just yet. So far, applying any fixes isn't doing anything, so I think maybe just using a fresh install of clover will work

Now the other things, I only have ideas of what the are. Kext is kernel extension. The way I understand it, it's like a driver for the computer, essentially. And since our hardware isn't Apple hardware, we have to trick OSX into letting us use our hardware. That is why we have to patch kext and all of that annoying stuff.

Lunaraiyne
03-07-2016, 07:22 PM
I'm not very good at editing the config files yet, so I'm not able to do anything there. Like I had said earlier, I'm pretty new to all of this stuff too, so I'm learning as I go

Jam31337
03-08-2016, 05:45 PM
We need to grab someone clever in these things to this topic, so the work starts. We have pretty much information. Two successfull stories with installing and launching the mac os x on our G750JM's and we just need some little help tp go further and have a 99.999% working mac os x on our beastily awesome ROG's)

Lunaraiyne
03-10-2016, 06:20 PM
That's unfortunately true, though I do think that you and I have clarified whichever instructions seemed kind of vague, just as the OP Had asked. And for the most part, the machine is functional and I'm using it instead of my old 2008 MacBook. I got used to the lack of trackpad, even though it's really irritating when I want to do something in GarageBand.

Lunaraiyne
03-12-2016, 11:46 PM
Hey Jam, you'll never guess what I did to make the trackpad scrolling work... in the system preferences, without editing anything, I just cranked up the scroll speed to max and now it works like a charm. Try it if you haven't already.

Jam31337
03-13-2016, 08:05 PM
Hey Jam, you'll never guess what I did to make the trackpad scrolling work... in the system preferences, without editing anything, I just cranked up the scroll speed to max and now it works like a charm. Try it if you haven't already.

good one! i've tested el capitan copy for vmware and succesfully restored my time machine to it, so i currently work on it. will try this when i boot to mac). still waiting for someone to come here and help us)

Jam31337
03-24-2016, 04:58 PM
i've got a working image of el capitan for vmware and succesfully deployed my time machine backup on it so now i'll be using it for time until someone will make a step by step manual with 100% working hw for our 750 JM's

Lunaraiyne
04-04-2016, 02:56 PM
I've just been using Yosemite. Not interested in El Capitan at all. I think that maybe using Multibeast might be enough to restore functionality to the ethernet port and the Bluetooth if we wanted it. I haven't needed it so I haven't tried yet, but that's probably going to work.