View Full Version : The Witcher 3 & G551...

05-20-2015, 07:10 PM
yeah, I have started W3 with my G551JW (GT960M 4Mb) and results are as follows:
- it works smoothly with 30 FPS (setting from menu), Graphics set to HIGH (not ulter) and postprocessing maxed.
Resolution I use is 1366 x 780. Max temp is 80C. If I switch to 60 FPS, it still works smoothly, but sometimes (rarely) slows down. WIth full HD & 30 FPS runs badly. It runs smoothly with FHD when graphics preset is set to LOW only.
If I reset my GTX960M to standard, not overclocked, I must reduce resolution one step down, or change graphics preset to "medium".

G551 is fast enough to run The WItcher 3 with pretty high graphics settings and I'm satisfied with my Asus :)

05-21-2015, 09:32 PM
Its not acceptable to me that you have to lower the resolution. I would say its almost too much for a 960m.

After all, the minimum GPU req is a GTX 660 for Witcher 3. A 960m doesn't meet that but comes close.

Things look so much better if you run them at native display panel res. Im glad you're satisfied but I wouldn't go around advertising that it runs on "pretty high graphics settings".

I think, for most of us, we would want at least high settings @ 1080p and 60 FPS.

06-22-2015, 06:53 AM
Hi. I bought G551JW a week ago and Witcher 3 this weekend.
The game works tragically :( I try to play in low details in 1366 x 780 resolution and it doesn't work smoothly.

Can you tell me Piro:
1) have you update graphic driver (if yes, then from nvidia or asus);
2) what software to overclocking do you use on what settings?

06-22-2015, 09:38 AM
Ok.. I found the answer on page https://rog.asus.com/forum/showthread.php?61399-Overclocking-G551JW-with-GT960M ;)

06-22-2015, 03:47 PM
U R fast ;)

07-26-2015, 06:41 AM
hi , i play witcher 3 in full hd in high settings with 960gtx without problems , ill recommend u to update drivers, bios,

08-07-2015, 05:38 PM
I just got a GL551JW-DS74 and it seems to run W3 great. When I ran the game for the first time I set everything to medium and I was only getting 16fps. After updating the drivers using the geforce experience app I am now running the game on full HD, with high or ultra settings on everything excepts the hairworks (set to off) and I set ambient occlusion and Bloom to off in post processing. This machine was never going to run W3 on maxed out settings, but it looks great to me and gameplay is smooth. Played around 40 hours so far and haven't had any heat issues or slowdowns whatsoever. That includes long sessions without a cooling pad, I do prop up the back of the laptop on a book to give it more airflow though.