PDA

View Full Version : G74SX screen issue.



Mars
05-24-2015, 03:10 PM
Greetings all,

I'm having some difficulties with my G74SX notebook - specifically, the screen not displaying anything when turned on.

The laptop powers on and boots fine, and what appears to be a light behind the screen turns on and tints the otherwise black
reflection a dark gray colour.

I made sure to connect the machine to a television set via HDMI cable to verify its functionality.

Could someone tell me what's going on with the screen?

justinzon
05-24-2015, 09:17 PM
Did this happen out of the blue or was there something you did that led up to it ?
Have you recently opened it up for cleaning, perhaps not attached the cable correctly ?
This happens to me constantly.
I suspect a loose connector is shown in this image, which is from a G74sx.
49465
Before you go tearing your notebook apart though check some of these quick steps and see if it resolves it first.
http://www.computerhope.com/issues/ch001319.htm
Also try connecting to your tv set again, and while booted into windows, hold the function (fn) key + F8 to see if you can toggle between monitors.

Actually try these steps instead..
http://support.hp.com/us-en/document/c03518165

Mars
05-29-2015, 04:14 PM
I had to open up the notebook so I could replace the DC jack.

You were certainly right - I carefully reseated the LVDS cable you have indicated and the screen works.

Thank you so much.

justinzon
05-29-2015, 08:23 PM
Glad it wasn't something more serious.:)
Hope the DC jack repair went smooth...
Not something I look foreword to dealing with on mine.:eek:

Mars
05-30-2015, 12:10 AM
Once again, thank you kindly. For a little while I was afraid I'd need a brand new LVDS, inverter/screen or both.

To be honest, my desoldering job was very shoddy - I even expanded two of the board sleeves by mistakenly using a pin-vise to clear two particularly
stubborn metal tabs left behind by the old DC jack. Despite applying heat to the board dozens of times, the drilling, and having the behind of the
new jack a millimetre or so off the board, it worked fine after I soldered it in and tested. No problems since.

Mars
05-31-2015, 02:53 AM
Hey again,

My screen was working fine until an hour ago. All of a sudden, the display started to flash intermittently, and right before I shut it down, the screen began to flash in a more erratic manner while also flashing strange colours.

Does this mean the LVDS cable came loose again? Or is it something else?

justinzon
06-05-2015, 12:40 PM
I would assume but first try powering down, remove the power cable and battery for about 30 seconds.
Attach battery , cable & power up again to see if it works.

Only once has this happened to me were it wasn't the loose cable & removing the battery somehow reset things back to normal.
If that doesn't work though im going to assume its that cable connector again.
Remember, its gotta click in almost like a Lego piece.