View Full Version : G751J stuck in bios

05-30-2015, 12:46 PM

Upon posting this I could not start my laptop and was panicking because it was stuck in bios. The backstory is I left my laptop on for 10mins and it was fine in windows 8. I had no update scheduled and when I came back I was in bios menu. So I tried to quit without saving but it never let me. I then tried hitting f9 for optimised defaults and then tried to save and exit and I could exit bios that way but I got blackscreened for a second, no asus logo and again back into bios, I tried this a few times then turned off manually tried to turn back on but again same thing, black screen then bios. So then I turned it off finally giving up and found this forum. I just restarted one more time and it randomly works now, I am afraid to turn my laptop off or use it. Its less than a month old and I havent done anything besides update bios after i got it and it was running fine up until this happened. By the way I have the ssd that came with the laptop and another normal harddrive that came with the laptop, is there anything to prevent this from happening or running a test to find out why this happened? Thank you in advance

05-30-2015, 01:14 PM
Yes I would test that SSD it may be failing. Manufacture should have a tool to test it. If your within your return to Seller Period, you may want to do that. For what reason did you update the BIOS This should only be done if you have a specific reason too. Updating the BIOS is risky and is not recommended just because you think it will be better.

05-31-2015, 02:24 AM
Hi thanks for the reply, I only updated my bios because I went to the asus website and looked up my model and updated to the latest drivers and software accordinglybecause I wanted to make sure I had the latest updates basically. I updated my bios when I received my laptop (monthish ago) as it was part of a list of updates for everything. It was working fine up until yesterday when this occured. I will try to figure out how I can test the ssd. I have had no troubles since yesterday but I want to make sure it doesn't happen again. I backed up my data though