View Full Version : GL551JW-DS74 will not boot - no boot options

06-02-2015, 10:42 PM
I purchased my ASUS ROG GL551JW-DS74 two months ago and it has worked perfectly, until today. I turned it on, and it boots straight into BIOS. The DVD, SSD and HDD show up in SATA Config as expected, but nothing appears in boot options. I disabled secure boot and enabled CSM, and now only DVD appears as a boot option. I haven't made any other config changes, nothing prior to receiving the error. I haven't updated BIOS. Yesterday it worked great, today it doesn't. Can anyone give any suggestions on how to proceed from here?

08-03-2015, 04:56 AM
I am having the same problem with my GL551JW-DS74 purchased in May 2015 (worked great for 2 months). I have not changed anything on the BIOS. I am suspecting MB or HDD or SSD hardware failure. I don't have the skills to trouble shoot, so got an RMA and will ship the unit to ASUS Milpitas service center this week. I will post the outcome of the RMA repair once I get my laptop back.

08-03-2015, 07:25 AM
I would say that it sounds like an SSD/boot failure as I've seen this before when Backtracker screwed up my Windows install; the G751 seems to go straight to the BIOS if it doesn't find anything to boot from. Time to RMA it, I'd say!

08-03-2015, 07:18 PM
Same thing happened to me after 1 month. I tried EVERYTHING and ultimately came to the conclusion that the M.2 SSD failed. I sent it in for RMA, I'll let you know what they say.