View Full Version : Asus G751 Bios Flash Failed

06-07-2015, 04:19 PM
Hello , ive bought an ASUS ROG G751JT , its 2 days old , i wanted to upgrade the last bios , so i used Asus winflash utility , it restarted , then on the screen it sayd its erasing the old bios , and when it got to 10% it shuted down .
The laptop turns on , but screen is blank , keyboard light isnt on , is there any emergency bios flash on this laptop like on the old series ?
I tried holding ctrl+home with usb stick and image on it , but no succes .

Thank you .

06-07-2015, 07:14 PM
I had the same problem with my G751JY using Easy Flash from the BIOS.
Likewise, I tried everything. I have a thread about it:


I'm not saying you should give up ... but I had to return it for warranty. The process only took 2-3 days anyways, so don't worry, if it comes to it, they should fix it for you. They had to change the motherboard on mine but I got the M.2 socket for mine where the previous motherboard didn't have one ^^

I think the issue lay in that I tried to update from 205 straight to 207 instead of 206 > 207. That, or these things have very badly designed motherboards BIOS-wise :)

06-07-2015, 08:26 PM
I saw the thread couple of hrs ago , did you try to put the bios file in c:\ ? And rename it as .bin ?

06-07-2015, 09:28 PM
I said that I did in that thread :)
Plucked the drive out and put it into another laptop. I put 4-5 variations of the file in different names and extensions and in different folders. Nothing happened.

06-07-2015, 10:06 PM
Will the asus service see that i wanted to update the bios or not ?

06-08-2015, 12:18 AM
I tried all the possible combinations to start this laptop somehow to reupload the bios , but i just cannot make it to post anything , and why did it die suddenly ? ive had the 206 bios , and wanted to flash 207 ...

I just can`t believe Asus didn`t make somekind of fail safe boot to re upload the bios file ,my old gateway fx laptop had that !, i have a cheep Dlink router with like 20$ and even that has that feature if something goes wrong you can flash a file on it ,and now this cutting edge laptop doesn`t have this feature , you know not everything that is newer its better ... this is a good lesson.
I will send it to warranty i hope they will fix the problem , or i will have a huge paperweight ...

06-08-2015, 07:12 AM
They should fix it, they said they couldn't figure out what the real issue was so they just swapped the mobo.
There probably is a blind bios key combo, we just don't know it yet.

06-08-2015, 10:05 AM
Well i tried it more with the usb stick , if you put a stick formated as fat32 , and power on the laptop , i pushed the home button the keyboard light comes on , the fans start , and tries to reed from the usb stick , so technicaly there is some failsafe recovery but we dont have the necessary files to put on the stick , i think its just a matter of time until somebody figures it out .
I tried every bios file combination : g751jt.bin , g751jt.207 , g751.bin , g751jt.rom and the list goes on , again the stick has activity when pushing the home button like 5-10 times , but we dont have the corect files to make it work...
The good news is i tooked it back from where i bought it and tomorrow they are sending me a complete new laptop .
But im still frustrated that i dont know how to make it work if this will happen again ...

06-08-2015, 10:58 AM
Yeah, I did the same exact things. For me, the USB would always light up, not just when pressing keys.
We have quite a few months of warranty left so might as well make good use of it.

Like I said above though, they couldn't figure the issue out. Maybe a failed BIOS delete screws up whatever makes the failsafe work.

06-08-2015, 04:46 PM
Ctl + Home is be failsafe code for it to work you have to have the original G751.bin or what ever model you have *.bin on the root of your hard drive hold them down and then hit the start up button.
Reason that fail with windows 8 your not completely shutting down, IE hybrid shut down is default for window 8 and 8.1 You have to insure you are completely shutting down.

06-08-2015, 04:52 PM
Yes always there is the chance to brick your notebook when updating the BIOS this has always been true. Since UEFI more so than before. UEFI and notebooks even more so. Most to the time all goes well. Then sometime as you two have experienced all does not go well. You have to remember that BIOS= Basic In Out system the slightest thing goes wrong during update and your bricked.

06-08-2015, 09:46 PM
Ctrl+ Home method isnt working on the G751 series only on the older ones , it will be a matter of time untill someone geeker then me to figure this out .
Ctrl+ home will do no activity on this type of notebook , only if you press the power on key , and after that the home button several times , the keyboard light comes up , the fans come up , and the usb stick has activity .

06-09-2015, 03:58 PM
Are you using left or right USB ports? If the left... there are known issues with USB 3.0 standard at left side. Try the right USB ports... and maybe USB 2.0 pen drive. I don't know if it helps... but who knows?

06-09-2015, 06:53 PM
Ctl +Home only works if you have the original BIOS file on the root of your hard drive. Some have been able to Put a BIOS file on from another computer and had it work. its not a for sure thing but it is worth trying before you RMA to have repaired. Ctl + home will not work using a usb thumb drive! The ****.bin file has to be on the root of your OS drive

06-10-2015, 11:58 AM
Take it back to the store you bought it from before you run out of time and get a laptop with less issues.

06-10-2015, 12:29 PM
Ditto if your still with in the return to seller time frame.

06-11-2015, 01:56 AM
Warranty changed the laptop for me , i have another new asus g751 .
But just want to say that to all who are saying to put the .bin file to the hdd drive and then press "ctrl+ home " its not working with these series , i testd that and its not working , maybe it worked for the older series , but for these it isnt working ...