View Full Version : G74SX XC1 Trackpad not working AT ALL

12-05-2011, 06:38 PM
Hey, I'm new to the forums and I just got my first Asus laptop (G74SX XC1 as stated in title) I should also add that it has the Sentelic trackpad.

So far it's been great, I've had it for 5 days and it's been playing all of my games on max settings like I expected it to.

The issue is that the trackpad doesn't work at all. It worked last night up until I went to bed then left the computer on to download some stuff overnight then when I woke up this morning it hasn't been responsive at all, I mean it doesn't register clicks on the LR mouse buttons or my fingers on the trackpad. I've done tons of searching to find a fix, so far I've restored defaults (I disabled the gestures), updated the drivers for the trackpad and the ATK (since it can apparently fix some issues) as of yet nothing has worked.

I also read something about removing the taping on the trackpad but haven't found any details, nor would I like to do this if it voids my warranty. Also once I find a USB then I will try updating the BIOS.

Any help you could give me would be great, even if it's a link to a thread that has the same issues I do, even though the ones I've been to haven't helped yet.

Thank you!

12-05-2011, 06:45 PM
Return it to your reseller for an exchange.

12-05-2011, 07:11 PM
I just had a friend come over, with a USB :D flashed the new BIOS 203 which fixed the issue... sorry for wasting everyone's time and thank you JRd1st for taking the time to reply, I was writing Newegg, as my friend walked in the door, for an exchange

12-05-2011, 07:17 PM
Ok, glad you got it working!