PDA

View Full Version : New G74SX-A1 (Love it!) one question on video card driver update



Trijicon
12-08-2011, 07:24 PM
So I just got this G74SX-A1 and love it so far... I have none of the issues I have read about on here, just wish the sound was a bit better though. I did find and use that THX fix where you set the speakers to "external" and that seems to help it out a bit to the tune of about 10% or so more volume while playing movies and such which is nice. Although ASUS really needs to upgrade their sound system in a machine of this calibur.

Ok so to my question... I tried installing the newest driver for the GTX 560m from the NVDA website and everything went smoothly with the download and installation. However when I went to check out the system and tried to play a movie with the ROXIO CinaPlayer I got no picture, the sound came thru fine but the screen was black in that media player. I then rolled back the driver to the original driver and it worked fine.

I then read a post that had the newest BETA driver in it (290.36) and thought I would give that one a try... It uploaded just fine again but it also did the same thing to the ROXIO software where I could hear the movie playing but still had no picture for it. It would just be a black screen inside of that video player... So I rolled back the driver once again and it plays fine.

Has anyone else noticed this conflict and is there a fix for it anywhere?

Thanks much for your input.

dstrakele
12-08-2011, 07:32 PM
I'm thinking Roxio needs to update their product. Skype also is encountering issues with the latest NVIDIA drivers. See http://rog.asus.com/forum/showthread.php?5517-Latest-NVIDIA-drivers-Official-Beta-and-Modded&p=48868&viewfull=1#post48868 for more information. That's the way it is with drivers - particularly kernel mode drivers. Something new is introduced in one driver and it causes a problem in another. Then you have to wait for an update to resolve the issue.

Trijicon
12-08-2011, 07:54 PM
Thanks dstrakele :) Thats the link you posted for me yesterday where I found and tried that 290.36 driver, seems to happen with both the newest 'signed' driver and the beta driver.

I'm wondering if a new '2nd party' blu ray player software would help it out at all.

dstrakele
12-08-2011, 08:14 PM
I'd give PowerDVD 11 Ultra a trial and see if it fits the bill. IMO, it is one of the more robust Blu-Ray Players out there.

Trijicon
12-08-2011, 08:26 PM
Cool thanks, will do just that this weekend when I have the time and report back if that works with the new drivers.

Much appreciated.