View Full Version : G73J issues

12-12-2011, 07:35 PM
I have an Asus G73J laptop with an i5-450 CPU and a Radeon HD 5870 GPU. It's a bit over a year old now, and I've had quite a lot of issues.

A month or two after I bought it, I started experiencing GSODs occasionally while playing games. I couldn't find any way to fix it, and Asus' customer service (in Norway) said it wasn't a dangerous problem. So, I played with the occasional crashes for a while, until one day - around 7 months ago now - my PC broke down more permanently.

When I tried to power the PC, the screen remained black and all the lights (caps lock, num lock, etc) lit up and it didn't react to anything except for holding down the power button for 5 seconds. I did some tests (like hooking the PC up to a TV through different cables) to ensure that it wasn't a screen problem, and I'm fairly sure it wasn't.

So, I RMAed the PC. After a few weeks - three or so - I got it back. Overall, everybody involved was helpful, but the PC wasn't really fixed. The fans were running at max speed all the time, and it crashed frequently.

Thus, I had to RMA it again. This time, though, Asus seemed to treat me like some sort of criminal. I didn't receive any information, and everyone at Asus Norway just seemed to assume that I was responsible for breaking it. It wasn't a very pleasant experience at all, and it took around two months to get it back this time.

However, things weren't perfect this time either. Whenever I played a remotely heavy game, the laptop would get GSOD and crash. According to Asus Norway's support centre, nothing could be done about it. I did some more research on the subject and found the Vbios update thread on this forum (http://rog.asus.com/forum/showthread.php?519-G73Jh-GSOD-Vbios-Update). I did that, and for a month and a half or so, everything seemed perfect. I could play any games, and performance was far better than I'd ever experienced with this laptop before.

But that ended today. When I started the PC today, I was unable to change the resolution above the setting above 1024x768 (1152x864 or something like that was the max). Usually, the max resolution is 1600x900, the only exception being when I've uninstalled the graphics card drivers to install some new. So, I figured it might be a driver related issue, but restarted the laptop to see if it fixed itself. And it did - everything started normally - so I figured it wasn't that much of a problem.

It was, though. While playing Skyrim, I got a GSOD and pressed down the power button for 5 seconds to turn it off. When I then tried to turn it back on again, the problem from a few months ago was back. When I try to turn on the laptop, the screen turns black and doesn't react to anything. The fan turns to max speed, and the screen keeps being black and the fan at max speed until I turn it off.

I'm not quite sure what to do now. There's little point in me talking to the Asus Norway customer support, as they've never actually been able to suggest anything to help before. If I RMA it again, there's no guarantee this problem won't pop up again, considering it's happened twice in half a year now. RMAing it will also mean that it'll most likely be gone for two months and might come back with completely new errors.

Do I have any other options? Is RMAing it the only one, or could I do something to repair it (without breaking the warranty) myself? Is there anything I can do to prevent this problem for reappearing when I get it back?

I really have no idea what to do now, and I'm not even completely sure this is the right place to post this - so any help is appreciated.

Thanks in advance, Oyvoyv.