View Full Version : Intel ETU service cannot be installed

06-25-2015, 04:02 PM
Hi everyone, I have just purchased an Asus G751 and used Backtracker to migrate everything to SSD and everything has gone perfectly. However windows update managed to sneak this past me :

Intel - Other hardware - Intel(R) Extreme Tuning Utility Device Driver

Installation date: ‎25/‎06/‎2015 18:10

Installation status: Succeeded

Update type: Optional

Intel Other hardware software update released in February, 2015

This is (I presume) is the reason Intel ETU wont install, please see the image for details of the problem. This has started to drive me crazy, so any help is much appreciated.



06-26-2015, 01:20 PM
No one has any ideas?

06-26-2015, 01:32 PM
take the last one from intel...?! or install it from path manually with admin rights.

06-26-2015, 01:56 PM
Try downloading from here: https://downloadcenter.intel.com/search?keyword=xtu

Could be the Asus version is out of date.

06-26-2015, 03:37 PM
Thanks for the replies,

I have tried these options but the same issue continues, I just cant think what might be causing this. I thought I knew my way around Windows but I have been proven wrong :(

06-26-2015, 04:46 PM
in devicemanager evrything fine? netframework installed? intel managment engine interface correct installed? its need to enable firewall...

06-26-2015, 07:14 PM
Hi Warryabel,

No problems in device manager. I thought .NET framework was part of Win 8.1 and confirmed this when i tried to install a few minutes ago. The management engine is listed as installed.

I simply have no idea what to do.

06-26-2015, 07:38 PM
what is with firewall try to enable defender or defender then try to install!