PDA

View Full Version : is this a G551jm design flaw with the keyboard backlight not working at login page?



Darshan
06-26-2015, 03:37 PM
got my G551jm just a month back. I have observed something just within 2 days after getting my laptop. The keyboard backlit doesnt get illuminated unless i login to laptop. now this is strange. Cos even to enter my password i need keyboard backlit, and unless i put password and login, the backlit doesnt start working.
Does anyone have any feedback on this?

OCFreak
06-26-2015, 06:30 PM
That is normal. Most if not all recent laptops I've had doesn't turn backligh on before after login. Quite annoying, but so far I've not found any workaround.

joshindaphils
06-26-2015, 06:56 PM
The g751 does not have this behavior so I can't help you out here.. I imagine that there is an app running at login to control the backlight.

You may have luck identifying this app then using SC or NSSM to launch it as a service, there are drawback to this i.e. if you want to interact with the app you would need to stop the service then launch it in the userland.

NSSM: http://nssm.cc/
SC: https://support.microsoft.com/en-us/kb/251192

Set the service you create to launch at boot and you can have your back lights before login assuming the app doesn't throw a fit (there still will be some delay after boot).

There are other ways of doing this, the above is perhaps the most accessible.

BestiaAgnostica
07-31-2015, 05:36 AM
Hi guys,

Has anyone found a solution for this??
It is really annoying, since most of the time i would use my laptop on low-light conditions, and i have to look for my phone or something similar to illuminate the keyboard... This should be on even during boot-up/bios... but i cant seem to find the option
Any ideas?

DJEmir
08-20-2015, 08:35 AM
Very frustrating when trying to log into the computer in low light situations. This is exactly the reason I have come into this forum... same exact problem it doesn't light up until after I log In. Once I log Into windows I can use the Function key and f3 and f4 to control the backlight brightness. But until then the keyboard is dark and in the dark it's a problem because the color they chose doesn't have enough contrast so I can't even see what I'm typing to log in and need my phone or other external light to see what I'm typing. The default should be on not off at the beggining.

BestiaAgnostica
08-20-2015, 09:38 PM
Guys,

I think i found a workaround.. its really working but now i believe its doing some funny stuff... maybe you can give it a try and confirm what i am seeing

The solution was basically as stated by @Joshindaphils , to force the service to run at start up, however i used Task Scheduler as recommended on this post: http://forum.notebookreview.com/threads/keyboard-light-fix-gary-key.513264/page-10

Location: C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey\HControl.exe

After doing the above, it started working however i noticed:
Backlit on login screen will take from 5 to 10 secs to kick in, but it does
Keyboard will turn backlit off soon after login in, but it gets easily fixed after pressing the function key. I believe this has to do with the fact that now 2 Hcontrol processes are running, got to test this, disable one and confirm
Start up and shutdown processes seem to take longer now, but this maybe a mere perception, please check if you experience the same

Hope i helps
Cheers

mariockr
03-22-2016, 06:57 AM
Guys,

I think i found a workaround.. its really working but now i believe its doing some funny stuff... maybe you can give it a try and confirm what i am seeing

The solution was basically as stated by @Joshindaphils , to force the service to run at start up, however i used Task Scheduler as recommended on this post: http://forum.notebookreview.com/threads/keyboard-light-fix-gary-key.513264/page-10

Location: C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey\HControl.exe

After doing the above, it started working however i noticed:
Backlit on login screen will take from 5 to 10 secs to kick in, but it does
Keyboard will turn backlit off soon after login in, but it gets easily fixed after pressing the function key. I believe this has to do with the fact that now 2 Hcontrol processes are running, got to test this, disable one and confirm
Start up and shutdown processes seem to take longer now, but this maybe a mere perception, please check if you experience the same

Hope i helps
Cheers

I use this solution but ad one option in task properties: "Stop the task if it runs longer than - 1 minute", now only one copy of HControl is running and everything works correct.

BestiaAgnostica
03-22-2016, 09:57 PM
I use this solution but ad one option in task properties: "Stop the task if it runs longer than - 1 minute", now only one copy of HControl is running and everything works correct.

Nice! I will totally give it a try!
It still fails to light up the keyboard sometimes at strat up.... not sure why

I'm dealing with two different issues at this point, now
1. The screen will turn to "warmer" colors... and its annoying, i haven't been able to find what is doing it
2. The trackpad gestures are not really working, or they take like 10min to kick in....

JustinThyme
03-22-2016, 11:29 PM
The G752VY was doing the same thing until the last ATK package update. As soon as I installed that the lights come up so you can see to log in.

maf23
03-23-2016, 12:30 AM
GL552VW lights up prior to login with the new ATK driver as well, but you have to get it from the 752 model driver page. ASUS never put it on the GL552 driver download page. The version you need is: ATKPackage_Win10_64_VER100042. Works for Win 7 64 bit as well.

jrbdmb
03-23-2016, 11:37 AM
Found the driver under downloads for the G752VY. Interesting that it is *not* listed for the GL552 or GL752, even though I am hitting the exact same issue for my new GL552VW.

Thanks for the info.

mariockr
03-23-2016, 08:44 PM
GL552VW lights up prior to login with the new ATK driver as well, but you have to get it from the 752 model driver page. ASUS never put it on the GL552 driver download page. The version you need is: ATKPackage_Win10_64_VER100042. Works for Win 7 64 bit as well.

Thanks, this version of ATK also works with my g551jm.