PDA

View Full Version : Is my G751JT-CH71 faulty?



RainbowDash
07-15-2015, 03:41 PM
I'm having some problems. one it seems really slow. even for a HDD. I even uninstalled all the garbage that came with it and nothing. it isn't horrible but it takes a while still. I downloaded the crystal disk program and it says the drive is good.

I got this last week. BRAND new.

2 I think my wireless card is faulty.


at home when I first got it I had maybe DL problems. My max speed was around 900kbps. out of my max of 8mbps.

now at work the connection is att so it sucks but it still is 2mbps and should MORE then enough to play LOL. every game I get horrible pings. last game I hit a 7000 ping.

I haven't been able to games at home though yet.

I don't play anything besides LOL. but I can sometimes see the impact on regular internet. but doing a speed test it does hit the max of 2mbps.

also I basically just use it at work since I already have a pc at home and have no need for it there.

Jlieu
07-15-2015, 04:03 PM
Fresh install a windows Will solve the problem. G751 should come with SSD which is incredibly fast. Some process might have been running behind to pull everything down. FIRST THING IS ANTIVIRUS program, make sure only one antivirus is installed and Bitdefender or kaspersky only is recommended. Check carefully.

RainbowDash
07-15-2015, 04:41 PM
Fresh install a windows Will solve the problem. G751 should come with SSD which is incredibly fast. Some process might have been running behind to pull everything down. FIRST THING IS ANTIVIRUS program, make sure only one antivirus is installed and Bitdefender or kaspersky only is recommended. Check carefully. no ssd came with it. And that doesn't answer the more important problem. The network card.