PDA

View Full Version : Screen brightness flickers, my FPS drops, my 3DMarks scores are way down!



JavierH
07-19-2015, 09:36 PM
Something's going on with my ROG 750JZ.

It used to work OK, but lately I've noticed I lose brightness every now and then (screen drops its brightness) and FPS drop by half.

I tested my laptop using 3DMark and my scores lost at least 25% from what they used to be.

I've updated the Bios, the VBios, and I've turned on and off GPU Tweak, the problem is still therem.

I reinstalled the whole laptop and it still has the same issue.

Does anyone has he same problem?

(BTW I already checked the power settings and everything is set to max performance).

JavierH
07-19-2015, 11:53 PM
Wow, someone else seems to have this issue.

https://rog.asus.com/forum/showthread.php?37037-Please-help-major-fps-drops-causing-display-to-dim-while-plugged-in

And this.

https://rog.asus.com/forum/showthread.php?62387-Asus-ROG-G750JZ-Toggles-from-AC-Battery-mode-in-some-Games

And yes indeed, if I unplug my laptop, FPS drops exactly the same as what I'm looking at. It's the same issue.

vicmns
07-21-2015, 10:15 PM
Hi JavierH, I'm the author of the post https://rog.asus.com/forum/showthread.php?62387-Asus-ROG-G750JZ-Toggles-from-AC-Battery-mode-in-some-Games

I have already taken the laptop to service twice this month. The first time they changed the motherboard and battery, but after it came back I immediately made some GPU benchmarks (Resident Evil 6, 3D Mark, etc), and the problem still persist (Battery indicator going off/on, screen brightness going up/down, and of course, without the battery the system just shuts down...) so I sent it back this week . After this I'm pretty sure this is an architecture problem, since they change all the motherboard, which I asume includes the GPU, so problems related within this hardware are discarded.

Right now I don't know what to expect, I really hope that at least I can get a different system... I don't care if it's a new model or not; I just want to play some games, since that's why I bought it...

Well, if you still have the warranty, don't hesitate and send it to repair services. I recommend to record the problem, with and without the battery and when you get your RMA, send and email with them. So they can pinpoint te problem easily.

Hope that at least they can fix your problem.

Best of luck and keep gaming!

JavierH
07-22-2015, 01:16 PM
Hi JavierH, I'm the author of the post https://rog.asus.com/forum/showthread.php?62387-Asus-ROG-G750JZ-Toggles-from-AC-Battery-mode-in-some-Games

I have already taken the laptop to service twice this month. The first time they changed the motherboard and battery, but after it came back I immediately made some GPU benchmarks (Resident Evil 6, 3D Mark, etc), and the problem still persist (Battery indicator going off/on, screen brightness going up/down, and of course, without the battery the system just shuts down...) so I sent it back this week . After this I'm pretty sure this is an architecture problem, since they change all the motherboard, which I asume includes the GPU, so problems related within this hardware are discarded.

Right now I don't know what to expect, I really hope that at least I can get a different system... I don't care if it's a new model or not; I just want to play some games, since that's why I bought it...

Well, if you still have the warranty, don't hesitate and send it to repair services. I recommend to record the problem, with and without the battery and when you get your RMA, send and email with them. So they can pinpoint te problem easily.

Hope that at least they can fix your problem.

Best of luck and keep gaming!

Thank you for your message! I was wondering if you had fixed your issue. I'll look for the receipt and send it back. It should be easy to prove that it has an issue, I'll just run 3DMarks wihout a battery and have them see how it shuts itself off. Living in Mexico, I wonder what they'll do about it (we don't get as many warranty perks as people in the US).

I'm surprised not many more people have this issue. It's definitely something about the machine. Is the power supply not powerful enough? I don't know. All I know is, my laptop worked fine for about 3 months before it started doing this.

I'll also write ASUS, hope this is an issue that can be fixed via BIOS. I'm surprised it's not that widespread, since 3 or 4 laptops doing the same thing may mean every single one is susceptible to this failure.

vicmns
07-22-2015, 03:53 PM
I'm also from Mexico, just look for the receipt and call the 800 number (option 1). Try to explain well the problem to the lady/guy, that the problem also happens within games, also make emphasis on the fact that it shuts down without battery. After that they'll email you the RMA and a DHL tracking number since they have to collect it in order to send it back to the workshop.

And yes I agree with you, this kind of behaviour is totally rare; and if is happening on 3 different machines, it should happen with all the other machines.

Let's hope that they can pinpoint the problem easily now that they will have other machine to test on.

JavierH
09-13-2015, 10:51 PM
I don't have the receipt, so that's not an option for me. I got my machine as a gift.

I have found something else, though.

This happens when the battery is discharged, or less than 100%. What happens is, the system tries to charge the battery AND use the Nvidia card, the fans, etc. It seems to me the power supply is overworked and then everything shuts down - and the system starts running off the battery. So weird.

I'll contact ASUS tomorrow. I have tried before but I spent 30 minutes waiting for someone to answer my call.